summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-09-29 23:08:20 +0000
committerMike Frysinger <vapier@gentoo.org>2006-09-29 23:08:20 +0000
commit7065f7fd5d074858023fbd4434d744110c151bcb (patch)
tree5d3b22ef30d25499ae6df85aec3bc1f9d40cf26c /sys-libs/glibc/glibc-2.4-r3.ebuild
parentNew upstream version. (diff)
downloadgentoo-2-7065f7fd5d074858023fbd4434d744110c151bcb.tar.gz
gentoo-2-7065f7fd5d074858023fbd4434d744110c151bcb.tar.bz2
gentoo-2-7065f7fd5d074858023fbd4434d744110c151bcb.zip
allow people to use -foo_softfloat- for softfloat targets
(Portage version: 2.1.2_pre1-r1)
Diffstat (limited to 'sys-libs/glibc/glibc-2.4-r3.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.4-r3.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-2.4-r3.ebuild b/sys-libs/glibc/glibc-2.4-r3.ebuild
index 959d809371d2..52d99d3000be 100644
--- a/sys-libs/glibc/glibc-2.4-r3.ebuild
+++ b/sys-libs/glibc/glibc-2.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.4-r3.ebuild,v 1.24 2006/09/29 21:40:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.4-r3.ebuild,v 1.25 2006/09/29 23:08:20 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -871,7 +871,7 @@ glibc_do_configure() {
use glibc-omitfp && myconf="${myconf} --enable-omitfp"
- [[ ${CTARGET} == *-softfloat-* ]] && myconf="${myconf} --without-fp"
+ [[ ${CTARGET//_/-} == *-softfloat-* ]] && myconf="${myconf} --without-fp"
if [[ $1 == "linuxthreads" ]] ; then
if want_tls ; then