summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-05-14 09:31:15 +0000
committerHanno Böck <hanno@gentoo.org>2008-05-14 09:31:15 +0000
commit4bfef71c9ef97e0fbd76c24b075a2ac1582cd36a (patch)
treed1bee20b4c84d884c7dae0bc8111535ae5e18a63 /sys-libs/gwenhywfar
parentremove old gwenhywfar ebuild (diff)
downloadgentoo-2-4bfef71c9ef97e0fbd76c24b075a2ac1582cd36a.tar.gz
gentoo-2-4bfef71c9ef97e0fbd76c24b075a2ac1582cd36a.tar.bz2
gentoo-2-4bfef71c9ef97e0fbd76c24b075a2ac1582cd36a.zip
gwenhywfar: doxygen is only a build-dep, not runtime
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'sys-libs/gwenhywfar')
-rw-r--r--sys-libs/gwenhywfar/ChangeLog6
-rw-r--r--sys-libs/gwenhywfar/gwenhywfar-2.6.1.ebuild15
-rw-r--r--sys-libs/gwenhywfar/gwenhywfar-2.6.2.ebuild7
3 files changed, 17 insertions, 11 deletions
diff --git a/sys-libs/gwenhywfar/ChangeLog b/sys-libs/gwenhywfar/ChangeLog
index 57b28efc5d89..3ffe3d176d6d 100644
--- a/sys-libs/gwenhywfar/ChangeLog
+++ b/sys-libs/gwenhywfar/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/gwenhywfar
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.52 2008/02/05 16:34:33 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.53 2008/05/14 09:31:15 hanno Exp $
+
+ 14 May 2008; Hanno Boeck <hanno@gentoo.org> gwenhywfar-2.6.1.ebuild,
+ gwenhywfar-2.6.2.ebuild:
+ doxygen is only a build-time dependency.
05 Feb 2008; Markus Rothe <corsair@gentoo.org> gwenhywfar-2.6.2.ebuild:
Added ~ppc64; fix dependencies for app-office/kmymoney2
diff --git a/sys-libs/gwenhywfar/gwenhywfar-2.6.1.ebuild b/sys-libs/gwenhywfar/gwenhywfar-2.6.1.ebuild
index 33e55b8dd596..d7577d16b6ba 100644
--- a/sys-libs/gwenhywfar/gwenhywfar-2.6.1.ebuild
+++ b/sys-libs/gwenhywfar/gwenhywfar-2.6.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-2.6.1.ebuild,v 1.6 2007/11/16 00:25:33 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-2.6.1.ebuild,v 1.7 2008/05/14 09:31:15 hanno Exp $
DESCRIPTION="A multi-platform helper library for other libraries"
HOMEPAGE="http://gwenhywfar.sourceforge.net"
@@ -11,10 +11,11 @@ KEYWORDS="amd64 ~hppa ppc sparc x86"
IUSE="debug ssl doc ncurses"
-DEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
sys-libs/ncurses
- doc? ( app-doc/doxygen )
ncurses? ( sys-libs/ncurses )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
src_compile() {
econf \
@@ -22,7 +23,7 @@ src_compile() {
$(use_enable debug) \
$(use_enable doc full-doc) \
$(use_enable ncurses gwenui) \
- --with-docpath=/usr/share/doc/${PF}/apidoc || die "configure failed"
+ --with-docpath="/usr/share/doc/${PF}/apidoc" || die "configure failed"
emake || die "emake failed"
if use doc ; then
emake srcdoc || die "emake failed"
@@ -31,8 +32,8 @@ src_compile() {
src_install() {
einstall || die
- dodoc README* AUTHORS ChangeLog TODO || die
+ dodoc README* AUTHORS ChangeLog TODO || die "dodoc failed"
if use doc ; then
- make DESTDIR="${D}" install-srcdoc || die "make isntall-srcdoc failed"
+ make DESTDIR="${D}" install-srcdoc || die "install doc failed"
fi
}
diff --git a/sys-libs/gwenhywfar/gwenhywfar-2.6.2.ebuild b/sys-libs/gwenhywfar/gwenhywfar-2.6.2.ebuild
index 6c111099d019..7d414cf4772d 100644
--- a/sys-libs/gwenhywfar/gwenhywfar-2.6.2.ebuild
+++ b/sys-libs/gwenhywfar/gwenhywfar-2.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-2.6.2.ebuild,v 1.2 2008/02/05 16:34:33 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-2.6.2.ebuild,v 1.3 2008/05/14 09:31:15 hanno Exp $
DESCRIPTION="A multi-platform helper library for other libraries"
HOMEPAGE="http://gwenhywfar.sourceforge.net"
@@ -11,10 +11,11 @@ KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE="debug ssl doc ncurses"
-DEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
+RDEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
sys-libs/ncurses
- doc? ( app-doc/doxygen )
ncurses? ( sys-libs/ncurses )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
src_compile() {
econf \