summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-03-13 22:36:40 +0000
committerMike Frysinger <vapier@gentoo.org>2014-03-13 22:36:40 +0000
commit5a9ae752cc77f316df953f4ec8cfcee261b8c175 (patch)
treefef290b7f13d099d3d16eae076509d58a00a0ec0 /sys-libs/libaal
parentRevision bump installs bash completion script to the correct location by Samu... (diff)
downloadgentoo-2-5a9ae752cc77f316df953f4ec8cfcee261b8c175.tar.gz
gentoo-2-5a9ae752cc77f316df953f4ec8cfcee261b8c175.tar.bz2
gentoo-2-5a9ae752cc77f316df953f4ec8cfcee261b8c175.zip
Upgrade to EAPI=4 and rewrite the whole ebuild in the process.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-libs/libaal')
-rw-r--r--sys-libs/libaal/ChangeLog9
-rw-r--r--sys-libs/libaal/libaal-1.0.5-r1.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/sys-libs/libaal/ChangeLog b/sys-libs/libaal/ChangeLog
index d9fb1e7dd76d..55503ddb2932 100644
--- a/sys-libs/libaal/ChangeLog
+++ b/sys-libs/libaal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libaal
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libaal/ChangeLog,v 1.20 2008/05/31 17:35:39 vapier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libaal/ChangeLog,v 1.21 2014/03/13 22:36:40 vapier Exp $
+
+*libaal-1.0.5-r1 (13 Mar 2014)
+
+ 13 Mar 2014; Mike Frysinger <vapier@gentoo.org> +libaal-1.0.5-r1.ebuild:
+ Upgrade to EAPI=4 and rewrite the whole ebuild in the process.
31 May 2008; Mike Frysinger <vapier@gentoo.org> libaal-1.0.5.ebuild:
Add arm love #203718 by Shvetsov Alexey.
diff --git a/sys-libs/libaal/libaal-1.0.5-r1.ebuild b/sys-libs/libaal/libaal-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..2fc9c85cc05d
--- /dev/null
+++ b/sys-libs/libaal/libaal-1.0.5-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libaal/libaal-1.0.5-r1.ebuild,v 1.1 2014/03/13 22:36:40 vapier Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="library required by reiser4progs"
+HOMEPAGE="https://sourceforge.net/projects/reiser4/"
+SRC_URI="mirror://sourceforge/reiser4/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 -sparc ~x86"
+IUSE="static-libs"
+
+src_prepare() {
+ # remove stupid CFLAG hardcodes
+ sed -i \
+ -e "/GENERIC_CFLAGS/s:-O3::" \
+ -e "/^CFLAGS=/s:\"\":\"${CFLAGS}\":" \
+ configure || die "sed"
+ printf '#!/bin/sh\n:\n' > run-ldconfig
+}
+
+src_configure() {
+ econf \
+ --enable-libminimal \
+ --enable-memory-manager \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ gen_usr_ldscript -a aal{,-minimal}
+}