summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-10-27 12:19:56 +0000
committerPacho Ramos <pacho@gentoo.org>2012-10-27 12:19:56 +0000
commit33743b0892bd55f1c5624dc57e901a3e2ea22406 (patch)
tree71e983d9bd371e475f2b2192fba699ccf85cae4e /sys-libs/libosinfo
parentRemoved message about network interface requirement. (diff)
downloadgentoo-2-33743b0892bd55f1c5624dc57e901a3e2ea22406.tar.gz
gentoo-2-33743b0892bd55f1c5624dc57e901a3e2ea22406.tar.bz2
gentoo-2-33743b0892bd55f1c5624dc57e901a3e2ea22406.zip
Version bump, drop old.
(Portage version: 2.1.11.30/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'sys-libs/libosinfo')
-rw-r--r--sys-libs/libosinfo/ChangeLog8
-rw-r--r--sys-libs/libosinfo/libosinfo-0.2.1.ebuild (renamed from sys-libs/libosinfo/libosinfo-0.1.2.ebuild)23
2 files changed, 19 insertions, 12 deletions
diff --git a/sys-libs/libosinfo/ChangeLog b/sys-libs/libosinfo/ChangeLog
index c6b25cc77123..bb7e1572b2f6 100644
--- a/sys-libs/libosinfo/ChangeLog
+++ b/sys-libs/libosinfo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libosinfo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libosinfo/ChangeLog,v 1.12 2012/09/16 00:58:19 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libosinfo/ChangeLog,v 1.13 2012/10/27 12:19:56 pacho Exp $
+
+*libosinfo-0.2.1 (27 Oct 2012)
+
+ 27 Oct 2012; Pacho Ramos <pacho@gentoo.org> +libosinfo-0.2.1.ebuild,
+ -libosinfo-0.1.2.ebuild:
+ Version bump, drop old.
16 Sep 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
libosinfo-0.2.0.ebuild:
diff --git a/sys-libs/libosinfo/libosinfo-0.1.2.ebuild b/sys-libs/libosinfo/libosinfo-0.2.1.ebuild
index 3e59a6728a94..47400d0edb6d 100644
--- a/sys-libs/libosinfo/libosinfo-0.1.2.ebuild
+++ b/sys-libs/libosinfo/libosinfo-0.2.1.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libosinfo/libosinfo-0.1.2.ebuild,v 1.4 2012/08/14 09:25:45 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libosinfo/libosinfo-0.2.1.ebuild,v 1.1 2012/10/27 12:19:56 pacho Exp $
EAPI=4
-inherit eutils toolchain-funcs
+VALA_MIN_API_VERSION="0.16"
+VALA_USE_DEPEND="vapigen"
-PN_VALA_SLOT=0.16
+inherit eutils toolchain-funcs vala
DESCRIPTION="GObject library for managing information about real and virtual OSes"
HOMEPAGE="http://fedorahosted.org/libosinfo/"
@@ -14,34 +15,34 @@ SRC_URI="http://fedorahosted.org/releases/${PN:0:1}/${PN:1:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc +introspection +vala test"
+IUSE="+introspection +vala test"
REQUIRED_USE="vala? ( introspection )"
-RDEPEND=">=dev-libs/glib-2
+RDEPEND=">=dev-libs/glib-2:2
+ >=dev-libs/libxslt-1.0.0
dev-libs/libxml2
net-libs/libsoup:2.4
net-libs/libsoup-gnome:2.4
introspection? ( >=dev-libs/gobject-introspection-0.9.0 )"
DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
virtual/pkgconfig
- doc? ( >=dev-util/gtk-doc-1.10 )
test? ( dev-libs/check )
- vala? ( dev-lang/vala:${PN_VALA_SLOT}[vapigen] )"
+ vala? ( $(vala_depend) )"
-DOCS="AUTHORS ChangeLog NEWS README"
+src_prepare() {
+ use vala && vala_src_prepare
+}
src_configure() {
local udevdir=/lib/udev
has_version sys-fs/udev && udevdir="$($(tc-getPKG_CONFIG) --variable=udevdir udev)"
- export VAPIGEN="$(type -P vapigen-${PN_VALA_SLOT})"
-
# --enable-udev is only for rules.d file install
econf \
--disable-static \
--disable-silent-rules \
- $(use_enable doc gtk-doc) \
$(use_enable test tests) \
$(use_enable introspection) \
$(use_enable vala) \