summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2015-02-04 17:46:44 +0000
committerJason Zaman <perfinion@gentoo.org>2015-02-04 17:46:44 +0000
commit3e0ea2d53cc4fa5d6a025bfa5ac321e99a3c0d2b (patch)
treebf97a80731cbd63704abdef0699440548c20d86a /sys-libs/libsepol
parentAdd libinput flag and dependency (diff)
downloadgentoo-2-3e0ea2d53cc4fa5d6a025bfa5ac321e99a3c0d2b.tar.gz
gentoo-2-3e0ea2d53cc4fa5d6a025bfa5ac321e99a3c0d2b.tar.bz2
gentoo-2-3e0ea2d53cc4fa5d6a025bfa5ac321e99a3c0d2b.zip
Version bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x7EF137EC935B0EAF)
Diffstat (limited to 'sys-libs/libsepol')
-rw-r--r--sys-libs/libsepol/ChangeLog9
-rw-r--r--sys-libs/libsepol/libsepol-2.4.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/sys-libs/libsepol/ChangeLog b/sys-libs/libsepol/ChangeLog
index 8fe6c1edfca9..6cb200ab006f 100644
--- a/sys-libs/libsepol/ChangeLog
+++ b/sys-libs/libsepol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libsepol
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.72 2014/12/06 23:19:21 perfinion Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/ChangeLog,v 1.73 2015/02/04 17:46:44 perfinion Exp $
+
+*libsepol-2.4 (04 Feb 2015)
+
+ 04 Feb 2015; Jason Zaman <perfinion@gentoo.org> +libsepol-2.4.ebuild:
+ Version bump
*libsepol-2.4_rc7 (06 Dec 2014)
diff --git a/sys-libs/libsepol/libsepol-2.4.ebuild b/sys-libs/libsepol/libsepol-2.4.ebuild
new file mode 100644
index 000000000000..46932676204e
--- /dev/null
+++ b/sys-libs/libsepol/libsepol-2.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsepol/libsepol-2.4.ebuild,v 1.1 2015/02/04 17:46:44 perfinion Exp $
+
+EAPI="5"
+
+inherit multilib toolchain-funcs eutils multilib-minimal
+
+MY_P="${P//_/-}"
+
+DESCRIPTION="SELinux binary policy representation library"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
+SRC_URI="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20150202/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+# tests are not meant to be run outside of the
+# full SELinux userland repo
+RESTRICT="test"
+
+src_prepare() {
+ epatch_user
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ tc-export RANLIB;
+ LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)"
+}
+
+multilib_src_install() {
+ LIBDIR="\$(PREFIX)/$(get_libdir)" SHLIBDIR="\$(DESTDIR)/$(get_libdir)" \
+ emake DESTDIR="${D}" install
+}