summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-06-30 09:05:36 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-06-30 09:05:36 +0000
commitfe84d182cc72f296a7c6b94df61630c17a15af9a (patch)
tree6965b752753a41d1f6f310edf84342ec26b4e455 /sys-libs/musl
parentStabilize on amd64 and x86, in tree for >30 days and works fine. (diff)
downloadgentoo-2-fe84d182cc72f296a7c6b94df61630c17a15af9a.tar.gz
gentoo-2-fe84d182cc72f296a7c6b94df61630c17a15af9a.tar.bz2
gentoo-2-fe84d182cc72f296a7c6b94df61630c17a15af9a.zip
Version bump
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-libs/musl')
-rw-r--r--sys-libs/musl/ChangeLog8
-rw-r--r--sys-libs/musl/metadata.xml6
-rw-r--r--sys-libs/musl/musl-0.9.11.ebuild90
3 files changed, 100 insertions, 4 deletions
diff --git a/sys-libs/musl/ChangeLog b/sys-libs/musl/ChangeLog
index 226e1b186e78..1d2f1890f286 100644
--- a/sys-libs/musl/ChangeLog
+++ b/sys-libs/musl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/musl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/ChangeLog,v 1.7 2013/06/13 19:57:01 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/ChangeLog,v 1.8 2013/06/30 09:05:36 blueness Exp $
+
+*musl-0.9.11 (30 Jun 2013)
+
+ 30 Jun 2013; Anthony G. Basile <blueness@gentoo.org> +musl-0.9.11.ebuild,
+ metadata.xml:
+ Version bump
13 Jun 2013; Anthony G. Basile <blueness@gentoo.org> -musl-0.9.9.ebuild,
musl-0.9.10.ebuild, musl-9999.ebuild:
diff --git a/sys-libs/musl/metadata.xml b/sys-libs/musl/metadata.xml
index 3f6b0120e02c..733d904a9f88 100644
--- a/sys-libs/musl/metadata.xml
+++ b/sys-libs/musl/metadata.xml
@@ -3,10 +3,10 @@
<pkgmetadata>
<herd>toolchain</herd>
<maintainer>
- <email>lu_zero@gentoo.org</email>
- </maintainer>
- <maintainer>
<email>blueness@gentoo.org</email>
<name>Anthony G. Basile</name>
</maintainer>
+ <maintainer>
+ <email>lu_zero@gentoo.org</email>
+ </maintainer>
</pkgmetadata>
diff --git a/sys-libs/musl/musl-0.9.11.ebuild b/sys-libs/musl/musl-0.9.11.ebuild
new file mode 100644
index 000000000000..6b6259558d7b
--- /dev/null
+++ b/sys-libs/musl/musl-0.9.11.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/musl-0.9.11.ebuild,v 1.1 2013/06/30 09:05:36 blueness Exp $
+
+EAPI=4
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.musl-libc.org/musl"
+ inherit git-2
+fi
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+DESCRIPTION="Lightweight, fast and simple C library focused on standards-conformance and safety"
+HOMEPAGE="http://www.musl-libc.org/"
+if [[ ${PV} != "9999" ]] ; then
+ PATCH_VER=""
+ SRC_URI="http://www.musl-libc.org/releases/${P}.tar.gz"
+ KEYWORDS="-* ~amd64 ~arm ~mips"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="crosscompile_opts_headers-only"
+
+is_crosscompile() {
+ [[ ${CHOST} != ${CTARGET} ]]
+}
+
+just_headers() {
+ use crosscompile_opts_headers-only && is_crosscompile
+}
+
+pkg_setup() {
+ if [ ${CTARGET} == ${CHOST} ] ; then
+ case ${CHOST} in
+ *-musl*) ;;
+ *) die "Use sys-devel/crossdev to build a musl toolchain" ;;
+ esac
+ fi
+}
+
+src_configure() {
+ tc-export CC
+
+ ./configure \
+ --target="${CTARGET}" \
+ --prefix="/usr" \
+ --disable-gcc-wrapper
+}
+
+src_compile() {
+ emake include/bits/alltypes.h || die
+ just_headers && return 0
+
+ emake || die
+}
+
+src_install() {
+ local sysroot=${D}
+ is_crosscompile && sysroot+="/usr/${CTARGET}"
+
+ local target="install"
+ just_headers && target="install-headers"
+ emake DESTDIR="${sysroot}" ${target} || die
+
+ # Make sure we install the sys-include symlink so that when
+ # we build a 2nd stage cross-compiler, gcc finds the target
+ # system headers correctly. See gcc/doc/gccinstall.info
+ if is_crosscompile ; then
+ dosym usr/include /usr/${CTARGET}/sys-include
+ fi
+}
+
+pkg_postinst() {
+ is_crosscompile && return 0
+
+ [ "${ROOT}" != "/" ] && return 0
+ # update cache before reloading init
+ ldconfig
+ # reload init ...
+ /sbin/telinit U 2>/dev/null
+}