summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-11-22 08:33:28 +0000
committerMike Frysinger <vapier@gentoo.org>2009-11-22 08:33:28 +0000
commiteca18d8f897fe250f16216fd8be121029301d2b7 (patch)
tree84a454fbbe13a26bf266660428111c18cd361789 /sys-libs/ncurses/ncurses-5.7-r3.ebuild
parentVersion bump, bug #293661 (diff)
downloadgentoo-2-eca18d8f897fe250f16216fd8be121029301d2b7.tar.gz
gentoo-2-eca18d8f897fe250f16216fd8be121029301d2b7.tar.bz2
gentoo-2-eca18d8f897fe250f16216fd8be121029301d2b7.zip
Optimize cross compile step if host version already matches.
(Portage version: 2.2_rc51/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/ncurses/ncurses-5.7-r3.ebuild')
-rw-r--r--sys-libs/ncurses/ncurses-5.7-r3.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-libs/ncurses/ncurses-5.7-r3.ebuild b/sys-libs/ncurses/ncurses-5.7-r3.ebuild
index 0457e1aa4daf..913d20546ea9 100644
--- a/sys-libs/ncurses/ncurses-5.7-r3.ebuild
+++ b/sys-libs/ncurses/ncurses-5.7-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.7-r3.ebuild,v 1.1 2009/10/28 12:18:12 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.7-r3.ebuild,v 1.2 2009/11/22 08:33:28 vapier Exp $
EAPI="1"
inherit eutils flag-o-matic toolchain-funcs
@@ -43,7 +43,7 @@ src_compile() {
# when cross-compiling, we need to build up our own tic
# because people often don't keep matching host/target
# ncurses versions #249363
- if tc-is-cross-compiler ; then
+ if tc-is-cross-compiler && ! ROOT=/ has_version ~sys-libs/${P} ; then
make_flags="-C progs tic"
CHOST=${CBUILD} \
CFLAGS=${BUILD_CFLAGS} \