summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2003-08-01 13:17:11 +0000
committerAron Griffis <agriffis@gentoo.org>2003-08-01 13:17:11 +0000
commitb27a50349a7061fea53e0464670d809686917384 (patch)
treebe98a2312b98b3065292176d9a2b6de62bc2f2a0 /sys-libs/ncurses
parentfix bug 18486: add xterm-debian (diff)
downloadgentoo-2-b27a50349a7061fea53e0464670d809686917384.tar.gz
gentoo-2-b27a50349a7061fea53e0464670d809686917384.tar.bz2
gentoo-2-b27a50349a7061fea53e0464670d809686917384.zip
fix bug 18486: add xterm-debian
Diffstat (limited to 'sys-libs/ncurses')
-rw-r--r--sys-libs/ncurses/ChangeLog8
-rw-r--r--sys-libs/ncurses/Manifest4
-rw-r--r--sys-libs/ncurses/files/digest-ncurses-5.3-r31
-rw-r--r--sys-libs/ncurses/files/xterm-debian.ti7
-rw-r--r--sys-libs/ncurses/ncurses-5.3-r3.ebuild97
5 files changed, 114 insertions, 3 deletions
diff --git a/sys-libs/ncurses/ChangeLog b/sys-libs/ncurses/ChangeLog
index 34f1331cdf44..7dac9b1d6291 100644
--- a/sys-libs/ncurses/ChangeLog
+++ b/sys-libs/ncurses/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/ncurses
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ChangeLog,v 1.29 2003/07/01 14:55:55 todd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ChangeLog,v 1.30 2003/08/01 13:17:04 agriffis Exp $
+
+*ncurses-5.3-r3 (01 Aug 2003)
+
+ 01 Aug 2003; Aron Griffis <agriffis@gentoo.org> ncurses-5.3-r3.ebuild,
+ files/xterm-debian.ti:
+ Add xterm-debian terminfo entry for bug 18486
*ncurses-5.3-r2 (11 Jun 2003)
diff --git a/sys-libs/ncurses/Manifest b/sys-libs/ncurses/Manifest
index 6a149268d539..3f2afa0d39fe 100644
--- a/sys-libs/ncurses/Manifest
+++ b/sys-libs/ncurses/Manifest
@@ -1,6 +1,6 @@
MD5 1ad647ff4d701a02a2ae52a27449e4f4 ncurses-5.3-r1.ebuild 2350
-MD5 9173dcc064d6b0f88d7724f4933d1fe9 ncurses-5.3-r3.ebuild 2649
-MD5 ee293e83e50aaa22dd20302b5553e5a9 ChangeLog 5448
+MD5 b36a63541166aa2b5fde952da6ac2e5c ncurses-5.3-r3.ebuild 2649
+MD5 c3b19841d0f873f424131df0a7cb1e6d ChangeLog 5630
MD5 12f25a3f9025c1f0a6be1ac685c9b8c7 ncurses-5.3-r2.ebuild 2441
MD5 f96d1b4b0bf94f1d38ce950df0efb37e files/ncurses-5.3-xterm.patch 1002
MD5 2167b54d7c96964183554e767e5f5376 files/xterm-debian.ti 342
diff --git a/sys-libs/ncurses/files/digest-ncurses-5.3-r3 b/sys-libs/ncurses/files/digest-ncurses-5.3-r3
new file mode 100644
index 000000000000..e8f327278e5b
--- /dev/null
+++ b/sys-libs/ncurses/files/digest-ncurses-5.3-r3
@@ -0,0 +1 @@
+MD5 5dcc9faa93157eafa572494bffed131a ncurses-5.3.tar.gz 2067718
diff --git a/sys-libs/ncurses/files/xterm-debian.ti b/sys-libs/ncurses/files/xterm-debian.ti
new file mode 100644
index 000000000000..68b7efea8cc2
--- /dev/null
+++ b/sys-libs/ncurses/files/xterm-debian.ti
@@ -0,0 +1,7 @@
+# xterm-debian is identical to xterm-xfree86 except that it more strictly
+# conforms to DEC VT220 behavior in the case of the backspace key; this is
+# mandated by the Section 3.8 of the Debian Policy Manual. Also see
+# <http://vt100.net/docs/vt220-rm/>.
+xterm-debian|Debian xterm (VT220-conformant backspace),
+ kbs=\177,
+ use=xterm-xfree86,
diff --git a/sys-libs/ncurses/ncurses-5.3-r3.ebuild b/sys-libs/ncurses/ncurses-5.3-r3.ebuild
new file mode 100644
index 000000000000..b0a08a5cf671
--- /dev/null
+++ b/sys-libs/ncurses/ncurses-5.3-r3.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.3-r3.ebuild,v 1.1 2003/08/01 13:17:04 agriffis Exp $
+
+IUSE=""
+
+inherit eutils flag-o-matic
+filter-flags "-fno-exceptions"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Linux console display library"
+HOMEPAGE="http://www.gnu.org/software/ncurses/ncurses.html"
+SRC_URI="mirror://gnu/ncurses/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="5"
+KEYWORDS="~amd64 ~x86 ~ppc ~sparc ~alpha ~hppa ~arm ~mips"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/ncurses-5.3-xterm.patch
+}
+
+src_compile() {
+ [ -z "${DEBUGBUILD}" ] && myconf="${myconf} --without-debug"
+
+ # From version 5.3, ncurses also build c++ bindings, and as
+ # we do not have a c++ compiler during bootstrap, disable
+ # building it. We will rebuild ncurses after gcc's second
+ # build in bootstrap.sh.
+ # <azarah@gentoo.org> (23 Oct 2002)
+ ( use build || use bootstrap ) \
+ && myconf="${myconf} --without-cxx --without-cxx-binding --without-ada"
+
+ econf \
+ --libdir=/lib \
+ --disable-termcap \
+ --with-shared \
+ --with-rcs-ids \
+ --without-ada \
+ ${myconf} || die "configure failed"
+
+ # do not work with -j2 on P4 - <azarah@gentoo.org> (23 Oct 2002)
+ make || die "parallel make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+
+ # Move static and extraneous ncurses libraries out of /lib
+ cd ${D}/lib
+ dodir /usr/lib
+ mv libform* libmenu* libpanel* ${D}/usr/lib
+ mv *.a ${D}/usr/lib
+ # bug #4411
+ gen_usr_ldscript libncurses.so
+
+ # With this fix, the default xterm has color as it should
+ #cd ${D}/usr/share/terminfo/x
+ #mv xterm xterm.orig
+ #dosym xterm-color /usr/share/terminfo/x/xterm
+
+ if [ -n "`use build`" ]
+ then
+ cd ${D}
+ rm -rf usr/share/man
+ cd usr/share/terminfo
+ cp -a l/linux n/nxterm v/vt100 ${T}
+ rm -rf *
+ mkdir l x v
+ cp -a ${T}/linux l
+ cp -a ${T}/nxterm x/xterm
+ cp -a ${T}/vt100 v
+ #bash compilation requires static libncurses libraries, so
+ #this breaks the "build a new build image" system. We now
+ #need to remove libncurses.a from the build image manually.
+ #rm *.a
+ else
+ # Install xterm-debian terminfo entry to satisfy bug #18486
+ LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:${D}/usr/lib:${D}/lib \
+ TERMINFO=${D}/usr/share/terminfo \
+ ${D}/usr/bin/tic ${FILESDIR}/xterm-debian.ti
+
+ cd ${S}
+ dodoc ANNOUNCE MANIFEST NEWS README* TO-DO
+ dodoc doc/*.doc
+ dohtml -r doc/html/
+ fi
+}
+
+pkg_postinst() {
+ # Old ncurses may still be around from old build tbz2's.
+ rm -f /lib/libncurses.so.5.2
+ rm -f /usr/lib/lib{form,menu,panel}.so.5.2
+}