summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-03-25 22:03:50 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-03-25 22:03:50 +0000
commit20618b3941e59391461fea283dd24ce7ded0ef0e (patch)
treee806c05d4723aa4f9eb738e02b49c4d70dc23ec4 /sys-libs/openipmi/openipmi-1.3.18.ebuild
parentVersion bump. (diff)
downloadgentoo-2-20618b3941e59391461fea283dd24ce7ded0ef0e.tar.gz
gentoo-2-20618b3941e59391461fea283dd24ce7ded0ef0e.tar.bz2
gentoo-2-20618b3941e59391461fea283dd24ce7ded0ef0e.zip
Add old stable version for OpenHPI to use.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-libs/openipmi/openipmi-1.3.18.ebuild')
-rw-r--r--sys-libs/openipmi/openipmi-1.3.18.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-libs/openipmi/openipmi-1.3.18.ebuild b/sys-libs/openipmi/openipmi-1.3.18.ebuild
new file mode 100644
index 000000000000..6e2147fd41e6
--- /dev/null
+++ b/sys-libs/openipmi/openipmi-1.3.18.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/openipmi/openipmi-1.3.18.ebuild,v 1.1 2005/03/25 22:03:50 robbat2 Exp $
+
+DESCRIPTION="Library interface to IPMI"
+HOMEPAGE="http://sourceforge.net/projects/${PN}/"
+MY_PN="OpenIPMI"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="crypt snmp"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="virtual/libc
+ sys-libs/gdbm
+ dev-util/pkgconfig
+ crypt? ( dev-libs/openssl )
+ snmp? ( net-analyzer/net-snmp )"
+
+src_compile() {
+ local myconf=""
+ myconf="${myconf} `use_with snmp ucdsnmp yes`"
+ myconf="${myconf} `use_with crypt openssl yes`"
+ # these binaries are for root!
+ econf ${myconf} --bindir=/usr/sbin || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc README* FAQ ChangeLog TODO lanserv/README.emulator lanserv/atca.emu
+}