summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-05-16 01:24:27 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-05-16 01:24:27 +0000
commit266ae2423dd3815abb417b1633e9483059d8a4e4 (patch)
tree127c9fc2b764a021a12b3de48de0aace0ec25533 /sys-libs/pam_ssh_agent
parentbug 92745 (diff)
downloadgentoo-2-266ae2423dd3815abb417b1633e9483059d8a4e4.tar.gz
gentoo-2-266ae2423dd3815abb417b1633e9483059d8a4e4.tar.bz2
gentoo-2-266ae2423dd3815abb417b1633e9483059d8a4e4.zip
Converted to use toolchain-funcs eclass. Cleaned up 0.2 ebuild to make it works on amd64 (and keyworded accordly). Avoid installation of LICENSE file.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'sys-libs/pam_ssh_agent')
-rw-r--r--sys-libs/pam_ssh_agent/ChangeLog9
-rw-r--r--sys-libs/pam_ssh_agent/pam_ssh_agent-0.1.ebuild8
-rw-r--r--sys-libs/pam_ssh_agent/pam_ssh_agent-0.2.ebuild25
3 files changed, 25 insertions, 17 deletions
diff --git a/sys-libs/pam_ssh_agent/ChangeLog b/sys-libs/pam_ssh_agent/ChangeLog
index 6d84c253784f..2f2442440582 100644
--- a/sys-libs/pam_ssh_agent/ChangeLog
+++ b/sys-libs/pam_ssh_agent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/pam_ssh_agent
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam_ssh_agent/ChangeLog,v 1.4 2004/06/24 23:08:45 agriffis Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam_ssh_agent/ChangeLog,v 1.5 2005/05/16 01:24:27 flameeyes Exp $
+
+ 16 May 2005; Diego Pettenò <flameeyes@gentoo.org>
+ pam_ssh_agent-0.1.ebuild, pam_ssh_agent-0.2.ebuild:
+ Converted to use toolchain-funcs eclass. Cleaned up 0.2 ebuild to make it
+ works on amd64 (and keyworded accordly). Avoid installation of LICENSE file.
01 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org>
pam_ssh_agent-0.1.ebuild:
diff --git a/sys-libs/pam_ssh_agent/pam_ssh_agent-0.1.ebuild b/sys-libs/pam_ssh_agent/pam_ssh_agent-0.1.ebuild
index ecc672d2368c..42ed1727d020 100644
--- a/sys-libs/pam_ssh_agent/pam_ssh_agent-0.1.ebuild
+++ b/sys-libs/pam_ssh_agent/pam_ssh_agent-0.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam_ssh_agent/pam_ssh_agent-0.1.ebuild,v 1.4 2004/06/24 23:08:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam_ssh_agent/pam_ssh_agent-0.1.ebuild,v 1.5 2005/05/16 01:24:27 flameeyes Exp $
-inherit gcc
+inherit toolchain-funcs
DESCRIPTION="PAM module that spawns a ssh-agent and adds identities using the password supplied at login"
HOMEPAGE="http://pam-ssh-agent.sourceforge.net/"
@@ -21,7 +21,7 @@ RDEPEND="net-misc/keychain
src_unpack() {
unpack ${A}
cd ${S}
- sed -i "s:gcc:$(gcc-getCC) ${CFLAGS}:" Makefile
+ sed -i "s:gcc:$(tc-getCC) ${CFLAGS}:" Makefile
}
src_compile() {
diff --git a/sys-libs/pam_ssh_agent/pam_ssh_agent-0.2.ebuild b/sys-libs/pam_ssh_agent/pam_ssh_agent-0.2.ebuild
index 4eb4dd6c77a5..bf5dbf57c795 100644
--- a/sys-libs/pam_ssh_agent/pam_ssh_agent-0.2.ebuild
+++ b/sys-libs/pam_ssh_agent/pam_ssh_agent-0.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam_ssh_agent/pam_ssh_agent-0.2.ebuild,v 1.2 2004/06/24 23:08:45 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam_ssh_agent/pam_ssh_agent-0.2.ebuild,v 1.3 2005/05/16 01:24:27 flameeyes Exp $
-inherit gcc
+inherit toolchain-funcs flag-o-matic multilib
DESCRIPTION="PAM module that spawns a ssh-agent and adds identities using the password supplied at login"
HOMEPAGE="http://pam-ssh-agent.sourceforge.net/"
@@ -10,24 +10,27 @@ SRC_URI="mirror://sourceforge/pam-ssh-agent/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
-DEPEND="sys-libs/pam
- >=sys-apps/sed-4"
-RDEPEND="net-misc/keychain
+DEPEND="net-misc/keychain
+ sys-libs/pam
dev-tcltk/expect"
src_unpack() {
unpack ${A}
cd ${S}
- sed -i "s:gcc:$(gcc-getCC) ${CFLAGS}:" Makefile
+ sed -i -e "s:gcc:$(tc-getCC) \${CFLAGS}:" Makefile
+ sed -i -e "s:/lib/:/$(get_libdir)/:" Makefile
}
src_compile() {
- emake || die
+ append-flags -fPIC
+
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die
- dodoc LICENSE README
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc README
}