summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-05-03 00:52:49 +0000
committerMike Frysinger <vapier@gentoo.org>2006-05-03 00:52:49 +0000
commitb927a0d6ff6f6d410b59348d92b5673b5d09f5bb (patch)
tree08920ef9e73ccb01fdb50614db18541fdb6e5e2f /sys-libs/timezone-data/timezone-data-2006f.ebuild
parentAdded ~sparc keyword. (diff)
downloadgentoo-2-b927a0d6ff6f6d410b59348d92b5673b5d09f5bb.tar.gz
gentoo-2-b927a0d6ff6f6d410b59348d92b5673b5d09f5bb.tar.bz2
gentoo-2-b927a0d6ff6f6d410b59348d92b5673b5d09f5bb.zip
Version bump #132020 by Rodrigo Severo.
(Portage version: 2.1_pre10)
Diffstat (limited to 'sys-libs/timezone-data/timezone-data-2006f.ebuild')
-rw-r--r--sys-libs/timezone-data/timezone-data-2006f.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-libs/timezone-data/timezone-data-2006f.ebuild b/sys-libs/timezone-data/timezone-data-2006f.ebuild
new file mode 100644
index 000000000000..330057d60d70
--- /dev/null
+++ b/sys-libs/timezone-data/timezone-data-2006f.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/timezone-data/timezone-data-2006f.ebuild,v 1.1 2006/05/03 00:52:49 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Timezone data (/usr/share/zoneinfo) and utilities (tzselect/zic/zdump)"
+HOMEPAGE="ftp://elsie.nci.nih.gov/pub/"
+SRC_URI="ftp://elsie.nci.nih.gov/pub/tzdata${PV}.tar.gz
+ ftp://elsie.nci.nih.gov/pub/tzcode${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha ~amd64 arm ia64 m68k mips ppc ~ppc64 s390 sh sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${PN}-2005n-makefile.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ rm -rf "${D}"/usr/share/zoneinfo-leaps
+ dodoc README Theory
+ dohtml *.htm *.jpg
+}
+
+pkg_postinst() {
+ if [[ ! -e ${ROOT}/etc/localtime ]] ; then
+ ewarn "Please remember to set your timezone using the zic command."
+ rm -f "${ROOT}"/etc/localtime
+ ln -s ../usr/share/zoneinfo/Factory "${ROOT}"/etc/localtime
+ fi
+}