summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-12 03:42:07 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-12 03:42:07 +0000
commit914633b45949226b92dcafe41974eea431130564 (patch)
tree3bff1c955f1745eddd8ad8d0cbf856e8900aade0 /sys-libs/uclibc
parentAdded message to deprecated file. (diff)
downloadgentoo-2-914633b45949226b92dcafe41974eea431130564.tar.gz
gentoo-2-914633b45949226b92dcafe41974eea431130564.tar.bz2
gentoo-2-914633b45949226b92dcafe41974eea431130564.zip
fix bootstrapping #73583
Diffstat (limited to 'sys-libs/uclibc')
-rw-r--r--sys-libs/uclibc/files/0.9.26-r8-cvs.patch40
-rw-r--r--sys-libs/uclibc/uclibc-0.9.26-r8.ebuild4
2 files changed, 43 insertions, 1 deletions
diff --git a/sys-libs/uclibc/files/0.9.26-r8-cvs.patch b/sys-libs/uclibc/files/0.9.26-r8-cvs.patch
new file mode 100644
index 000000000000..9ef2375912f6
--- /dev/null
+++ b/sys-libs/uclibc/files/0.9.26-r8-cvs.patch
@@ -0,0 +1,40 @@
+Fix building with linux26-headers.
+
+http://bugs.gentoo.org/show_bug.cgi?id=73583
+
+Index: include/features.h
+===================================================================
+RCS file: /var/cvs/uClibc/include/features.h,v
+retrieving revision 1.60
+retrieving revision 1.61
+diff -u -r1.60 -r1.61
+--- include/features.h 27 Oct 2004 07:26:21 -0000 1.60
++++ include/features.h 11 Jan 2005 17:02:22 -0000 1.61
+@@ -417,6 +417,9 @@
+ #ifndef __LINUX_COMPILER_H
+ #define __LINUX_COMPILER_H
+ #endif
++#ifndef __cast__
++#define __cast__(_to)
++#endif
+
+ /* Arrange to hide uClibc internals */
+ #if __GNUC_PREREQ (3, 3)
+Index: libc/sysdeps/linux/common/ssp.c
+===================================================================
+RCS file: /var/cvs/uClibc/libc/sysdeps/linux/common/ssp.c,v
+retrieving revision 1.5
+retrieving revision 1.6
+diff -u -r1.5 -r1.6
+--- libc/sysdeps/linux/common/ssp.c 25 Nov 2004 19:10:39 -0000 1.5
++++ libc/sysdeps/linux/common/ssp.c 11 Jan 2005 17:01:53 -0000 1.6
+@@ -29,7 +29,9 @@
+ #include <sys/un.h>
+ #include <sys/syslog.h>
+ #include <sys/time.h>
++#ifdef HAVE_DEV_ERANDOM
+ #include <sys/sysctl.h>
++#endif
+
+ #ifdef __PROPOLICE_BLOCK_SEGV__
+ #define SSP_SIGTYPE SIGSEGV
diff --git a/sys-libs/uclibc/uclibc-0.9.26-r8.ebuild b/sys-libs/uclibc/uclibc-0.9.26-r8.ebuild
index 61017c88c57c..acf5203e6d52 100644
--- a/sys-libs/uclibc/uclibc-0.9.26-r8.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.26-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.26-r8.ebuild,v 1.1 2005/01/12 00:50:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.26-r8.ebuild,v 1.2 2005/01/12 03:42:07 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -104,6 +104,8 @@ src_unpack() {
use build || epatch ${WORKDIR}/patch/math
fi
+ epatch ${FILESDIR}/${PVR}-cvs.patch #73583
+
########## CPU SELECTION ##########
local target config_target