summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-19 08:42:07 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-19 08:42:07 +0000
commitb7b95d86dfe7b12b0c768a36d922a4be9111d576 (patch)
treea94eaed5cd483fd490bd1bbc256862f8d3127ade /sys-libs/zlib
parentupdate copyright (diff)
downloadgentoo-2-b7b95d86dfe7b12b0c768a36d922a4be9111d576.tar.gz
gentoo-2-b7b95d86dfe7b12b0c768a36d922a4be9111d576.tar.bz2
gentoo-2-b7b95d86dfe7b12b0c768a36d922a4be9111d576.zip
Fixes by Diego Pettenò to respect user LDFLAGS and not run ldconfig #126718.
(Portage version: 2.1_pre6-r3)
Diffstat (limited to 'sys-libs/zlib')
-rw-r--r--sys-libs/zlib/ChangeLog6
-rw-r--r--sys-libs/zlib/files/zlib-1.2.3-LDFLAGS.patch31
-rw-r--r--sys-libs/zlib/zlib-1.2.3.ebuild6
3 files changed, 40 insertions, 3 deletions
diff --git a/sys-libs/zlib/ChangeLog b/sys-libs/zlib/ChangeLog
index 3c345df85a72..bf086ff9081d 100644
--- a/sys-libs/zlib/ChangeLog
+++ b/sys-libs/zlib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/zlib
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/ChangeLog,v 1.57 2006/03/06 13:17:36 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/ChangeLog,v 1.58 2006/03/19 08:42:07 vapier Exp $
+
+ 19 Mar 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/zlib-1.2.3-LDFLAGS.patch, zlib-1.2.3.ebuild:
+ Fixes by Diego Pettenò to respect user LDFLAGS and not run ldconfig #126718.
06 Mar 2006; Diego Pettenò <flameeyes@gentoo.org>
files/zlib-1.2.1-fPIC.patch:
diff --git a/sys-libs/zlib/files/zlib-1.2.3-LDFLAGS.patch b/sys-libs/zlib/files/zlib-1.2.3-LDFLAGS.patch
new file mode 100644
index 000000000000..86da956eb5f4
--- /dev/null
+++ b/sys-libs/zlib/files/zlib-1.2.3-LDFLAGS.patch
@@ -0,0 +1,31 @@
+--- zlib-1.2.3/Makefile.in
++++ zlib-1.2.3/Makefile.in
+@@ -24,7 +24,7 @@
+ #CFLAGS=-O3 -Wall -Wwrite-strings -Wpointer-arith -Wconversion \
+ # -Wstrict-prototypes -Wmissing-prototypes
+
+-LDFLAGS=libz.a
++TEST_LDFLAGS=libz.a
+ LDSHARED=$(CC)
+ CPP=$(CC) -E
+
+@@ -83,16 +83,16 @@
+ $(CC) $(CFLAGS) -DPIC -fPIC -c $< -o $@
+
+ $(SHAREDLIBV): $(PIC_OBJS)
+- $(LDSHARED) -o $@ $(PIC_OBJS) -lc
++ $(LDSHARED) -o $@ $(PIC_OBJS) -lc $(LDFLAGS)
+ rm -f $(SHAREDLIB) $(SHAREDLIBM)
+ ln -s $@ $(SHAREDLIB)
+ ln -s $@ $(SHAREDLIBM)
+
+ example$(EXE): example.o $(LIBS)
+- $(CC) $(CFLAGS) -o $@ example.o $(LDFLAGS)
++ $(CC) $(CFLAGS) -o $@ example.o $(LDFLAGS) $(TEST_LDFLAGS)
+
+ minigzip$(EXE): minigzip.o $(LIBS)
+- $(CC) $(CFLAGS) -o $@ minigzip.o $(LDFLAGS)
++ $(CC) $(CFLAGS) -o $@ minigzip.o $(LDFLAGS) $(TEST_LDFLAGS)
+
+ install-libs: $(LIBS)
+ -@if [ ! -d $(exec_prefix) ]; then mkdir -p $(exec_prefix); fi
diff --git a/sys-libs/zlib/zlib-1.2.3.ebuild b/sys-libs/zlib/zlib-1.2.3.ebuild
index 68c5ec394dac..435a5a678df0 100644
--- a/sys-libs/zlib/zlib-1.2.3.ebuild
+++ b/sys-libs/zlib/zlib-1.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.3.ebuild,v 1.8 2006/02/21 23:55:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.2.3.ebuild,v 1.9 2006/03/19 08:42:07 vapier Exp $
inherit eutils flag-o-matic
@@ -18,7 +18,6 @@ RDEPEND=""
src_unpack() {
unpack ${A}
-
cd "${S}"
# Make sure we link with glibc at all times
epatch "${FILESDIR}"/${PN}-1.2.1-glibc.patch
@@ -32,6 +31,9 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-1.2.1-fPIC.patch
# generate DT_SONAME on BSD hosts #123571
epatch "${FILESDIR}"/${PN}-1.2.3-bsd-soname.patch
+ # respect LDFLAGS #126718
+ epatch "${FILESDIR}"/${PN}-1.2.3-LDFLAGS.patch
+ sed -i -e '/ldconfig/d' Makefile.in
}
src_compile() {