summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-11-06 00:37:11 +0000
committerMike Frysinger <vapier@gentoo.org>2006-11-06 00:37:11 +0000
commit1e8d260826917cfcce64a740bca16faf6d688164 (patch)
tree98749478ffe09fb4ff3ad8e91a978ee83b16b78a /sys-libs
parentkeyworded ~x86, bug #154187 (diff)
downloadgentoo-2-1e8d260826917cfcce64a740bca16faf6d688164.tar.gz
gentoo-2-1e8d260826917cfcce64a740bca16faf6d688164.tar.bz2
gentoo-2-1e8d260826917cfcce64a740bca16faf6d688164.zip
update patch and rewrite ebuild to be more like other system libcs
(Portage version: 2.1.2_rc1-r2)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/newlib/files/digest-newlib-1.14.06
-rw-r--r--sys-libs/newlib/newlib-1.14.0.ebuild70
2 files changed, 27 insertions, 49 deletions
diff --git a/sys-libs/newlib/files/digest-newlib-1.14.0 b/sys-libs/newlib/files/digest-newlib-1.14.0
index ae27cff91593..49b634bab7b7 100644
--- a/sys-libs/newlib/files/digest-newlib-1.14.0
+++ b/sys-libs/newlib/files/digest-newlib-1.14.0
@@ -1,6 +1,6 @@
-MD5 209154baba054525a22d056ad3de9fc5 newlib-1.14.0-spu.patch.gz 49856
-RMD160 47fde8507a22b1c05bb16a4ba9d58b1021762ce9 newlib-1.14.0-spu.patch.gz 49856
-SHA256 6ffd289983ab6f6a138b77a45dd284dc10c42a59d1a3e299654782192a5ca497 newlib-1.14.0-spu.patch.gz 49856
+MD5 3e9f8ffa5c7ea5c75ae623db28070123 newlib-1.14.0-spu.patch.bz2 38900
+RMD160 d8f90ef2c27ef42c80dc03b4b1e1d1e3bd0f39d3 newlib-1.14.0-spu.patch.bz2 38900
+SHA256 09bb372bb8d26b9b6f3122f05a473e6850999de5f6408bf9a5bbc1f69554b640 newlib-1.14.0-spu.patch.bz2 38900
MD5 3fa663f131b355d3adb24ead4df678f2 newlib-1.14.0.tar.gz 7981432
RMD160 6f2b3f32759925142421ddc069229eff857dd106 newlib-1.14.0.tar.gz 7981432
SHA256 7db55671132c2943dbbdadfaa954915c23dbc329168575a42bb940ef4bf50a23 newlib-1.14.0.tar.gz 7981432
diff --git a/sys-libs/newlib/newlib-1.14.0.ebuild b/sys-libs/newlib/newlib-1.14.0.ebuild
index b6993492a48b..13f66009aa2d 100644
--- a/sys-libs/newlib/newlib-1.14.0.ebuild
+++ b/sys-libs/newlib/newlib-1.14.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-1.14.0.ebuild,v 1.2 2006/08/23 08:55:02 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-1.14.0.ebuild,v 1.3 2006/11/06 00:37:11 vapier Exp $
-inherit eutils flag-o-matic gnuconfig autotools
+inherit eutils flag-o-matic
export CBUILD=${CBUILD:-${CHOST}}
export CTARGET=${CTARGET:-${CHOST}}
@@ -20,7 +20,7 @@ fi
DESCRIPTION="Newlib is a C library intended for use on embedded systems"
HOMEPAGE="http://sourceware.org/newlib/"
SRC_URI="ftp://sources.redhat.com/pub/newlib/${P}.tar.gz
- mirror://gentoo/${P}-spu.patch.gz"
+ mirror://gentoo/${P}-spu.patch.bz2"
LICENSE="NEWLIB LIBGLOSS GPL-2"
[[ ${CTARGET} != ${CHOST} ]] \
@@ -28,71 +28,49 @@ LICENSE="NEWLIB LIBGLOSS GPL-2"
|| SLOT="0"
KEYWORDS="-* ~ppc64 ~ppc"
IUSE="nls threads unicode multilib"
+RESTRICT="strip"
-DEPEND="sys-devel/gnuconfig"
+DEPEND=""
RDEPEND=""
-RESTRICT="nostrip"
-
NEWLIBBUILD="${WORKDIR}/build"
-alt_build_kprefix() {
- if [[ ${CBUILD} == ${CHOST} && ${CTARGET} == ${CHOST} ]] \
- || [[ -n ${UCLIBC_AND_GLIBC} ]]
- then
- echo /usr
- else
- echo /usr/${CTARGET}/usr
- fi
-}
-
src_unpack() {
unpack ${A}
- epatch ${WORKDIR}/${P}-spu.patch
- einfo "Updating configure scripts"
- cd ${S}
- gnuconfig_update
- export WANT_AUTOCONF=2.1
- # ugly workaround
- for a in libgloss libgloss/doc libgloss/libnosys
- do
- pushd ${S}/${a} >/dev/null
- aclocal 2>/dev/null
- autoconf 2>/dev/null
- popd >/dev/null
- done
- mkdir ${NEWLIBBUILD}
+ epatch "${WORKDIR}"/${P}-spu.patch
+ mkdir -p "${NEWLIBBUILD}"
}
src_compile() {
+ # we should fix this ...
+ unset LDFLAGS
+ CHOST=${CTARGET} strip-unsupported-flags
+
local myconf=""
-#hardwired to avoid breakages
+ # hardwired to avoid breakages
[[ ${CTARGET} == *-softfloat-* ]] \
&& myconf="--disable-newlib-hw-fp" \
|| myconf="--enable-newlib-hw-fp"
-
-#to the user discretion
- myconf="${myconf} `use_enable unicode newlib-mb`"
- myconf="${myconf} `use_enable nls`"
- myconf="${myconf} `use_enable multilib`"
[[ ${CTARGET} == "spu" ]] \
&& myconf="${myconf} --disable-threads" \
- || myconf="${myconf} `use_enable threads`"
+ || myconf="${myconf} $(use_enable threads)"
- cd ${NEWLIBBUILD}
+ cd "${NEWLIBBUILD}"
- ../${P}/configure \
- --host=${CHOST} \
- --target=${CTARGET} \
- --prefix=/usr \
- ${myconf} || die "econf failed"
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable unicode newlib-mb) \
+ $(use_enable nls) \
+ $(use_enable multilib) \
+ ${myconf} \
+ || die "econf failed"
emake || die "emake failed"
}
src_install() {
- cd ${NEWLIBBUILD}
- emake -j1 DESTDIR=${D} install
+ cd "${NEWLIBBUILD}"
+ emake -j1 DESTDIR="${D}" install
env -uRESTRICT CHOST=${CTARGET} prepallstrip
# minor hack to keep things clean
- rm -fR ${D}/usr/info
+ rm -fR "${D}"/usr/info
}