summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-03-05 22:31:27 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-03-05 22:31:27 +0000
commit3b21071415c38b6c680e35d35a5e72f0221d1865 (patch)
treef159561ebb9183748147d9a0bfb7f54a5a8f3d0f /sys-libs
parentDependency update: sys-apps/buffer -> sys-block/buffer. (diff)
downloadgentoo-2-3b21071415c38b6c680e35d35a5e72f0221d1865.tar.gz
gentoo-2-3b21071415c38b6c680e35d35a5e72f0221d1865.tar.bz2
gentoo-2-3b21071415c38b6c680e35d35a5e72f0221d1865.zip
Moving --enable-omitfp check above strip-unsupported-flags. strip-unsupported-flags strips -fomit-frame-pointer -malign-double so removing that redundant line.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
index 6f2c11f1ebd0..543062fd43d8 100644
--- a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.10 2005/03/05 22:13:31 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.11 2005/03/05 22:31:27 eradicator Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -576,6 +576,10 @@ alt_usrlibdir() {
}
setup_flags() {
+ # If the user wants to use -fomit-frame-pointer, let the build system
+ # determine when it's safe
+ is-flag -fomit-frame-pointer && EXTRA_ECONF="--enable-omitfp ${EXTRA_ECONF}"
+
# Over-zealous CFLAGS can often cause problems. What may work for one
# person may not work for another. To avoid a large influx of bugs
# relating to failed builds, we strip most CFLAGS out to ensure as few
@@ -641,12 +645,7 @@ setup_flags() {
append-flags -finline-limit=2000
fi
- # If the user wants to use -fomit-frame-pointer, let the build system
- # determine when it's safe
- has_flag -fomit-frame-pointer && EXTRA_ECONF="--enable-omitfp ${EXTRA_ECONF}"
-
# We don't want these flags for glibc
- filter-flags -fomit-frame-pointer -malign-double
filter-ldflags -pie
# Lock glibc at -O2 -- linuxthreads needs it and we want to be