summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-01 10:10:12 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-01 10:10:12 +0000
commit4e43f4d27d7aa75fd2f7379b555e5be3274e25e3 (patch)
tree4bf9956c611160365afafad805e127bb50337b41 /sys-libs
parentremoved stale entries for gcl and xfoil (diff)
downloadgentoo-2-4e43f4d27d7aa75fd2f7379b555e5be3274e25e3.tar.gz
gentoo-2-4e43f4d27d7aa75fd2f7379b555e5be3274e25e3.tar.bz2
gentoo-2-4e43f4d27d7aa75fd2f7379b555e5be3274e25e3.zip
dont run scanelf when cross-compiling and fix stack_end issues #113343
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/uclibc/files/digest-uclibc-0.9.282
-rw-r--r--sys-libs/uclibc/uclibc-0.9.28.ebuild34
2 files changed, 21 insertions, 15 deletions
diff --git a/sys-libs/uclibc/files/digest-uclibc-0.9.28 b/sys-libs/uclibc/files/digest-uclibc-0.9.28
index 4d5df4c5bbbc..3159c1262a41 100644
--- a/sys-libs/uclibc/files/digest-uclibc-0.9.28
+++ b/sys-libs/uclibc/files/digest-uclibc-0.9.28
@@ -1,3 +1,3 @@
-MD5 7b867551d59399d2fff438aaee08f296 uClibc-0.9.28-patches-1.1.tar.bz2 20041
+MD5 c546948abd2c1e3f8cbb01caae248537 uClibc-0.9.28-patches-1.2.tar.bz2 19862
MD5 1ada58d919a82561061e4741fb6abd29 uClibc-0.9.28.tar.bz2 1763847
MD5 d75b2239b4e27c3c9cbed1c8f6eabba6 uClibc-locale-030818.tgz 236073
diff --git a/sys-libs/uclibc/uclibc-0.9.28.ebuild b/sys-libs/uclibc/uclibc-0.9.28.ebuild
index a39c37b1f806..7ae93cd426f2 100644
--- a/sys-libs/uclibc/uclibc-0.9.28.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.28.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.ebuild,v 1.13 2005/11/25 22:20:41 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.28.ebuild,v 1.14 2005/12/01 10:10:12 vapier Exp $
#ESVN_REPO_URI="svn://uclibc.org/trunk/uClibc"
#inherit subversion
@@ -21,7 +21,7 @@ fi
MY_P=uClibc-${PV}
SVN_VER=""
-PATCH_VER="1.1"
+PATCH_VER="1.2"
DESCRIPTION="C library for developing embedded Linux systems"
HOMEPAGE="http://www.uclibc.org/"
SRC_URI="http://www.kernel.org/pub/linux/libs/uclibc/${MY_P}.tar.bz2
@@ -213,19 +213,25 @@ src_unpack() {
local moredefs="DL_FINI_CRT_COMPAT"
# We need todo this for a few months. .28 is a major upgrade.
- if ! use uclibc-compat && [[ "$UCLIBC_SCANED_COMPAT" == "" ]]; then
- local fnames=""
- einfo "Doing a scanelf in paths for bins containing the __uClibc_start_main symbol"
- fnames="$(scanelf -pyqs__uClibc_start_main -F%F#s)"
- if [ "$fnames" == "" ]; then
- einfo "This system is clean."
- einfo "To prevent the scanning of files again in the future you can export UCLIBC_SCANED_COMPAT=1"
- moredefs=""
+ # Don't do it from cross-compiling case though
+ if ! use uclibc-compat ; then
+ if [[ -z ${UCLIBC_AND_GLIBC} ]] && [[ -z ${UCLIBC_SCANNED_COMPAT} ]] && \
+ ! just_headers && [[ ${CHOST} == ${CTARGET} ]] ; then
+ local fnames=""
+ einfo "Doing a scanelf in paths for bins containing the __uClibc_start_main symbol"
+ fnames=$(scanelf -pyqs__uClibc_start_main -F%F#s)
+ if [[ -z ${fnames} ]] ; then
+ einfo "This system is clean."
+ einfo "To prevent the scanning of files again in the future you can export UCLIBC_SCANNED_COMPAT=1"
+ moredefs=""
+ else
+ ewarn "You need to remerge the packages that contain the following files before you can remerge ${P} without USE=uclibc-compat enabled."
+ ewarn "qfile ${fnames}"
+ echo
+ ewarn "Leaving on ${moredefs}"
+ fi
else
- ewarn "You need to remerge the packages that contain the following files before you can remerge ${P} without USE=uclibc-compat enabled."
- ewarn "qfile ${fnames}"
- echo
- ewarn "Leaving on ${moredefs}"
+ moredefs=""
fi
fi
for def in ${moredefs} MALLOC_GLIBC_COMPAT DO_C99_MATH UCLIBC_HAS_{RPC,CTYPE_CHECKED,WCHAR,HEXADECIMAL_FLOATS,GLIBC_CUSTOM_PRINTF,FOPEN_EXCLUSIVE_MODE,GLIBC_CUSTOM_STREAMS,PRINTF_M_SPEC,FTW} ; do