summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-06-18 09:17:08 +0000
committerMike Frysinger <vapier@gentoo.org>2008-06-18 09:17:08 +0000
commit5380a732da8814cf4a5215b7e2bdc1b421edf536 (patch)
tree0bec821293d6577f2271e5591cdfd816c57b97fe /sys-libs
parentVersion bump to 3.1.2 (diff)
downloadgentoo-2-5380a732da8814cf4a5215b7e2bdc1b421edf536.tar.gz
gentoo-2-5380a732da8814cf4a5215b7e2bdc1b421edf536.tar.bz2
gentoo-2-5380a732da8814cf4a5215b7e2bdc1b421edf536.zip
Version bump.
(Portage version: 2.2_pre8/cvs/Linux 2.6.25 x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/ss/ChangeLog7
-rw-r--r--sys-libs/ss/ss-1.40.11.ebuild82
2 files changed, 88 insertions, 1 deletions
diff --git a/sys-libs/ss/ChangeLog b/sys-libs/ss/ChangeLog
index 3944e81fca5a..b4b1aa0078b2 100644
--- a/sys-libs/ss/ChangeLog
+++ b/sys-libs/ss/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/ss
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ss/ChangeLog,v 1.69 2008/06/14 10:11:27 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ss/ChangeLog,v 1.70 2008/06/18 09:17:08 vapier Exp $
+
+*ss-1.40.11 (18 Jun 2008)
+
+ 18 Jun 2008; Mike Frysinger <vapier@gentoo.org> +ss-1.40.11.ebuild:
+ Version bump.
14 Jun 2008; Christoph Mende <angelos@gentoo.org> ss-1.40.9.ebuild:
Stable on amd64, bug #225239
diff --git a/sys-libs/ss/ss-1.40.11.ebuild b/sys-libs/ss/ss-1.40.11.ebuild
new file mode 100644
index 000000000000..927fba289a14
--- /dev/null
+++ b/sys-libs/ss/ss-1.40.11.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ss/ss-1.40.11.ebuild,v 1.1 2008/06/18 09:17:08 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs multilib
+
+DESCRIPTION="Subsystem command parsing library"
+HOMEPAGE="http://e2fsprogs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/e2fsprogs/e2fsprogs-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND="~sys-libs/com_err-${PV}"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/e2fsprogs-${PV}
+
+env_setup() {
+ export LDCONFIG=/bin/true
+ export CC=$(tc-getCC)
+ export STRIP=/bin/true
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.39-makefile.patch
+
+ # make sure we error out if com_err is attempted to be built
+ rm -f lib/et/*.c
+ # since we've split out com_err/ss into their own ebuilds, we
+ # need to fake out the local files. let the toolchain find them.
+ mkdir tc || die
+ echo "GROUP ( libcom_err.a )" > tc/libcom_err.a
+ echo "GROUP ( libcom_err.so )" > tc/libcom_err.so
+ sed -i \
+ -e '/^LIBCOM_ERR/s:$(LIB):$(top_builddir)/tc:' \
+ MCONFIG.in || die
+ ln -s $(type -P compile_et) lib/et/compile_et
+}
+
+src_compile() {
+ env_setup
+
+ # We want to use the "bsd" libraries while building on Darwin, but while
+ # building on other Gentoo/*BSD we prefer elf-naming scheme.
+ local libtype
+ case ${CHOST} in
+ *-darwin*) libtype=bsd;;
+ *) libtype=elf;;
+ esac
+
+ econf \
+ --enable-${libtype}-shlibs \
+ --with-ldopts="${LDFLAGS}" \
+ $(use_enable nls) \
+ || die
+ emake -C lib/ss COMPILE_ET=compile_et || die "make ss failed"
+}
+
+src_test() {
+ env_setup
+ emake -j1 -C lib/ss check || die "make check failed"
+}
+
+src_install() {
+ env_setup
+
+ dodir /usr/share/man/man1
+ emake -C lib/ss DESTDIR="${D}" install || die
+
+ # Move shared libraries to /lib/, install static libraries to /usr/lib/,
+ # and install linker scripts to /usr/lib/.
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)/ || die "move .so"
+ dolib.a lib/libss.a || die "dolib.a"
+ gen_usr_ldscript libss.so
+}