summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-20 00:05:36 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-20 00:05:36 +0000
commit59fb50809554fe8224d836e1b6d1069888100e11 (patch)
tree494be2c4a02d8b28dc88c91c78c0ad6f2ee2eb9a /sys-libs
parentMoving licence for package t_coffee. (diff)
downloadgentoo-2-59fb50809554fe8224d836e1b6d1069888100e11.tar.gz
gentoo-2-59fb50809554fe8224d836e1b6d1069888100e11.tar.bz2
gentoo-2-59fb50809554fe8224d836e1b6d1069888100e11.zip
update the OABI stuff in src_compile and src_install to handle cross-compilers #109771
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.3.5-r2.ebuild47
1 files changed, 27 insertions, 20 deletions
diff --git a/sys-libs/glibc/glibc-2.3.5-r2.ebuild b/sys-libs/glibc/glibc-2.3.5-r2.ebuild
index cd32b67cd5c1..a8e983e87b7f 100644
--- a/sys-libs/glibc/glibc-2.3.5-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r2.ebuild,v 1.18 2005/10/19 21:00:35 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.5-r2.ebuild,v 1.19 2005/10/20 00:05:36 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -1153,23 +1153,22 @@ src_compile() {
setup_env
if [[ -z ${OABI} ]] ; then
+ local abilist=""
if has_multilib_profile ; then
+ abilist=$(get_install_abis)
+ einfo "Building multilib glibc for ABIs: ${abilist}"
+ elif is_crosscompile || tc-is-cross-compiler ; then
+ abilist=${DEFAULT_ABI}
+ fi
+ if [[ -n ${abilist} ]] ; then
OABI=${ABI}
- einfo "Building multilib glibc for ABIs: $(get_install_abis)"
- for ABI in $(get_install_abis) ; do
+ for ABI in ${abilist} ; do
export ABI
src_compile
done
ABI=${OABI}
unset OABI
return 0
- elif is_crosscompile || tc-is-cross-compiler ; then
- OABI=${ABI}
- export ABI=${DEFAULT_ABI}
- src_compile
- ABI=${OABI}
- unset OABI
- return 0
fi
fi
@@ -1198,16 +1197,24 @@ src_test() {
src_install() {
setup_env
- if [[ -z ${OABI} ]] && has_multilib_profile ; then
- OABI=${ABI}
- einfo "Installing multilib glibc for ABIs: $(get_install_abis)"
- for ABI in $(get_install_abis) ; do
- export ABI
- src_install
- done
- ABI=${OABI}
- unset OABI
- return 0
+ if [[ -z ${OABI} ]] ; then
+ local abilist=""
+ if has_multilib_profile ; then
+ abilist=$(get_install_abis)
+ einfo "Installing multilib glibc for ABIs: ${abilist}"
+ elif is_crosscompile || tc-is-cross-compiler ; then
+ abilist=${DEFAULT_ABI}
+ fi
+ if [[ -n ${abilist} ]] ; then
+ OABI=${ABI}
+ for ABI in ${abilist} ; do
+ export ABI
+ src_install
+ done
+ ABI=${OABI}
+ unset OABI
+ return 0
+ fi
fi
# Handle stupid lib32 BS