summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2012-03-10 04:30:16 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2012-03-10 04:30:16 +0000
commit5e1c26ea276ebde8af548ef715666069b12ffa02 (patch)
tree07192f9f1a26e47dbbcde40ead0d6e46acd05970 /sys-libs
parentRevbump to restore X use flag. (diff)
downloadgentoo-2-5e1c26ea276ebde8af548ef715666069b12ffa02.tar.gz
gentoo-2-5e1c26ea276ebde8af548ef715666069b12ffa02.tar.bz2
gentoo-2-5e1c26ea276ebde8af548ef715666069b12ffa02.zip
Bump to 0.1.0, needed for latest gnome-boxes
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libosinfo/ChangeLog7
-rw-r--r--sys-libs/libosinfo/libosinfo-0.1.0.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/sys-libs/libosinfo/ChangeLog b/sys-libs/libosinfo/ChangeLog
index 93f721e40853..70fb92261aad 100644
--- a/sys-libs/libosinfo/ChangeLog
+++ b/sys-libs/libosinfo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libosinfo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libosinfo/ChangeLog,v 1.5 2012/01/16 21:50:31 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libosinfo/ChangeLog,v 1.6 2012/03/10 04:30:16 nirbheek Exp $
+
+*libosinfo-0.1.0 (10 Mar 2012)
+
+ 10 Mar 2012; Nirbheek Chauhan <nirbheek@gentoo.org> +libosinfo-0.1.0.ebuild:
+ Bump to 0.1.0, needed for latest gnome-boxes
*libosinfo-0.0.5 (16 Jan 2012)
diff --git a/sys-libs/libosinfo/libosinfo-0.1.0.ebuild b/sys-libs/libosinfo/libosinfo-0.1.0.ebuild
new file mode 100644
index 000000000000..b8d102a28b03
--- /dev/null
+++ b/sys-libs/libosinfo/libosinfo-0.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libosinfo/libosinfo-0.1.0.ebuild,v 1.1 2012/03/10 04:30:16 nirbheek Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="GObject library for managing information about real and virtual OSes"
+HOMEPAGE="https://fedorahosted.org/libosinfo/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+SRC_URI="https://fedorahosted.org/releases/l/i/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +introspection +vala test"
+
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ dev-libs/glib:2
+ >=dev-libs/libxml2-2.6.0:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.10 )
+ test? ( dev-libs/check )
+ vala? ( dev-lang/vala:0.14 )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ # --enable-udev only installs udev rules
+ G2CONF="--disable-coverage
+ --disable-static
+ --enable-udev
+ --with-udev-rulesdir=/lib/udev/rules.d
+ VAPIGEN=$(type -P vapigen-0.14)
+ $(use_enable introspection)
+ $(use_enable test tests)
+ $(use_enable vala)"
+}