summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Gall <tgall@gentoo.org>2004-10-18 23:20:25 +0000
committerTom Gall <tgall@gentoo.org>2004-10-18 23:20:25 +0000
commit70a00d962ac2790caf4b16d1e06bac431800031e (patch)
treeae407ec13a1d256e037c65110a0e62bb1b9120a7 /sys-libs
parentstable on mips wrt bug 67326 (Manifest recommit) (diff)
downloadgentoo-2-70a00d962ac2790caf4b16d1e06bac431800031e.tar.gz
gentoo-2-70a00d962ac2790caf4b16d1e06bac431800031e.tar.bz2
gentoo-2-70a00d962ac2790caf4b16d1e06bac431800031e.zip
emergancy glibc fix for ppc64, fixed as to not affect any other architecture
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog7
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild17
2 files changed, 20 insertions, 4 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 782253c9d2b0..bab1db14ff8a 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/glibc
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.278 2004/10/16 04:49:56 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.279 2004/10/18 23:20:25 tgall Exp $
+
+ 16 Oct 2004; Tom Gall <tgall@gentoo.org> glibc-2.3.4.20040808-r1.ebuild:
+ emergancy fix, code from lv's change on 10/13 h0rked up ppc64 royally
+ and given this is the ppc64 stable version, I'm going to rush this in
+ to avoid the angry mob that's amassing outside my window
16 Oct 2004; Luca Barbato <lu_zero@gentoo.org>
glibc-2.3.4.20041006.ebuild:
diff --git a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
index 898b2d6cda55..0133784201d2 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.8 2004/10/13 22:43:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.9 2004/10/18 23:20:25 tgall Exp $
inherit eutils flag-o-matic gcc
@@ -604,7 +604,11 @@ src_install() {
mkdir ${T}/thread-backup
mv ${D}/$(get_libdir)/lib{pthread,thread_db}* ${T}/thread-backup/
env -uRESTRICT prepallstrip
- mv ${T}/thread-backup/* ${D}/$(get_libdir)/ || die
+
+ # this directory can be empty in certain cases so || die is wrong
+ # but hey, this is an emergancy fix for ppc64 so I won't break anyone else
+ use ppc64 && mv ${T}/thread-backup/* ${D}/$(get_libdir)/
+ use !ppc64 && mv ${T}/thread-backup/* ${D}/$(get_libdir)/ || die
# If librt.so is a symlink, change it into linker script (Redhat)
if [ -L "${D}/usr/lib/librt.so" -a "${LIBRT_LINKERSCRIPT}" = "yes" ]; then
@@ -692,7 +696,9 @@ EOF
insinto /etc
doins ${FILESDIR}/locales.build
- must_exist /$(get_libdir)/ libpthread.so.0
+ # this test isn't using the correct directory on ppc64
+ # and really it's a worthless test
+ use !ppc64 && must_exist /$(get_libdir)/ libpthread.so.0
# this whole section is useless, it fails if sandbox is LOADED, not if it's
# enabled. but forcing sandbox not to load isnt an option...
@@ -749,6 +755,11 @@ pkg_preinst() {
# chunk of FHS compliance only applies to 64bit archs where 32bit
# compatibility is a major concern (not IA64, for example).
use amd64 && [ "$(get_libdir)" == "lib64" ] && fix_lib64_symlinks
+
+ # note that PPC64 doesn't comply with documents that aren't
+ # a standard yet and there is little support in the
+ # community for them. But post 2004.3 we'll figure it out
+ use ppc64 && [ "$(get_libdir)" == "lib64" ]
}
pkg_postinst() {