summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-02-09 05:39:21 +0000
committerMike Frysinger <vapier@gentoo.org>2013-02-09 05:39:21 +0000
commit7bf4495f147f4f89e02e0e425ba26b2f1ee7e161 (patch)
treebdfb621ba5e522a6988fccc2cf0862ce9cb23593 /sys-libs
parentUtilize python_install_all. (diff)
downloadgentoo-2-7bf4495f147f4f89e02e0e425ba26b2f1ee7e161.tar.gz
gentoo-2-7bf4495f147f4f89e02e0e425ba26b2f1ee7e161.tar.bz2
gentoo-2-7bf4495f147f4f89e02e0e425ba26b2f1ee7e161.zip
Revert manual gcc dir search #453760 since that the real bug is broken ld.so.cache searching #454200.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog7
-rw-r--r--sys-libs/glibc/files/eblits/pkg_preinst.eblit7
2 files changed, 8 insertions, 6 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index d5e615973662..7880b76a2e08 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,5 +1,10 @@
# ChangeLog for sys-libs/glibc
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.922 2013/02/09 04:42:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.923 2013/02/09 05:39:21 vapier Exp $
+
+ 09 Feb 2013; Mike Frysinger <vapier@gentoo.org>
+ files/eblits/pkg_preinst.eblit:
+ Revert manual gcc dir search #453760 since that the real bug is broken
+ ld.so.cache searching #454200.
09 Feb 2013; Mike Frysinger <vapier@gentoo.org> ChangeLog-2007,
files/eblits/src_unpack.eblit, glibc-2.10.1-r1.ebuild, glibc-2.11.3.ebuild,
diff --git a/sys-libs/glibc/files/eblits/pkg_preinst.eblit b/sys-libs/glibc/files/eblits/pkg_preinst.eblit
index 3475415ea325..b57205f45259 100644
--- a/sys-libs/glibc/files/eblits/pkg_preinst.eblit
+++ b/sys-libs/glibc/files/eblits/pkg_preinst.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/pkg_preinst.eblit,v 1.7 2013/01/25 03:12:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/pkg_preinst.eblit,v 1.8 2013/02/09 05:39:21 vapier Exp $
# Simple test to make sure our new glibc isnt completely broken.
# Make sure we don't test with statically built binaries since
@@ -8,9 +8,6 @@
glibc_sanity_check() {
cd / #228809
- # We also might have to search the gcc dir for things like libgcc_s.so #453760
- local gccdir=$(ls -1rd /usr/lib/gcc/${CHOST}/*/ | head -1)
-
# We enter ${D} so to avoid trouble if the path contains
# special characters; for instance if the path contains the
# colon character (:), then the linker will try to split it
@@ -26,7 +23,7 @@ glibc_sanity_check() {
[[ -z ${x} ]] && continue
striptest=$(LC_ALL="C" file -L ${x} 2>/dev/null) || continue
[[ ${striptest} == *"statically linked"* ]] && continue
- ./ld-*.so --library-path ".:${gccdir}" ${x} > /dev/null \
+ ./ld-*.so --library-path . ${x} > /dev/null \
|| die "simple run test (${x}) failed"
done