summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-03-09 10:26:59 +0000
committerAchim Gottinger <achim@gentoo.org>2001-03-09 10:26:59 +0000
commit92aa49df5fbb94f611714048bc4f5764eb790368 (patch)
tree8733810875a5a5e23fac4fb5667964a5ef22d824 /sys-libs
parent*** empty log message *** (diff)
downloadgentoo-2-92aa49df5fbb94f611714048bc4f5764eb790368.tar.gz
gentoo-2-92aa49df5fbb94f611714048bc4f5764eb790368.tar.bz2
gentoo-2-92aa49df5fbb94f611714048bc4f5764eb790368.zip
*** empty log message ***
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/files/glibc-2.2.2-posix-bug-regex2-mem-perl.diff12
-rw-r--r--sys-libs/ncurses/ncurses-5.2-r3.ebuild69
-rw-r--r--sys-libs/pam/files/pam-0.73-pam_issue.diff10
-rw-r--r--sys-libs/slang/slang-1.4.4.ebuild45
4 files changed, 136 insertions, 0 deletions
diff --git a/sys-libs/glibc/files/glibc-2.2.2-posix-bug-regex2-mem-perl.diff b/sys-libs/glibc/files/glibc-2.2.2-posix-bug-regex2-mem-perl.diff
new file mode 100644
index 000000000000..c42618e8118a
--- /dev/null
+++ b/sys-libs/glibc/files/glibc-2.2.2-posix-bug-regex2-mem-perl.diff
@@ -0,0 +1,12 @@
+--- posix/Makefile~ Thu Feb 15 23:08:40 2001
++++ posix/Makefile Tue Feb 27 23:26:10 2001
+@@ -139,7 +139,9 @@
+ # XXX Please note that for now we ignore the result of this test.
+ tests: $(objpfx)annexc.out
+ ifeq (no,$(cross-compiling))
++ifneq (no,$(PERL))
+ tests:$(objpfx)bug-regex2-mem
++endif
+ endif
+
+ $(objpfx)annexc.out: $(objpfx)annexc
diff --git a/sys-libs/ncurses/ncurses-5.2-r3.ebuild b/sys-libs/ncurses/ncurses-5.2-r3.ebuild
new file mode 100644
index 000000000000..a46851c36a8d
--- /dev/null
+++ b/sys-libs/ncurses/ncurses-5.2-r3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.2-r3.ebuild,v 1.1 2001/03/09 10:26:59 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Linux console display libarary"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/ncurses/${A}
+ ftp://ftp.gnu.org/pub/gnu/ncurses/${A}"
+HOMEPAGE="http://www.gnu.org/software/ncurses/ncurses.html"
+DEPEND="virtual/glibc gpm? ( >=sys-libs/gpm-1.19.3 )"
+
+src_compile() {
+
+ local myconf
+ if [ "`use gpm`" ]
+ then
+ myconf="--with-gpm"
+ fi
+ if [ -z "$DEBUG" ]
+ then
+ myconf="${myconf} --without-debug"
+ fi
+ try ./configure --prefix=/usr --libdir=/lib --mandir=/usr/share/man \
+ --enable-symlinks --enable-termcap \
+ --with-shared --with-rcs-ids \
+ --host=${CHOST} ${myconf}
+
+ try make ${MAKEOPTS}
+
+}
+
+src_install() {
+
+ dodir /usr/lib
+ try make DESTDIR=${D} install
+
+ cd ${D}/lib
+ ln -s libncurses.a libcurses.a
+ chmod 755 ${D}/lib/*.${PV}
+ dodir /usr/lib
+ mv libform* libmenu* libpanel* ../usr/lib
+ mv *.a ../usr/lib
+
+ cd ${S}
+
+ dodoc ANNOUNCE MANIFEST NEWS README* TO-DO
+ dodoc doc/*.doc
+ docinto html
+ dodoc doc/html/*.html
+ docinto html/ada
+ dodoc doc/html/ada/*.htm
+ docinto html/ada/files
+ dodoc doc/html/ada/files/*.htm
+ docinto html/ada/funcs
+ dodoc doc/html/ada/funcs/*.htm
+ docinto html/man
+ dodoc doc/html/man/*.html
+
+ #with this fix, the default xterm has color as it should
+ cd ${D}/usr/share/terminfo/x
+ mv xterm xterm.orig
+ ln -s xterm-color xterm
+
+}
+
+
+
diff --git a/sys-libs/pam/files/pam-0.73-pam_issue.diff b/sys-libs/pam/files/pam-0.73-pam_issue.diff
new file mode 100644
index 000000000000..03657bcad233
--- /dev/null
+++ b/sys-libs/pam/files/pam-0.73-pam_issue.diff
@@ -0,0 +1,10 @@
+--- modules/pam_issue/pam_issue.c~ Tue Jun 20 22:11:40 2000
++++ modules/pam_issue/pam_issue.c Sun Feb 18 10:03:26 2001
+@@ -28,6 +28,7 @@
+ #include <sys/utsname.h>
+ #include <utmp.h>
+ #include <malloc.h>
++#include <time.h>
+
+ #include <security/_pam_macros.h>
+
diff --git a/sys-libs/slang/slang-1.4.4.ebuild b/sys-libs/slang/slang-1.4.4.ebuild
new file mode 100644
index 000000000000..d46be12731ce
--- /dev/null
+++ b/sys-libs/slang/slang-1.4.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-1.4.4.ebuild,v 1.1 2001/03/09 10:26:59 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Console display library used by most text viewer"
+SRC_URI="ftp://space.mit.edu/pub/davis/slang/v1.4/${A}"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ cp configure configure.orig
+ sed -e "s/ELF_CFLAGS=\"-O2/ELF_CFLAGS=\"${CFLAGS}/" configure.orig > configure
+}
+
+
+src_compile() {
+
+ try ./configure --host=${CHOST} --prefix=/usr
+ try make ${MAKEOPTS} prefix=${D}/usr all elf
+ #cp src/objs/libslang.a .
+ #try make ${MAKEOPTS} prefix=${D}/usr clean elf
+}
+
+src_install() {
+
+ dolib.a src/objs/libslang.a
+ dolib.so src/elfobjs/libslang.so.${PV}
+ dosym linslang.so.${PV} /usr/lib/libslang.so
+
+ insinto /usr/include
+ doins src/{slang.h,slcurses.h}
+ dodoc COPYING* NEWS README *.txt
+ dodoc doc/*.txt doc/internal/*.txt doc/text/*.txt
+ docinto html
+ dodoc doc/*.html
+}
+
+
+