summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-05-14 03:20:08 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-05-14 03:20:08 +0000
commita62e432d9d11bac5372f61bac654440bbdf08332 (patch)
tree1f1cfaa43987b6701fa5b90dbaf3022fcfa4ace7 /sys-libs
parentBug #319583: DBM support was not actually being built due to bug in upstream ... (diff)
downloadgentoo-2-a62e432d9d11bac5372f61bac654440bbdf08332.tar.gz
gentoo-2-a62e432d9d11bac5372f61bac654440bbdf08332.tar.bz2
gentoo-2-a62e432d9d11bac5372f61bac654440bbdf08332.zip
Remove broken 5.0.21.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/ChangeLog5
-rw-r--r--sys-libs/db/db-5.0.21.ebuild190
2 files changed, 4 insertions, 191 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index 670646e448bf..1bb16759daf0 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/db
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.304 2010/05/14 03:19:25 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.305 2010/05/14 03:20:08 robbat2 Exp $
+
+ 14 May 2010; Robin H. Johnson <robbat2@gentoo.org> -db-5.0.21.ebuild:
+ Remove broken 5.0.21.
*db-5.0.21-r1 (14 May 2010)
diff --git a/sys-libs/db/db-5.0.21.ebuild b/sys-libs/db/db-5.0.21.ebuild
deleted file mode 100644
index 70a89c82bc52..000000000000
--- a/sys-libs/db/db-5.0.21.ebuild
+++ /dev/null
@@ -1,190 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-5.0.21.ebuild,v 1.1 2010/05/11 08:01:45 robbat2 Exp $
-
-inherit eutils db flag-o-matic java-pkg-opt-2 autotools libtool
-
-#Number of official patches
-#PATCHNO=`echo ${PV}|sed -e "s,\(.*_p\)\([0-9]*\),\2,"`
-PATCHNO=${PV/*.*.*_p}
-if [[ ${PATCHNO} == "${PV}" ]] ; then
- MY_PV=${PV}
- MY_P=${P}
- PATCHNO=0
-else
- MY_PV=${PV/_p${PATCHNO}}
- MY_P=${PN}-${MY_PV}
-fi
-
-S_BASE="${WORKDIR}/${MY_P}"
-S="${S_BASE}/build_unix"
-DESCRIPTION="Oracle Berkeley DB"
-HOMEPAGE="http://www.oracle.com/technology/software/products/berkeley-db/index.html"
-SRC_URI="http://download.oracle.com/berkeley-db/${MY_P}.tar.gz"
-for (( i=1 ; i<=${PATCHNO} ; i++ )) ; do
- export SRC_URI="${SRC_URI} http://www.oracle.com/technology/products/berkeley-db/db/update/${MY_PV}/patch.${MY_PV}.${i}"
-done
-
-LICENSE="OracleDB"
-SLOT="5.0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="doc java nocxx tcl test"
-
-# the entire testsuite needs the TCL functionality
-DEPEND="tcl? ( >=dev-lang/tcl-8.4 )
- test? ( >=dev-lang/tcl-8.4 )
- java? ( >=virtual/jdk-1.5 )
- >=sys-devel/binutils-2.16.1"
-RDEPEND="tcl? ( dev-lang/tcl )
- java? ( >=virtual/jre-1.5 )"
-
-src_unpack() {
- unpack "${MY_P}".tar.gz
- cd "${WORKDIR}"/"${MY_P}"
- for (( i=1 ; i<=${PATCHNO} ; i++ ))
- do
- epatch "${DISTDIR}"/patch."${MY_PV}"."${i}"
- done
- epatch "${FILESDIR}"/${PN}-4.8-libtool.patch
- epatch "${FILESDIR}"/${PN}-4.8.24-java-manifest-location.patch
-
- # use the includes from the prefix
- epatch "${FILESDIR}"/${PN}-4.6-jni-check-prefix-first.patch
- epatch "${FILESDIR}"/${PN}-4.3-listen-to-java-options.patch
-
- # Upstream release script grabs the dates when the script was run, so lets
- # end-run them to keep the date the same.
- export REAL_DB_RELEASE_DATE="$(awk \
- '/^DB_VERSION_STRING=/{ gsub(".*\\(|\\).*","",$0); print $0; }' \
- "${S_BASE}"/dist/configure)"
- sed -r -i \
- -e "/^DB_RELEASE_DATE=/s~=.*~='${REAL_DB_RELEASE_DATE}'~g" \
- "${S_BASE}"/dist/RELEASE
-
- # Include the SLOT for Java JAR files
- # This supersedes the unused jarlocation patches.
- sed -r -i \
- -e '/jarfile=.*\.jar$/s,(.jar$),-$(LIBVERSION)\1,g' \
- "${S_BASE}"/dist/Makefile.in
-
- cd "${S_BASE}"/dist
- rm -f aclocal/libtool.m4
- sed -i \
- -e '/AC_PROG_LIBTOOL$/aLT_OUTPUT' \
- configure.ac
- sed -i \
- -e '/^AC_PATH_TOOL/s/ sh, none/ bash, none/' \
- aclocal/programs.m4
- AT_M4DIR="aclocal aclocal_java" eautoreconf
- # Upstream sucks - they do autoconf and THEN replace the version variables.
- . ./RELEASE
- for v in \
- DB_VERSION_{FAMILY,LETTER,RELEASE,MAJOR,MINOR} \
- DB_VERSION_{PATCH,FULL,UNIQUE_NAME,STRING,FULL_STRING} \
- DB_VERSION \
- DB_RELEASE_DATE ; do
- local ev="__EDIT_${v}__"
- sed -i -e "s/${ev}/${!v}/g" configure
- done
-}
-
-src_compile() {
- local myconf=''
-
- # compilation with -O0 fails on amd64, see bug #171231
- if use amd64; then
- replace-flags -O0 -O2
- is-flagq -O[s123] || append-flags -O2
- fi
-
- # use `set` here since the java opts will contain whitespace
- set --
- if use java ; then
- set -- "$@" \
- --with-java-prefix="${JAVA_HOME}" \
- --with-javac-flags="$(java-pkg_javac-args)"
- fi
-
- # Add linker versions to the symbols. Easier to do, and safer than header file
- # mumbo jumbo.
- if use userland_GNU ; then
- append-ldflags -Wl,--default-symver
- fi
-
- # Bug #270851: test needs TCL support
- if use tcl || use test ; then
- myconf="${myconf} --enable-tcl"
- myconf="${myconf} --with-tcl=/usr/$(get_libdir)"
- else
- myconf="${myconf} --disable-tcl"
- fi
-
- # sql_compat will cause a collision with sqlite3
- # --enable-sql_compat
- cd "${S}"
- ECONF_SOURCE="${S_BASE}"/dist \
- STRIP="true" \
- econf \
- --enable-compat185 \
- --enable-dbm \
- --enable-o_direct \
- --without-uniquename \
- --enable-sql \
- --enable-sql_codegen \
- --disable-sql_compat \
- $(use arm && echo --with-mutex=ARM/gcc-assembly) \
- $(use amd64 && echo --with-mutex=x86/gcc-assembly) \
- $(use_enable !nocxx cxx) \
- $(use_enable !nocxx stl) \
- $(use_enable java) \
- ${myconf} \
- $(use_enable test) \
- "$@"
-
- emake || die "make failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
-
- db_src_install_usrbinslot
-
- db_src_install_headerslot
-
- db_src_install_doc
-
- db_src_install_usrlibcleanup
-
- dodir /usr/sbin
- # This file is not always built, and no longer exists as of db-4.8
- [[ -f "${D}"/usr/bin/berkeley_db_svc ]] && \
- mv "${D}"/usr/bin/berkeley_db_svc "${D}"/usr/sbin/berkeley_db"${SLOT/./}"_svc
-
- if use java; then
- java-pkg_regso "${D}"/usr/"$(get_libdir)"/libdb_java*.so
- java-pkg_dojar "${D}"/usr/"$(get_libdir)"/*.jar
- rm -f "${D}"/usr/"$(get_libdir)"/*.jar
- fi
-}
-
-pkg_postinst() {
- db_fix_so
-}
-
-pkg_postrm() {
- db_fix_so
-}
-
-src_test() {
- # db_repsite is impossible to build, as upstream strips those sources.
- # db_repsite is used directly in the setup_site_prog,
- # setup_site_prog is called from open_site_prog
- # which is called only from tests
- egrep -ril \
- 'open_site_prog|setup_site_prog|db_repsite' \
- "${S_BASE}/test" \
- | xargs egrep -l '^# TEST ' \
- | xargs rename .tcl .tcl.DISABLED
-
- db_src_test
-}