summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-01-07 10:25:59 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-01-07 10:25:59 +0000
commitd53b83794b5287ad3c836e4cc2c4689e74000cc2 (patch)
tree8902d585cec055e2b0f56245e0966001882f3116 /sys-libs
parentRemoved old versions and files (diff)
downloadgentoo-2-d53b83794b5287ad3c836e4cc2c4689e74000cc2.tar.gz
gentoo-2-d53b83794b5287ad3c836e4cc2c4689e74000cc2.tar.bz2
gentoo-2-d53b83794b5287ad3c836e4cc2c4689e74000cc2.zip
Removed old versions and files
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/readline/ChangeLog10
-rw-r--r--sys-libs/readline/files/readline-6.1-rlfe-freebsd.patch16
-rw-r--r--sys-libs/readline/readline-6.1.ebuild104
-rw-r--r--sys-libs/readline/readline-6.1_p2.ebuild105
-rw-r--r--sys-libs/readline/readline-6.2.ebuild107
-rw-r--r--sys-libs/readline/readline-6.2_p1-r1.ebuild109
-rw-r--r--sys-libs/readline/readline-6.2_p4.ebuild109
-rw-r--r--sys-libs/readline/readline-6.2_p5.ebuild130
8 files changed, 8 insertions, 682 deletions
diff --git a/sys-libs/readline/ChangeLog b/sys-libs/readline/ChangeLog
index af6b22192adc..c3969810aac6 100644
--- a/sys-libs/readline/ChangeLog
+++ b/sys-libs/readline/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/readline
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.189 2013/12/30 16:43:12 vapier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.190 2014/01/07 10:25:59 polynomial-c Exp $
+
+ 07 Jan 2014; Lars Wendler <polynomial-c@gentoo.org> -readline-6.1.ebuild,
+ -readline-6.1_p2.ebuild, -readline-6.2.ebuild, -readline-6.2_p1-r1.ebuild,
+ -readline-6.2_p4.ebuild, -readline-6.2_p5.ebuild,
+ -files/readline-6.1-rlfe-freebsd.patch:
+ Removed old versions and files.
30 Dec 2013; Mike Frysinger <vapier@gentoo.org> readline-6.2_p5-r1.ebuild:
tweak rlfe sed a bit #457558
diff --git a/sys-libs/readline/files/readline-6.1-rlfe-freebsd.patch b/sys-libs/readline/files/readline-6.1-rlfe-freebsd.patch
deleted file mode 100644
index e9a051eacb82..000000000000
--- a/sys-libs/readline/files/readline-6.1-rlfe-freebsd.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-FreeBSD-8 dropped sgtty.h in favor of termios.h,
-without this rlfe build on FreeBSD-8 fails with a
-missing sgtty.h.
-See also bug #301508.
-
---- readline-6.1/examples/rlfe/os.h.orig
-+++ readline-6.1/examples/rlfe/os.h
-@@ -186,7 +186,7 @@
- * terminal handling
- */
-
--#ifdef POSIX
-+#if defined(POSIX) || defined(__FreeBSD__)
- # include <termios.h>
- # ifdef hpux
- # include <bsdtty.h>
diff --git a/sys-libs/readline/readline-6.1.ebuild b/sys-libs/readline/readline-6.1.ebuild
deleted file mode 100644
index 4222265f07b8..000000000000
--- a/sys-libs/readline/readline-6.1.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-6.1.ebuild,v 1.11 2011/09/26 02:37:51 vapier Exp $
-
-inherit eutils multilib toolchain-funcs flag-o-matic
-
-# Official patches
-# See ftp://ftp.cwru.edu/pub/bash/readline-6.0-patches/
-PLEVEL=${PV##*_p}
-MY_PV=${PV/_p*}
-MY_PV=${MY_PV/_/-}
-MY_P=${PN}-${MY_PV}
-[[ ${PV} != *_p* ]] && PLEVEL=0
-patches() {
- [[ ${PLEVEL} -eq 0 ]] && return 1
- local opt=$1
- eval set -- {1..${PLEVEL}}
- set -- $(printf "${PN}${MY_PV/\.}-%03d " "$@")
- if [[ ${opt} == -s ]] ; then
- echo "${@/#/${DISTDIR}/}"
- else
- local u
- for u in ftp://ftp.cwru.edu/pub/bash mirror://gnu/${PN} ; do
- printf "${u}/${PN}-${MY_PV}-patches/%s " "$@"
- done
- fi
-}
-
-DESCRIPTION="Another cute console display library"
-HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
-SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz $(patches)"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE=""
-
-# We must be certain that we have a bash that is linked
-# to its internal readline, else we may get problems.
-RDEPEND=">=sys-libs/ncurses-5.2-r2"
-DEPEND="${RDEPEND}
- >=app-shells/bash-2.05b-r2"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
-
- cd "${S}"
- [[ ${PLEVEL} -gt 0 ]] && epatch $(patches -s)
- epatch "${FILESDIR}"/${PN}-5.0-no_rpath.patch
- epatch "${FILESDIR}"/${PN}-5.2-no-ignore-shlib-errors.patch #216952
-
- # force ncurses linking #71420
- sed -i -e 's:^SHLIB_LIBS=:SHLIB_LIBS=-lncurses:' support/shobj-conf || die "sed"
-
- # fix building under Gentoo/FreeBSD; upstream FreeBSD deprecated
- # objformat for years, so we don't want to rely on that.
- sed -i -e '/objformat/s:if .*; then:if true; then:' support/shobj-conf || die
-
- ln -s ../.. examples/rlfe/readline # for local readline headers
-}
-
-src_compile() {
- append-cppflags -D_GNU_SOURCE
-
- econf --with-curses || die
- emake || die
-
- if ! tc-is-cross-compiler ; then
- # code is full of AC_TRY_RUN()
- cd examples/rlfe
- append-ldflags -L.
- local l
- for l in readline history ; do
- ln -s ../../shlib/lib${l}$(get_libname)* lib${l}$(get_libname)
- ln -sf ../../lib${l}.a lib${l}.a
- done
- econf || die
- emake || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- gen_usr_ldscript -a readline history #4411
-
- if ! tc-is-cross-compiler; then
- dobin examples/rlfe/rlfe || die
- fi
-
- dodoc CHANGELOG CHANGES README USAGE NEWS
- docinto ps
- dodoc doc/*.ps
- dohtml -r doc
-}
-
-pkg_preinst() {
- preserve_old_lib /$(get_libdir)/lib{history,readline}.so.{4,5} #29865
-}
-
-pkg_postinst() {
- preserve_old_lib_notify /$(get_libdir)/lib{history,readline}.so.{4,5}
-}
diff --git a/sys-libs/readline/readline-6.1_p2.ebuild b/sys-libs/readline/readline-6.1_p2.ebuild
deleted file mode 100644
index 808d751e7682..000000000000
--- a/sys-libs/readline/readline-6.1_p2.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-6.1_p2.ebuild,v 1.9 2011/09/26 02:37:51 vapier Exp $
-
-inherit eutils multilib toolchain-funcs flag-o-matic
-
-# Official patches
-# See ftp://ftp.cwru.edu/pub/bash/readline-6.0-patches/
-PLEVEL=${PV##*_p}
-MY_PV=${PV/_p*}
-MY_PV=${MY_PV/_/-}
-MY_P=${PN}-${MY_PV}
-[[ ${PV} != *_p* ]] && PLEVEL=0
-patches() {
- [[ ${PLEVEL} -eq 0 ]] && return 1
- local opt=$1
- eval set -- {1..${PLEVEL}}
- set -- $(printf "${PN}${MY_PV/\.}-%03d " "$@")
- if [[ ${opt} == -s ]] ; then
- echo "${@/#/${DISTDIR}/}"
- else
- local u
- for u in ftp://ftp.cwru.edu/pub/bash mirror://gnu/${PN} ; do
- printf "${u}/${PN}-${MY_PV}-patches/%s " "$@"
- done
- fi
-}
-
-DESCRIPTION="Another cute console display library"
-HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
-SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz $(patches)"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE=""
-
-# We must be certain that we have a bash that is linked
-# to its internal readline, else we may get problems.
-RDEPEND=">=sys-libs/ncurses-5.2-r2"
-DEPEND="${RDEPEND}
- >=app-shells/bash-2.05b-r2"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
-
- cd "${S}"
- [[ ${PLEVEL} -gt 0 ]] && epatch $(patches -s)
- epatch "${FILESDIR}"/${PN}-5.0-no_rpath.patch
- epatch "${FILESDIR}"/${PN}-5.2-no-ignore-shlib-errors.patch #216952
- epatch "${FILESDIR}"/${PN}-6.1-rlfe-freebsd.patch # 301508
-
- # force ncurses linking #71420
- sed -i -e 's:^SHLIB_LIBS=:SHLIB_LIBS=-lncurses:' support/shobj-conf || die "sed"
-
- # fix building under Gentoo/FreeBSD; upstream FreeBSD deprecated
- # objformat for years, so we don't want to rely on that.
- sed -i -e '/objformat/s:if .*; then:if true; then:' support/shobj-conf || die
-
- ln -s ../.. examples/rlfe/readline # for local readline headers
-}
-
-src_compile() {
- append-cppflags -D_GNU_SOURCE
-
- econf --with-curses || die
- emake || die
-
- if ! tc-is-cross-compiler ; then
- # code is full of AC_TRY_RUN()
- cd examples/rlfe
- append-ldflags -L.
- local l
- for l in readline history ; do
- ln -s ../../shlib/lib${l}$(get_libname)* lib${l}$(get_libname)
- ln -sf ../../lib${l}.a lib${l}.a
- done
- econf || die
- emake || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- gen_usr_ldscript -a readline history #4411
-
- if ! tc-is-cross-compiler; then
- dobin examples/rlfe/rlfe || die
- fi
-
- dodoc CHANGELOG CHANGES README USAGE NEWS
- docinto ps
- dodoc doc/*.ps
- dohtml -r doc
-}
-
-pkg_preinst() {
- preserve_old_lib /$(get_libdir)/lib{history,readline}.so.{4,5} #29865
-}
-
-pkg_postinst() {
- preserve_old_lib_notify /$(get_libdir)/lib{history,readline}.so.{4,5}
-}
diff --git a/sys-libs/readline/readline-6.2.ebuild b/sys-libs/readline/readline-6.2.ebuild
deleted file mode 100644
index 50d4165a2337..000000000000
--- a/sys-libs/readline/readline-6.2.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-6.2.ebuild,v 1.2 2011/09/26 02:37:51 vapier Exp $
-
-inherit eutils multilib toolchain-funcs flag-o-matic
-
-# Official patches
-# See ftp://ftp.cwru.edu/pub/bash/readline-6.0-patches/
-PLEVEL=${PV##*_p}
-MY_PV=${PV/_p*}
-MY_PV=${MY_PV/_/-}
-MY_P=${PN}-${MY_PV}
-[[ ${PV} != *_p* ]] && PLEVEL=0
-patches() {
- [[ ${PLEVEL} -eq 0 ]] && return 1
- local opt=$1
- eval set -- {1..${PLEVEL}}
- set -- $(printf "${PN}${MY_PV/\.}-%03d " "$@")
- if [[ ${opt} == -s ]] ; then
- echo "${@/#/${DISTDIR}/}"
- else
- local u
- for u in ftp://ftp.cwru.edu/pub/bash mirror://gnu/${PN} ; do
- printf "${u}/${PN}-${MY_PV}-patches/%s " "$@"
- done
- fi
-}
-
-DESCRIPTION="Another cute console display library"
-HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
-SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz $(patches)"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE=""
-
-# We must be certain that we have a bash that is linked
-# to its internal readline, else we may get problems.
-RDEPEND=">=sys-libs/ncurses-5.2-r2"
-DEPEND="${RDEPEND}
- >=app-shells/bash-2.05b-r2"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
-
- cd "${S}"
- [[ ${PLEVEL} -gt 0 ]] && epatch $(patches -s)
- epatch "${FILESDIR}"/${PN}-5.0-no_rpath.patch
- epatch "${FILESDIR}"/${PN}-5.2-no-ignore-shlib-errors.patch #216952
-
- # force ncurses linking #71420
- sed -i -e 's:^SHLIB_LIBS=:SHLIB_LIBS=-lncurses:' support/shobj-conf || die "sed"
-
- # fix building under Gentoo/FreeBSD; upstream FreeBSD deprecated
- # objformat for years, so we don't want to rely on that.
- sed -i -e '/objformat/s:if .*; then:if true; then:' support/shobj-conf || die
-
- ln -s ../.. examples/rlfe/readline # for local readline headers
-}
-
-src_compile() {
- # fix implicit decls with widechar funcs
- append-cppflags -D_GNU_SOURCE
- # http://lists.gnu.org/archive/html/bug-readline/2010-07/msg00013.html
- append-cppflags -Dxrealloc=_rl_realloc -Dxmalloc=_rl_malloc -Dxfree=_rl_free
-
- econf --with-curses || die
- emake || die
-
- if ! tc-is-cross-compiler ; then
- # code is full of AC_TRY_RUN()
- cd examples/rlfe
- append-ldflags -L.
- local l
- for l in readline history ; do
- ln -s ../../shlib/lib${l}$(get_libname)* lib${l}$(get_libname)
- ln -sf ../../lib${l}.a lib${l}.a
- done
- econf || die
- emake || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- gen_usr_ldscript -a readline history #4411
-
- if ! tc-is-cross-compiler; then
- dobin examples/rlfe/rlfe || die
- fi
-
- dodoc CHANGELOG CHANGES README USAGE NEWS
- docinto ps
- dodoc doc/*.ps
- dohtml -r doc
-}
-
-pkg_preinst() {
- preserve_old_lib /$(get_libdir)/lib{history,readline}.so.{4,5} #29865
-}
-
-pkg_postinst() {
- preserve_old_lib_notify /$(get_libdir)/lib{history,readline}.so.{4,5}
-}
diff --git a/sys-libs/readline/readline-6.2_p1-r1.ebuild b/sys-libs/readline/readline-6.2_p1-r1.ebuild
deleted file mode 100644
index ac7bf623e715..000000000000
--- a/sys-libs/readline/readline-6.2_p1-r1.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-6.2_p1-r1.ebuild,v 1.4 2012/04/30 01:36:43 vapier Exp $
-
-inherit eutils multilib toolchain-funcs flag-o-matic
-
-# Official patches
-# See ftp://ftp.cwru.edu/pub/bash/readline-6.0-patches/
-PLEVEL=${PV##*_p}
-MY_PV=${PV/_p*}
-MY_PV=${MY_PV/_/-}
-MY_P=${PN}-${MY_PV}
-[[ ${PV} != *_p* ]] && PLEVEL=0
-patches() {
- [[ ${PLEVEL} -eq 0 ]] && return 1
- local opt=$1
- eval set -- {1..${PLEVEL}}
- set -- $(printf "${PN}${MY_PV/\.}-%03d " "$@")
- if [[ ${opt} == -s ]] ; then
- echo "${@/#/${DISTDIR}/}"
- else
- local u
- for u in ftp://ftp.cwru.edu/pub/bash mirror://gnu/${PN} ; do
- printf "${u}/${PN}-${MY_PV}-patches/%s " "$@"
- done
- fi
-}
-
-DESCRIPTION="Another cute console display library"
-HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
-SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz $(patches)"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="static-libs"
-
-RDEPEND=">=sys-libs/ncurses-5.2-r2"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
-
- cd "${S}"
- [[ ${PLEVEL} -gt 0 ]] && epatch $(patches -s)
- epatch "${FILESDIR}"/${PN}-5.0-no_rpath.patch
- epatch "${FILESDIR}"/${PN}-5.2-no-ignore-shlib-errors.patch #216952
-
- # force ncurses linking #71420
- sed -i -e 's:^SHLIB_LIBS=:SHLIB_LIBS=-lncurses:' support/shobj-conf || die "sed"
-
- # fix building under Gentoo/FreeBSD; upstream FreeBSD deprecated
- # objformat for years, so we don't want to rely on that.
- sed -i -e '/objformat/s:if .*; then:if true; then:' support/shobj-conf || die
-
- ln -s ../.. examples/rlfe/readline # for local readline headers
-}
-
-src_compile() {
- # fix implicit decls with widechar funcs
- append-cppflags -D_GNU_SOURCE
- # http://lists.gnu.org/archive/html/bug-readline/2010-07/msg00013.html
- append-cppflags -Dxrealloc=_rl_realloc -Dxmalloc=_rl_malloc -Dxfree=_rl_free
-
- # This is for rlfe, but we need to make sure LDFLAGS doesn't change
- # so we can re-use the config cache file between the two.
- append-ldflags -L.
- econf \
- --cache-file="${S}"/config.cache \
- --with-curses \
- $(use_enable static-libs static)
- emake || die
-
- if ! tc-is-cross-compiler ; then
- # code is full of AC_TRY_RUN()
- cd examples/rlfe
- local l
- for l in readline history ; do
- ln -s ../../shlib/lib${l}$(get_libname)* lib${l}$(get_libname)
- ln -sf ../../lib${l}.a lib${l}.a
- done
- econf --cache-file="${S}"/config.cache
- emake || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- gen_usr_ldscript -a readline history #4411
-
- if ! tc-is-cross-compiler; then
- dobin examples/rlfe/rlfe || die
- fi
-
- dodoc CHANGELOG CHANGES README USAGE NEWS
- docinto ps
- dodoc doc/*.ps
- dohtml -r doc
-}
-
-pkg_preinst() {
- preserve_old_lib /$(get_libdir)/lib{history,readline}.so.{4,5} #29865
-}
-
-pkg_postinst() {
- preserve_old_lib_notify /$(get_libdir)/lib{history,readline}.so.{4,5}
-}
diff --git a/sys-libs/readline/readline-6.2_p4.ebuild b/sys-libs/readline/readline-6.2_p4.ebuild
deleted file mode 100644
index 6283b9355890..000000000000
--- a/sys-libs/readline/readline-6.2_p4.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-6.2_p4.ebuild,v 1.2 2013/02/17 23:40:35 zmedico Exp $
-
-inherit eutils multilib toolchain-funcs flag-o-matic
-
-# Official patches
-# See ftp://ftp.cwru.edu/pub/bash/readline-6.0-patches/
-PLEVEL=${PV##*_p}
-MY_PV=${PV/_p*}
-MY_PV=${MY_PV/_/-}
-MY_P=${PN}-${MY_PV}
-[[ ${PV} != *_p* ]] && PLEVEL=0
-patches() {
- [[ ${PLEVEL} -eq 0 ]] && return 1
- local opt=$1
- eval set -- {1..${PLEVEL}}
- set -- $(printf "${PN}${MY_PV/\.}-%03d " "$@")
- if [[ ${opt} == -s ]] ; then
- echo "${@/#/${DISTDIR}/}"
- else
- local u
- for u in ftp://ftp.cwru.edu/pub/bash mirror://gnu/${PN} ; do
- printf "${u}/${PN}-${MY_PV}-patches/%s " "$@"
- done
- fi
-}
-
-DESCRIPTION="Another cute console display library"
-HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
-SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz $(patches)"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
-IUSE="static-libs"
-
-RDEPEND=">=sys-libs/ncurses-5.2-r2"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
-
- cd "${S}"
- [[ ${PLEVEL} -gt 0 ]] && epatch $(patches -s)
- epatch "${FILESDIR}"/${PN}-5.0-no_rpath.patch
- epatch "${FILESDIR}"/${PN}-5.2-no-ignore-shlib-errors.patch #216952
-
- # force ncurses linking #71420
- sed -i -e 's:^SHLIB_LIBS=:SHLIB_LIBS=-lncurses:' support/shobj-conf || die "sed"
-
- # fix building under Gentoo/FreeBSD; upstream FreeBSD deprecated
- # objformat for years, so we don't want to rely on that.
- sed -i -e '/objformat/s:if .*; then:if true; then:' support/shobj-conf || die
-
- ln -s ../.. examples/rlfe/readline # for local readline headers
-}
-
-src_compile() {
- # fix implicit decls with widechar funcs
- append-cppflags -D_GNU_SOURCE
- # http://lists.gnu.org/archive/html/bug-readline/2010-07/msg00013.html
- append-cppflags -Dxrealloc=_rl_realloc -Dxmalloc=_rl_malloc -Dxfree=_rl_free
-
- # This is for rlfe, but we need to make sure LDFLAGS doesn't change
- # so we can re-use the config cache file between the two.
- append-ldflags -L.
- econf \
- --cache-file="${S}"/config.cache \
- --with-curses \
- $(use_enable static-libs static)
- emake || die
-
- if ! tc-is-cross-compiler ; then
- # code is full of AC_TRY_RUN()
- cd examples/rlfe
- local l
- for l in readline history ; do
- ln -s ../../shlib/lib${l}$(get_libname)* lib${l}$(get_libname)
- ln -sf ../../lib${l}.a lib${l}.a
- done
- econf --cache-file="${S}"/config.cache
- emake || die
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- gen_usr_ldscript -a readline history #4411
-
- if ! tc-is-cross-compiler; then
- dobin examples/rlfe/rlfe || die
- fi
-
- dodoc CHANGELOG CHANGES README USAGE NEWS
- docinto ps
- dodoc doc/*.ps
- dohtml -r doc
-}
-
-pkg_preinst() {
- preserve_old_lib /$(get_libdir)/lib{history,readline}.so.{4,5} #29865
-}
-
-pkg_postinst() {
- preserve_old_lib_notify /$(get_libdir)/lib{history,readline}.so.{4,5}
-}
diff --git a/sys-libs/readline/readline-6.2_p5.ebuild b/sys-libs/readline/readline-6.2_p5.ebuild
deleted file mode 100644
index dc77109aa807..000000000000
--- a/sys-libs/readline/readline-6.2_p5.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-6.2_p5.ebuild,v 1.2 2013/12/25 23:46:50 vapier Exp $
-
-EAPI="4"
-
-inherit eutils multilib toolchain-funcs flag-o-matic
-
-# Official patches
-# See ftp://ftp.cwru.edu/pub/bash/readline-6.2-patches/
-PLEVEL=${PV##*_p}
-MY_PV=${PV/_p*}
-MY_PV=${MY_PV/_/-}
-MY_P=${PN}-${MY_PV}
-[[ ${PV} != *_p* ]] && PLEVEL=0
-patches() {
- [[ ${PLEVEL} -eq 0 ]] && return 1
- local opt=$1
- eval set -- {1..${PLEVEL}}
- set -- $(printf "${PN}${MY_PV/\.}-%03d " "$@")
- if [[ ${opt} == -s ]] ; then
- echo "${@/#/${DISTDIR}/}"
- else
- local u
- for u in ftp://ftp.cwru.edu/pub/bash mirror://gnu/${PN} ; do
- printf "${u}/${PN}-${MY_PV}-patches/%s " "$@"
- done
- fi
-}
-
-DESCRIPTION="Another cute console display library"
-HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
-SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz $(patches)"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
-IUSE="static-libs"
-
-RDEPEND=">=sys-libs/ncurses-5.2-r2"
-DEPEND="${RDEPEND}"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${MY_P}.tar.gz
-}
-
-src_prepare() {
- [[ ${PLEVEL} -gt 0 ]] && epatch $(patches -s)
- epatch "${FILESDIR}"/${PN}-5.0-no_rpath.patch
- epatch "${FILESDIR}"/${PN}-5.2-no-ignore-shlib-errors.patch #216952
- epatch "${FILESDIR}"/${PN}-6.2-rlfe-tgoto.patch #385091
-
- # Force ncurses linking. #71420
- # Use pkg-config to get the right values. #457558
- sed -i \
- -e "s:^SHLIB_LIBS=:SHLIB_LIBS='$($(tc-getPKG_CONFIG) ncurses --libs)':" \
- support/shobj-conf || die
-
- # fix building under Gentoo/FreeBSD; upstream FreeBSD deprecated
- # objformat for years, so we don't want to rely on that.
- sed -i -e '/objformat/s:if .*; then:if true; then:' support/shobj-conf || die
-
- ln -s ../.. examples/rlfe/readline # for local readline headers
-}
-
-src_configure() {
- # fix implicit decls with widechar funcs
- append-cppflags -D_GNU_SOURCE
- # http://lists.gnu.org/archive/html/bug-readline/2010-07/msg00013.html
- append-cppflags -Dxrealloc=_rl_realloc -Dxmalloc=_rl_malloc -Dxfree=_rl_free
-
- # Force the test since we used sed above to force it.
- export bash_cv_termcap_lib=ncurses
-
- # Make sure configure picks a better ar than `ar`. #484866
- tc-export AR
-
- # This is for rlfe, but we need to make sure LDFLAGS doesn't change
- # so we can re-use the config cache file between the two.
- append-ldflags -L.
- econf \
- --cache-file="${S}"/config.cache \
- --with-curses \
- $(use_enable static-libs static)
-
- if ! tc-is-cross-compiler ; then
- # code is full of AC_TRY_RUN()
- cd examples/rlfe
- econf --cache-file="${S}"/config.cache
- fi
-}
-
-src_compile() {
- emake
-
- if ! tc-is-cross-compiler ; then
- # code is full of AC_TRY_RUN()
- cd examples/rlfe
- local l
- for l in readline history ; do
- ln -s ../../shlib/lib${l}$(get_libname)* lib${l}$(get_libname)
- ln -sf ../../lib${l}.a lib${l}.a
- done
- emake
- fi
-}
-
-src_install() {
- default
- gen_usr_ldscript -a readline history #4411
-
- if ! tc-is-cross-compiler; then
- dobin examples/rlfe/rlfe
- fi
-
- dodoc USAGE
- docinto ps
- dodoc doc/*.ps
- dohtml -r doc
-}
-
-pkg_preinst() {
- preserve_old_lib /$(get_libdir)/lib{history,readline}.so.{4,5} #29865
-}
-
-pkg_postinst() {
- preserve_old_lib_notify /$(get_libdir)/lib{history,readline}.so.{4,5}
-}