summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-04-12 09:44:09 +0000
committerAchim Gottinger <achim@gentoo.org>2001-04-12 09:44:09 +0000
commitef3d08609c639c43797692ae8f1f8b06f8c92ad5 (patch)
tree90302d28b002bb9d3c7485a8a80db443919d7429 /sys-libs
parentUpdate and dependencie fix (diff)
downloadgentoo-2-ef3d08609c639c43797692ae8f1f8b06f8c92ad5.tar.gz
gentoo-2-ef3d08609c639c43797692ae8f1f8b06f8c92ad5.tar.bz2
gentoo-2-ef3d08609c639c43797692ae8f1f8b06f8c92ad5.zip
Update, required for bash-2.05
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/readline/files/digest-readline-4.21
-rw-r--r--sys-libs/readline/readline-4.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/sys-libs/readline/files/digest-readline-4.2 b/sys-libs/readline/files/digest-readline-4.2
new file mode 100644
index 000000000000..ee3d6c346f48
--- /dev/null
+++ b/sys-libs/readline/files/digest-readline-4.2
@@ -0,0 +1 @@
+MD5 1005aef64e772b369c4421785334a3f5 readline-4.2.tar.gz
diff --git a/sys-libs/readline/readline-4.2.ebuild b/sys-libs/readline/readline-4.2.ebuild
new file mode 100644
index 000000000000..ad65c28c1899
--- /dev/null
+++ b/sys-libs/readline/readline-4.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-4.2.ebuild,v 1.1 2001/04/12 09:44:09 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Another cute console display library"
+SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/readline/${A}
+ ftp://ftp.gnu.org/gnu/readline/${A}"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2-r2"
+
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ try ./configure --host=${CHOST} --with-curses \
+ --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info
+ try make ${MAKEOPTS}
+ cd shlib
+ try make ${MAKEOPTS}
+
+}
+
+
+src_install() {
+
+ try make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
+ cd shlib
+ try make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
+
+ cd ..
+
+ dodir /lib
+ mv ${D}/usr/lib/*.so* ${D}/lib
+ dosym libhistory.so.${PV} /lib/libhistory.so
+ dosym libreadline.so.${PV} /lib/libreadline.so
+ # Needed because make install uses ${D} for the link
+ dosym libhistory.so.${PV} /lib/libhistory.so.4
+ dosym libreadline.so.${PV} /lib/libreadline.so.4
+ chmod 755 ${D}/lib/*.${PV}
+
+ dodoc CHANGELOG CHANGES COPYING MANIFEST README USAGE
+ docinto ps
+ dodoc doc/*.ps
+ docinto html
+ dodoc doc/*.html
+
+
+}
+
+
+
+