summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2012-09-23 18:44:44 +0000
committerVictor Ostorga <vostorga@gentoo.org>2012-09-23 18:44:44 +0000
commitfbfc5ff0f17a8412880dfc3f9d905c6a304eb072 (patch)
tree5c7cff8d0c3a7b07a9cf3cdcd75fd533e5ac3b08 /sys-libs
parentalpha/ia64/m68k/s390/sh/sparc stable wrt #431950 (diff)
downloadgentoo-2-fbfc5ff0f17a8412880dfc3f9d905c6a304eb072.tar.gz
gentoo-2-fbfc5ff0f17a8412880dfc3f9d905c6a304eb072.tar.bz2
gentoo-2-fbfc5ff0f17a8412880dfc3f9d905c6a304eb072.zip
Version bump to 0.9.17
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/tevent/ChangeLog7
-rw-r--r--sys-libs/tevent/tevent-0.9.17.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/sys-libs/tevent/ChangeLog b/sys-libs/tevent/ChangeLog
index ac46e4ab5d14..ca8856fcf212 100644
--- a/sys-libs/tevent/ChangeLog
+++ b/sys-libs/tevent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/tevent
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/tevent/ChangeLog,v 1.21 2012/09/20 17:53:58 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tevent/ChangeLog,v 1.22 2012/09/23 18:44:44 vostorga Exp $
+
+*tevent-0.9.17 (23 Sep 2012)
+
+ 23 Sep 2012; Víctor Ostorga <vostorga@gentoo.org> +tevent-0.9.17.ebuild:
+ Version bump to 0.9.17
20 Sep 2012; Tomáš Chvátal <scarabeus@gentoo.org>
+files/add-py-file-0.9.14.patch, +files/tevent-version.patch:
diff --git a/sys-libs/tevent/tevent-0.9.17.ebuild b/sys-libs/tevent/tevent-0.9.17.ebuild
new file mode 100644
index 000000000000..172e23f11ef3
--- /dev/null
+++ b/sys-libs/tevent/tevent-0.9.17.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tevent/tevent-0.9.17.ebuild,v 1.1 2012/09/23 18:44:44 vostorga Exp $
+
+EAPI=4
+PYTHON_DEPEND="2:2.4"
+
+inherit waf-utils python
+
+DESCRIPTION="Samba tevent library"
+HOMEPAGE="http://tevent.samba.org/"
+SRC_URI="http://samba.org/ftp/tevent/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=sys-libs/talloc-2.0.6[python]"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ waf-utils_src_install
+ insinto $(python_get_sitedir)
+ doins tevent.py
+}
+
+pkg_postinst() {
+ python_mod_optimize tevent.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup tevent.py
+}