summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Jaroszyński <peper@gentoo.org>2006-10-26 16:33:29 +0000
committerPiotr Jaroszyński <peper@gentoo.org>2006-10-26 16:33:29 +0000
commit8acfedf105f1d489f34ef993921727b9ff2fed66 (patch)
treec57798a7ec5d71722fa96ff546d9f733f418f637 /sys-power/acpi/acpi-0.06-r5.ebuild
parentRemove the dep on find-utils (diff)
downloadgentoo-2-8acfedf105f1d489f34ef993921727b9ff2fed66.tar.gz
gentoo-2-8acfedf105f1d489f34ef993921727b9ff2fed66.tar.bz2
gentoo-2-8acfedf105f1d489f34ef993921727b9ff2fed66.zip
Fix deps and a few other things.
(Portage version: 2.1.2_pre3-r7)
Diffstat (limited to 'sys-power/acpi/acpi-0.06-r5.ebuild')
-rw-r--r--sys-power/acpi/acpi-0.06-r5.ebuild29
1 files changed, 15 insertions, 14 deletions
diff --git a/sys-power/acpi/acpi-0.06-r5.ebuild b/sys-power/acpi/acpi-0.06-r5.ebuild
index db46c120b750..a2dd79572936 100644
--- a/sys-power/acpi/acpi-0.06-r5.ebuild
+++ b/sys-power/acpi/acpi-0.06-r5.ebuild
@@ -1,41 +1,42 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpi/acpi-0.06-r5.ebuild,v 1.1 2005/04/22 18:19:12 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpi/acpi-0.06-r5.ebuild,v 1.2 2006/10/26 16:33:29 peper Exp $
inherit eutils
SRC_URI_BASE="http://ftp.debian.org/debian/pool/main/${PN:0:1}/${PN}"
SRC_URI_TGZ="${PN}_${PV}.orig.tar.gz"
SRC_URI_PATCH="${PN}_${PV}-${PR/r}.diff.gz"
-DESCRIPTION="Attempts to replicate the functionality of the 'old' apm command on ACPI systems, including battery and thermal information."
+DESCRIPTION="Attemp to replicate the functionality of the 'old' apm command on ACPI systems."
HOMEPAGE="http://packages.debian.org/unstable/utils/acpi.html"
-SRC_URI="${SRC_URI_BASE}/${SRC_URI_TGZ} ${SRC_URI_BASE}/${SRC_URI_PATCH}"
+SRC_URI="${SRC_URI_BASE}/${SRC_URI_TGZ}
+ ${SRC_URI_BASE}/${SRC_URI_PATCH}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-* x86 ~amd64"
IUSE=""
-RDEPEND="virtual/libc"
-DEPEND="${RDEPEND}
- sys-apps/help2man
- sys-devel/gcc"
+DEPEND="=sys-devel/automake-1.4*
+ sys-apps/help2man"
+RDEPEND=""
src_unpack() {
unpack ${SRC_URI_TGZ}
mv ${PN} ${P}
- epatch ${DISTDIR}/${SRC_URI_PATCH}
+ epatch "${DISTDIR}/${SRC_URI_PATCH}"
}
src_compile() {
- econf || die
- emake || die
- # build docs
- emake -C doc || die
+ econf || die "econf failed"
+ emake || die "emake failed"
+
+ # build manpage
+ emake -C doc || die "emake doc failed"
}
src_install() {
- einstall || die
+ make DESTDIR="${D}" install || die "make install failed"
doman doc/acpi.1
dodoc AUTHORS CREDITS ChangeLog README
}