summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-12-19 03:06:53 +0000
committerChristoph Junghans <ottxor@gentoo.org>2014-12-19 03:06:53 +0000
commit1634fb0063f29f22ee75e260fd740f195640c57d (patch)
tree14efb6b97bb23d77336365025a944bbcc0966eaa /sys-power/acpi_call
parentAdd upstream patch to avoid memory leak with USE=redis (diff)
downloadgentoo-2-1634fb0063f29f22ee75e260fd740f195640c57d.tar.gz
gentoo-2-1634fb0063f29f22ee75e260fd740f195640c57d.tar.bz2
gentoo-2-1634fb0063f29f22ee75e260fd740f195640c57d.zip
fixed build with linux-3.17 (bug #524614)
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'sys-power/acpi_call')
-rw-r--r--sys-power/acpi_call/ChangeLog10
-rw-r--r--sys-power/acpi_call/acpi_call-1.1.0-r1.ebuild37
-rw-r--r--sys-power/acpi_call/files/acpi_call-1.1.0-linux-3.17.patch26
3 files changed, 71 insertions, 2 deletions
diff --git a/sys-power/acpi_call/ChangeLog b/sys-power/acpi_call/ChangeLog
index a4c7b867de28..8d4fd06271de 100644
--- a/sys-power/acpi_call/ChangeLog
+++ b/sys-power/acpi_call/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/acpi_call
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpi_call/ChangeLog,v 1.7 2013/07/18 14:14:47 ottxor Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpi_call/ChangeLog,v 1.8 2014/12/19 03:06:53 ottxor Exp $
+
+*acpi_call-1.1.0-r1 (19 Dec 2014)
+
+ 19 Dec 2014; Christoph Junghans <ottxor@gentoo.org>
+ +acpi_call-1.1.0-r1.ebuild, +files/acpi_call-1.1.0-linux-3.17.patch:
+ fixed build with linux-3.17 (bug #524614)
*acpi_call-1.1.0 (18 Jul 2013)
diff --git a/sys-power/acpi_call/acpi_call-1.1.0-r1.ebuild b/sys-power/acpi_call/acpi_call-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..974761200f2f
--- /dev/null
+++ b/sys-power/acpi_call/acpi_call-1.1.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpi_call/acpi_call-1.1.0-r1.ebuild,v 1.1 2014/12/19 03:06:53 ottxor Exp $
+
+EAPI=5
+
+inherit eutils linux-info linux-mod
+
+if [ "${PV}" = "9999" ]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/mkottman/acpi_call.git"
+ KEYWORDS=""
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/mkottman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A kernel module that enables you to call ACPI methods"
+HOMEPAGE="http://github.com/mkottman/acpi_call"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+CONFIG_CHECK="ACPI"
+MODULE_NAMES="acpi_call(misc:${S})"
+BUILD_TARGETS="default"
+
+src_prepare(){
+ epatch "${FILESDIR}/${P}-linux-3.17.patch"
+}
+
+src_compile(){
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
+ linux-mod_src_compile
+}
diff --git a/sys-power/acpi_call/files/acpi_call-1.1.0-linux-3.17.patch b/sys-power/acpi_call/files/acpi_call-1.1.0-linux-3.17.patch
new file mode 100644
index 000000000000..32923a488aed
--- /dev/null
+++ b/sys-power/acpi_call/files/acpi_call-1.1.0-linux-3.17.patch
@@ -0,0 +1,26 @@
+From c5b7a4bf93a28e6ce68beb54b48d3745db943e54 Mon Sep 17 00:00:00 2001
+From: Christoph Junghans <ottxor@gentoo.org>
+Date: Mon, 27 Oct 2014 21:57:10 -0600
+Subject: [PATCH] fix build with linux-3.17
+
+https://bugs.gentoo.org/show_bug.cgi?id=524614
+---
+ acpi_call.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/acpi_call.c b/acpi_call.c
+index 3025d97..fa4f2c6 100644
+--- a/acpi_call.c
++++ b/acpi_call.c
+@@ -6,7 +6,7 @@
+ #include <linux/proc_fs.h>
+ #include <linux/slab.h>
+ #include <asm/uaccess.h>
+-#include <acpi/acpi.h>
++#include <linux/acpi.h>
+
+ MODULE_LICENSE("GPL");
+
+--
+2.0.4
+