summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2007-04-28 17:19:15 +0000
committerTorsten Veller <tove@gentoo.org>2007-04-28 17:19:15 +0000
commit3b8bb5ace0d0743924aa0d2c3f4ecfbd39a4e107 (patch)
tree81bd12b825be68176727976ba3731eb80fefc14a /sys-power/cpudyn
parentFix *initd, *confd and *envd calls (#173884, #174266) (diff)
downloadgentoo-2-3b8bb5ace0d0743924aa0d2c3f4ecfbd39a4e107.tar.gz
gentoo-2-3b8bb5ace0d0743924aa0d2c3f4ecfbd39a4e107.tar.bz2
gentoo-2-3b8bb5ace0d0743924aa0d2c3f4ecfbd39a4e107.zip
Fix *initd, *confd and *envd calls (#173884, #174266)
(Portage version: 2.1.2.5)
Diffstat (limited to 'sys-power/cpudyn')
-rw-r--r--sys-power/cpudyn/ChangeLog6
-rw-r--r--sys-power/cpudyn/cpudyn-0.99.0.ebuild18
-rw-r--r--sys-power/cpudyn/cpudyn-1.0.1.ebuild14
-rw-r--r--sys-power/cpudyn/cpudyn-1.0.ebuild14
4 files changed, 27 insertions, 25 deletions
diff --git a/sys-power/cpudyn/ChangeLog b/sys-power/cpudyn/ChangeLog
index 32cef437afa2..0e572e39eadd 100644
--- a/sys-power/cpudyn/ChangeLog
+++ b/sys-power/cpudyn/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-power/cpudyn
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpudyn/ChangeLog,v 1.6 2007/02/22 00:36:29 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpudyn/ChangeLog,v 1.7 2007/04/28 17:19:15 tove Exp $
+
+ 28 Apr 2007; Torsten Veller <tove@gentoo.org> cpudyn-0.99.0.ebuild,
+ cpudyn-1.0.ebuild, cpudyn-1.0.1.ebuild:
+ Fix *initd, *confd and *envd calls (#173884, #174266)
22 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/sys-power/cpudyn/cpudyn-0.99.0.ebuild b/sys-power/cpudyn/cpudyn-0.99.0.ebuild
index eecad06eebb5..bab270e60847 100644
--- a/sys-power/cpudyn/cpudyn-0.99.0.ebuild
+++ b/sys-power/cpudyn/cpudyn-0.99.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpudyn/cpudyn-0.99.0.ebuild,v 1.1 2005/03/14 22:37:27 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpudyn/cpudyn-0.99.0.ebuild,v 1.2 2007/04/28 17:19:15 tove Exp $
inherit eutils
DESCRIPTION="A daemon to control laptop power consumption via cpufreq and disk standby"
-HOMEPAGE="http://mnm.uib.es/~gallir/${PN}/"
+HOMEPAGE="http://mnm.uib.es/~gallir/cpudyn/"
SRC_URI="http://mnm.uib.es/~gallir/${PN}/download/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
@@ -15,11 +15,11 @@ S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
mkdir gentoo
cp debian/cpudyn.conf gentoo
- cp ${FILESDIR}/cpudyn.init gentoo/cpudyn.init
- epatch ${FILESDIR}/${PN}-0.99.0-init_conf_updates.patch
+ cp "${FILESDIR}"/cpudyn.init gentoo/cpudyn.init
+ epatch "${FILESDIR}"/${PN}-0.99.0-init_conf_updates.patch
}
src_compile() {
@@ -28,10 +28,8 @@ src_compile() {
src_install() {
into /
- exeinto /etc/init.d
- newexe gentoo/cpudyn.init cpudyn
- insinto /etc/conf.d
- newins gentoo/cpudyn.conf cpudyn
+ newinitd gentoo/cpudyn.init cpudyn
+ newconfd gentoo/cpudyn.conf cpudyn
into /usr
doman cpudynd.8
diff --git a/sys-power/cpudyn/cpudyn-1.0.1.ebuild b/sys-power/cpudyn/cpudyn-1.0.1.ebuild
index f53d84111a11..d04a9e582959 100644
--- a/sys-power/cpudyn/cpudyn-1.0.1.ebuild
+++ b/sys-power/cpudyn/cpudyn-1.0.1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpudyn/cpudyn-1.0.1.ebuild,v 1.3 2006/07/07 06:21:42 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpudyn/cpudyn-1.0.1.ebuild,v 1.4 2007/04/28 17:19:15 tove Exp $
inherit eutils
DESCRIPTION="A daemon to control laptop power consumption via cpufreq and disk standby"
-HOMEPAGE="http://mnm.uib.es/~gallir/${PN}"
+HOMEPAGE="http://mnm.uib.es/~gallir/cpudyn/"
SRC_URI="http://mnm.uib.es/~gallir/${PN}/download/${P}.tgz"
LICENSE="GPL-2"
@@ -17,8 +17,8 @@ S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
- cd ${S}/debian
- epatch ${FILESDIR}/${PN}-0.99.0-init_conf_updates.patch
+ cd "${S}"/debian
+ epatch "${FILESDIR}"/${PN}-0.99.0-init_conf_updates.patch
}
src_compile() {
@@ -32,8 +32,8 @@ src_install() {
dodoc INSTALL README VERSION changelog
dohtml *.html
- exeinto /etc/init.d ; newexe ${FILESDIR}/cpudyn.init cpudyn
- insinto /etc/conf.d ; newins debian/cpudyn.conf cpudyn
+ newexe "${FILESDIR}"/cpudyn.init cpudyn
+ newins debian/cpudyn.conf cpudyn
}
pkg_postinst() {
diff --git a/sys-power/cpudyn/cpudyn-1.0.ebuild b/sys-power/cpudyn/cpudyn-1.0.ebuild
index ae8dbda3697b..280b0f00dbaa 100644
--- a/sys-power/cpudyn/cpudyn-1.0.ebuild
+++ b/sys-power/cpudyn/cpudyn-1.0.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/cpudyn/cpudyn-1.0.ebuild,v 1.1 2005/03/14 22:37:27 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/cpudyn/cpudyn-1.0.ebuild,v 1.2 2007/04/28 17:19:15 tove Exp $
inherit eutils
DESCRIPTION="A daemon to control laptop power consumption via cpufreq and disk standby"
-HOMEPAGE="http://mnm.uib.es/~gallir/${PN}/"
+HOMEPAGE="http://mnm.uib.es/~gallir/cpudyn/"
SRC_URI="http://mnm.uib.es/~gallir/${PN}/download/${P}.tgz"
LICENSE="GPL-2"
@@ -17,8 +17,8 @@ S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
- cd ${S}/debian
- epatch ${FILESDIR}/${PN}-0.99.0-init_conf_updates.patch
+ cd "${S}"/debian
+ epatch "${FILESDIR}"/${PN}-0.99.0-init_conf_updates.patch
}
src_compile() {
@@ -32,8 +32,8 @@ src_install() {
dodoc INSTALL README VERSION changelog
dohtml *.html
- exeinto /etc/init.d ; newexe ${FILESDIR}/cpudyn.init cpudyn
- insinto /etc/conf.d ; newins debian/cpudyn.conf cpudyn
+ newinitd "${FILESDIR}"/cpudyn.init cpudyn
+ newconfd debian/cpudyn.conf cpudyn
}
pkg_postinst() {