summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-05-04 04:37:01 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-05-04 04:37:01 +0000
commit189f1abc2de89fd473599794ede1e5eb79245feb (patch)
tree45bf182d8f3bbd08070ce6ac8f2e70f30359b120 /sys-power/hibernate-script
parentCleanup (diff)
downloadgentoo-2-189f1abc2de89fd473599794ede1e5eb79245feb.tar.gz
gentoo-2-189f1abc2de89fd473599794ede1e5eb79245feb.tar.bz2
gentoo-2-189f1abc2de89fd473599794ede1e5eb79245feb.zip
Snapshot, all our patches applied and there is a better support for suspend2 as modules
(Portage version: 2.1.2.5)
Diffstat (limited to 'sys-power/hibernate-script')
-rw-r--r--sys-power/hibernate-script/ChangeLog9
-rw-r--r--sys-power/hibernate-script/files/digest-hibernate-script-1.95_beta200705046
-rw-r--r--sys-power/hibernate-script/hibernate-script-1.95_beta20070504.ebuild76
3 files changed, 90 insertions, 1 deletions
diff --git a/sys-power/hibernate-script/ChangeLog b/sys-power/hibernate-script/ChangeLog
index c0bd0f6de9a1..e429cb6628ad 100644
--- a/sys-power/hibernate-script/ChangeLog
+++ b/sys-power/hibernate-script/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-power/hibernate-script
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.52 2007/04/09 05:09:32 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.53 2007/05/04 04:37:01 alonbl Exp $
+
+*hibernate-script-1.95_beta20070504 (04 May 2007)
+
+ 04 May 2007; Alon Bar-Lev <alonbl@gentoo.org>
+ +hibernate-script-1.95_beta20070504.ebuild:
+ Snapshot, all our patches applied and there is a better support for suspend2
+ as modules
09 Apr 2007; Peter Weller <welp@gentoo.org>
hibernate-script-1.94-r5.ebuild:
diff --git a/sys-power/hibernate-script/files/digest-hibernate-script-1.95_beta20070504 b/sys-power/hibernate-script/files/digest-hibernate-script-1.95_beta20070504
new file mode 100644
index 000000000000..3fabba3ec966
--- /dev/null
+++ b/sys-power/hibernate-script/files/digest-hibernate-script-1.95_beta20070504
@@ -0,0 +1,6 @@
+MD5 d276f316cb18f35c8275de8abedcbb3b hibernate-script-1.95_beta20070504-patches-1.tar.bz2 1220
+RMD160 18c273d4e692d06a3c8e5f1107ad35d3dee26eac hibernate-script-1.95_beta20070504-patches-1.tar.bz2 1220
+SHA256 dd3afe794a9945f8b46596dbf435210224fb9bdb78a500e94dd816aba3b9cbfc hibernate-script-1.95_beta20070504-patches-1.tar.bz2 1220
+MD5 025a661a95aba9f0ca678907dcb5dde2 hibernate-script-1.95_beta20070504.tar.gz 74733
+RMD160 b552ad412a7846bc52599ee5f2797cb2203ded31 hibernate-script-1.95_beta20070504.tar.gz 74733
+SHA256 cb4d4e42b7c2d349c13e559fe1e785547eab0089dfcabf03a6926ff6bbc4595c hibernate-script-1.95_beta20070504.tar.gz 74733
diff --git a/sys-power/hibernate-script/hibernate-script-1.95_beta20070504.ebuild b/sys-power/hibernate-script/hibernate-script-1.95_beta20070504.ebuild
new file mode 100644
index 000000000000..400499e074a1
--- /dev/null
+++ b/sys-power/hibernate-script/hibernate-script-1.95_beta20070504.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/hibernate-script-1.95_beta20070504.ebuild,v 1.1 2007/05/04 04:37:01 alonbl Exp $
+
+inherit eutils
+
+PATCH_VERSION="1"
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.suspend2.net/"
+SRC_URI="http://www.suspend2.net/downloads/all/${P}.tar.gz
+ mirror://gentoo/${P}-patches-${PATCH_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="logrotate vim"
+
+DEPEND="sys-apps/sed"
+RDEPEND="logrotate? ( app-admin/logrotate )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Our patches
+ epatch "${WORKDIR}"/patches/*.patch
+}
+
+src_install() {
+ BASE_DIR="${D}" \
+ DISTRIBUTION="gentoo" \
+ PREFIX="/usr" \
+ MAN_DIR="${D}/usr/share/man" \
+ "${S}/install.sh" || die "Install failed"
+
+ # hibernate-ram will default to using ram.conf
+ dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+ newinitd "${S}"/init.d/hibernate-cleanup.sh hibernate-cleanup
+
+ # other ebuilds can install scriplets to this dir
+ keepdir /etc/hibernate/scriptlets.d/
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles
+ doins hibernate.vim
+ fi
+
+ dodoc CHANGELOG README SCRIPTLET-API hibernate.vim
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${S}"/logrotate.d-hibernate-script hibernate-script
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog "You should run the following command to invalidate"
+ elog "suspend images on a clean boot."
+ elog
+ elog " # rc-update add hibernate-cleanup boot"
+ elog
+ elog "See /usr/share/doc/${PF}/README.* for further details."
+ elog
+ elog "Please note that you will need to manually emerge any utilities"
+ elog "(radeontool, vbetool, ...) enabled in the configuration files,"
+ elog "should you wish to use them."
+ elog
+ elog "Starting with hibernate-script-1.90 the configuration files have"
+ elog "been reordered and split into method specific files. Make sure you"
+ elog "update your /etc/hibernate/ configuration files accordingly."
+ elog
+}