summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2007-11-04 14:28:17 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2007-11-04 14:28:17 +0000
commit12d9b5a7423cd9d3af3981ab89609ae3885eebb2 (patch)
tree0bcb5491a9ae7e065ea64fc765c354d7c2c4e17d /sys-power/ncpufreqd/ncpufreqd-2.4.ebuild
parentStable on amd64 wrt bug #195220 (diff)
downloadgentoo-2-12d9b5a7423cd9d3af3981ab89609ae3885eebb2.tar.gz
gentoo-2-12d9b5a7423cd9d3af3981ab89609ae3885eebb2.tar.bz2
gentoo-2-12d9b5a7423cd9d3af3981ab89609ae3885eebb2.zip
Use cmake-utils eclass.
(Portage version: 2.1.3.17)
Diffstat (limited to 'sys-power/ncpufreqd/ncpufreqd-2.4.ebuild')
-rw-r--r--sys-power/ncpufreqd/ncpufreqd-2.4.ebuild25
1 files changed, 5 insertions, 20 deletions
diff --git a/sys-power/ncpufreqd/ncpufreqd-2.4.ebuild b/sys-power/ncpufreqd/ncpufreqd-2.4.ebuild
index a495d4db5766..1ed3639876d6 100644
--- a/sys-power/ncpufreqd/ncpufreqd-2.4.ebuild
+++ b/sys-power/ncpufreqd/ncpufreqd-2.4.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/ncpufreqd/ncpufreqd-2.4.ebuild,v 1.1 2007/10/29 19:06:38 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/ncpufreqd/ncpufreqd-2.4.ebuild,v 1.2 2007/11/04 14:28:17 nelchael Exp $
+
+inherit cmake-utils
DESCRIPTION="Daemon controlling CPU speed and temperature"
HOMEPAGE="http://projects.simpledesigns.com.pl/project/ncpufreqd/"
@@ -12,28 +14,11 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND="dev-util/cmake
- virtual/logger"
-
-src_compile() {
-
- mkdir "${T}/build"
- cd "${T}/build"
-
- cmake \
- -DCMAKE_INSTALL_PREFIX=/usr/ \
- -DCMAKE_C_FLAGS="${CFLAGS}" \
- "${S}" || die "cmake failed"
-
- emake || die "emake failed"
-
-}
+DEPEND="virtual/logger"
src_install() {
- cd "${T}/build"
-
- make DESTDIR="${D}" install || die "emake install failed"
+ cmake-utils_src_install
cd "${S}"