summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-02-25 02:57:28 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-02-25 02:57:28 +0000
commit373dfb04885f32a765ef160a7a1f8532b9dfe413 (patch)
tree41eda65d52dcf5b6465aa7eb1dd707eaffd11385 /sys-power/nut
parentVersion bumped. Removed old versions. (diff)
downloadgentoo-2-373dfb04885f32a765ef160a7a1f8532b9dfe413.tar.gz
gentoo-2-373dfb04885f32a765ef160a7a1f8532b9dfe413.tar.bz2
gentoo-2-373dfb04885f32a765ef160a7a1f8532b9dfe413.zip
Version bump, bug #162657.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'sys-power/nut')
-rw-r--r--sys-power/nut/ChangeLog10
-rw-r--r--sys-power/nut/files/digest-nut-2.0.53
-rw-r--r--sys-power/nut/files/upsstats-upsset-link-2.0.5.patch15
-rw-r--r--sys-power/nut/nut-2.0.5.ebuild186
4 files changed, 212 insertions, 2 deletions
diff --git a/sys-power/nut/ChangeLog b/sys-power/nut/ChangeLog
index 803a570128c7..e0bfcc4fb17c 100644
--- a/sys-power/nut/ChangeLog
+++ b/sys-power/nut/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/nut
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/ChangeLog,v 1.25 2006/10/26 22:05:34 blubb Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/ChangeLog,v 1.26 2007/02/25 02:57:28 robbat2 Exp $
+
+*nut-2.0.5 (25 Feb 2007)
+
+ 25 Feb 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +files/upsstats-upsset-link-2.0.5.patch, +nut-2.0.5.ebuild:
+ Version bump, bug #162657.
26 Oct 2006; <blubb@gentoo.org> nut-2.0.4-r1.ebuild:
back to ~amd64 because libusb was de-keyworded as well; bug 148013 comment
diff --git a/sys-power/nut/files/digest-nut-2.0.5 b/sys-power/nut/files/digest-nut-2.0.5
new file mode 100644
index 000000000000..782b3150a09e
--- /dev/null
+++ b/sys-power/nut/files/digest-nut-2.0.5
@@ -0,0 +1,3 @@
+MD5 b08fde86191154bbcfda860f95a5dca2 nut-2.0.5.tar.gz 809006
+RMD160 e5f90a73932e038d3dfee8cb32faf097d99a7e0b nut-2.0.5.tar.gz 809006
+SHA256 5e1bfecfca528104db7025050c81258ee20620df7497ab5988ad461d951c8203 nut-2.0.5.tar.gz 809006
diff --git a/sys-power/nut/files/upsstats-upsset-link-2.0.5.patch b/sys-power/nut/files/upsstats-upsset-link-2.0.5.patch
new file mode 100644
index 000000000000..db48b1aa3eae
--- /dev/null
+++ b/sys-power/nut/files/upsstats-upsset-link-2.0.5.patch
@@ -0,0 +1,15 @@
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+Date: Sat, 24 Feb 2007 18:43:09 -0800
+
+Include a link to the upsset page from the stats page.
+
+--- nut-2.0.5.orig/conf/upsstats.html 2006-11-07 18:08:45.000000000 -0800
++++ nut-2.0.5/conf/upsstats.html 2007-02-24 18:41:06.000000000 -0800
+@@ -177,6 +177,7 @@
+
+ </td></tr>
+ </table>
++<p style="text-align: center"><a href="upsset.cgi">Settings &amp; Commands</a></p>
+
+ <hr /><div><small>
+ <a href="http://jigsaw.w3.org/css-validator/check/referer"><img style="float:right" src="http://jigsaw.w3.org/css-validator/images/vcss" alt="Valid CSS!" height="31" width="88"/></a>
diff --git a/sys-power/nut/nut-2.0.5.ebuild b/sys-power/nut/nut-2.0.5.ebuild
new file mode 100644
index 000000000000..22c46f6aa356
--- /dev/null
+++ b/sys-power/nut/nut-2.0.5.ebuild
@@ -0,0 +1,186 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/nut/nut-2.0.5.ebuild,v 1.1 2007/02/25 02:57:28 robbat2 Exp $
+
+inherit eutils fixheadtails
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="Network-UPS Tools"
+HOMEPAGE="http://www.networkupstools.org/"
+# Nut mirrors are presently broken
+#SRC_URI="mirror://nut/source/${PV%.*}/${MY_P}.tar.gz"
+SRC_URI="http://www.networkupstools.org/source/${PV%.*}/${MY_P}.tar.gz"
+
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="cgi snmp usb ssl"
+
+RDEPEND="cgi? ( >=media-libs/gd-2 )
+ snmp? ( net-analyzer/net-snmp )
+ usb? ( >=dev-libs/libusb-0.1.12 )
+ ssl? ( dev-libs/openssl )"
+DEPEND="$RDEPEND
+ >=sys-apps/sed-4
+ >=sys-devel/autoconf-2.58"
+
+# public files should be 644 root:root
+NUT_PUBLIC_FILES="/etc/nut/{{hosts,upsset,ups,upssched}.conf,upsstats{,-single}.html}"
+# private files should be 640 root:nut - readable by nut, writeable by root,
+NUT_PRIVATE_FILES="/etc/nut/{upsd.conf,upsd.users,upsmon.conf}"
+
+pkg_setup() {
+ enewgroup nut 84
+ enewuser nut 84 -1 /var/state/nut nut,tty
+ # try to add nut to the tty group for old cases where it already existed
+ gpasswd -a nut tty
+ warningmsg
+}
+
+src_unpack() {
+ unpack ${A}
+
+ EPATCH_OPTS="-p1 -d ${S}" epatch ${FILESDIR}/upsstats-upsset-link-2.0.5.patch
+
+ cd "${S}"
+
+ sed -e "s/install: install-dirs/install: install-dirs install-conf/" \
+ -i Makefile.in || die "sed failed"
+
+ ht_fix_file configure.in
+
+ sed -e "s:GD_LIBS.*=.*-L/usr/X11R6/lib \(.*\) -lXpm -lX11:GD_LIBS=\"\1:" \
+ -i configure.in || die "sed failed"
+
+ ebegin "Recreating configure"
+ WANT_AUTOCONF=2.5 autoconf || die "autoconf failed"
+ eend $?
+}
+
+src_compile() {
+ local myconf
+
+ if [ -n "${NUT_DRIVERS}" ]; then
+ myconf="${myconf} --with-drivers=${NUT_DRIVERS// /,}"
+ fi
+
+ econf \
+ --with-user=nut \
+ --with-group=nut \
+ --with-drvpath=/lib/nut \
+ --sysconfdir=/etc/nut \
+ --with-logfacility=LOG_DAEMON \
+ --with-statepath=/var/lib/nut \
+ $(use_with ssl) \
+ $(use_with cgi) \
+ $(use_with cgi cgipath /usr/share/nut) \
+ ${myconf} || die "econf failed"
+
+ emake || die "compile problem"
+
+ if use snmp; then
+ emake snmp || die "snmp compile problem"
+ fi
+
+ if use usb; then
+ emake usb || die "usb compile problem"
+ fi
+
+ if use cgi; then
+ emake cgi || die "cgi compile problem"
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install install-lib || die "make install failed"
+
+ dodir /sbin
+ dosym /lib/nut/upsdrvctl /sbin/upsdrvctl
+ # This needs to exist for the scripts
+ dosym /lib/nut/upsdrvctl /usr/sbin/upsdrvctl
+
+ if use snmp; then
+ make DESTDIR="${D}" install-snmp || die "make install-snmp failed"
+ fi
+
+ if use usb; then
+ make DESTDIR="${D}" install-usb || die "make install-usb failed"
+ fi
+
+ if use cgi; then
+ make DESTDIR="${D}" install-cgi || die "make install-cgi failed"
+ make DESTDIR="${D}" install-cgi-conf || die "make install-cgi-conf failed"
+ einfo "CGI monitoring scripts are installed in /usr/share/nut."
+ einfo "copy them to your web server's ScriptPath to activate."
+ einfo "If you use lighttpd, see lighttpd_nut.conf in the documentation."
+ fi
+
+ # this must be done after all of the install phases
+ for i in "${D}"/etc/nut/*.sample ; do
+ mv "${i}" "${i/.sample/}"
+ done
+
+
+ dodoc ChangeLog CREDITS INSTALL MAINTAINERS NEWS README UPGRADING \
+ docs/{FAQ,*.txt}
+
+ newdoc lib/README README.lib
+
+ dodoc ${FILESDIR}/lighttpd_nut.conf
+
+ docinto cables
+ dodoc docs/cables/*
+
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/upsd.rc6" upsd
+ newexe "${FILESDIR}/upsdrv.rc6-r1" upsdrv
+ newexe "${FILESDIR}/upsmon.rc6" upsmon
+
+ # This sets up permissions for nut to access a UPS
+ insinto /etc/udev/rules.d/
+ newins scripts/hotplug-ng/nut-usbups.rules 70-nut-usbups.rules
+
+ keepdir /var/lib/nut
+
+ fperms 0700 /var/lib/nut
+ fowners nut:nut /var/lib/nut
+
+ eval fperms 0640 ${NUT_PRIVATE_FILES}
+ eval fowners root:nut ${NUT_PRIVATE_FILES}
+
+ eval fperms 0644 ${NUT_PUBLIC_FILES}
+ eval fowners root:root ${NUT_PUBLIC_FILES}
+
+ # this is installed for 2.4 and fbsd guys
+ if ! has_version sys-fs/udev; then
+ insinto /etc/hotplug/usb
+ insopts -m 755
+ doins scripts/hotplug-ng/nut-usbups.hotplug
+ fi
+}
+
+pkg_postinst() {
+ # this is to ensure that everybody that installed old versions still has
+ # correct permissions
+ chown nut:nut ${ROOT}/var/lib/nut 2>/dev/null
+ chmod 0700 ${ROOT}/var/lib/nut 2>/dev/null
+
+ eval chown root:nut ${ROOT}${NUT_PRIVATE_FILES} 2>/dev/null
+ eval chmod 0640 ${ROOT}${NUT_PRIVATE_FILES} 2>/dev/null
+
+ eval chown root:root ${ROOT}${NUT_PUBLIC_FILES} 2>/dev/null
+ eval chmod 0644 ${ROOT}${NUT_PUBLIC_FILES} 2>/dev/null
+
+ warningmsg
+}
+
+warningmsg() {
+ ewarn "Please note that NUT now runs under the 'nut' user."
+ ewarn "NUT is in the tty group for access to RS-232 UPS."
+ ewarn "However if you use a USB UPS you may need to look at the udev or"
+ ewarn "hotplug rules that are installed."
+}