summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-11-18 08:45:18 +0000
committerMichael Weber <xmw@gentoo.org>2011-11-18 08:45:18 +0000
commit55c97700f241b925dec682c290a02a86ce7ea16f (patch)
tree38324c4e383e5502ad18d47aa646d1df68c90d9c /sys-power
parentFixed init script for multislotting. Bug 390307. Thanks to Guillaume Castagni... (diff)
downloadgentoo-2-55c97700f241b925dec682c290a02a86ce7ea16f.tar.gz
gentoo-2-55c97700f241b925dec682c290a02a86ce7ea16f.tar.bz2
gentoo-2-55c97700f241b925dec682c290a02a86ce7ea16f.zip
Version bump. Add linux 3 warning (bug 376441).
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/phc-k8/ChangeLog10
-rw-r--r--sys-power/phc-k8/phc-k8-0.4.3.ebuild27
-rw-r--r--sys-power/phc-k8/phc-k8-0.4.4.ebuild48
3 files changed, 75 insertions, 10 deletions
diff --git a/sys-power/phc-k8/ChangeLog b/sys-power/phc-k8/ChangeLog
index 878125c1cef2..868fa2810dc5 100644
--- a/sys-power/phc-k8/ChangeLog
+++ b/sys-power/phc-k8/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/phc-k8
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/phc-k8/ChangeLog,v 1.3 2010/12/04 19:34:35 xmw Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/phc-k8/ChangeLog,v 1.4 2011/11/18 08:45:18 xmw Exp $
+
+*phc-k8-0.4.4 (18 Nov 2011)
+
+ 18 Nov 2011; Michael Weber <xmw@gentoo.org> phc-k8-0.4.3.ebuild,
+ +phc-k8-0.4.4.ebuild:
+ Version bump. Add linux 3 warning (bug 376441).
*phc-k8-0.4.3 (04 Dec 2010)
diff --git a/sys-power/phc-k8/phc-k8-0.4.3.ebuild b/sys-power/phc-k8/phc-k8-0.4.3.ebuild
index 5c1eff8647ae..d505be41d104 100644
--- a/sys-power/phc-k8/phc-k8-0.4.3.ebuild
+++ b/sys-power/phc-k8/phc-k8-0.4.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/phc-k8/phc-k8-0.4.3.ebuild,v 1.1 2010/12/04 19:34:35 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/phc-k8/phc-k8-0.4.3.ebuild,v 1.2 2011/11/18 08:45:18 xmw Exp $
-EAPI=2
+EAPI=4
inherit linux-info linux-mod
@@ -17,14 +17,25 @@ IUSE=""
S=${WORKDIR}/${PN}_v${PV}
-CONFIG_CHECK="~!X86_POWERNOW_K8"
-ERROR_X86_POWERNOW_K8="CONFIG_X86_POWERNOW_K8 should be configured to Module, to
+pkg_pretend() {
+ if kernel_is gt 3 0 0 ; then
+ eerror "This version is not compartible with linux 3.x (bug 376441)"
+ eerror "Please use >=sys-power/phc-k8-0.4.4 !"
+ einfo ; einfo ; einfo
+ die "wrong kernel version"
+ fi
+}
+
+pkg_setup() {
+ CONFIG_CHECK="~!X86_POWERNOW_K8"
+ ERROR_X86_POWERNOW_K8="CONFIG_X86_POWERNOW_K8 should be configured to Module, to
a) include needed symbol cpufreq_get_measured_perf and
b) enable the replacemant of powernow-k8 with phc-k8."
-MODULE_NAMES="phc-k8(misc:)"
-BUILD_PARAMS="KERNELSRC=\"${KERNEL_DIR}\" -j1"
-BUILD_TARGETS="all"
+ MODULE_NAMES="phc-k8(misc:)"
+ BUILD_PARAMS="KERNELSRC=\"${KERNEL_DIR}\" -j1"
+ BUILD_TARGETS="all"
+}
src_install() {
linux-mod_src_install
diff --git a/sys-power/phc-k8/phc-k8-0.4.4.ebuild b/sys-power/phc-k8/phc-k8-0.4.4.ebuild
new file mode 100644
index 000000000000..afe86a668280
--- /dev/null
+++ b/sys-power/phc-k8/phc-k8-0.4.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/phc-k8/phc-k8-0.4.4.ebuild,v 1.1 2011/11/18 08:45:18 xmw Exp $
+
+EAPI=4
+
+inherit linux-info linux-mod
+
+DESCRIPTION="Processor Hardware Control for AMD K8 CPUs"
+HOMEPAGE="http://www.linux-phc.org/"
+SRC_URI="http://www.linux-phc.org/forum/download/file.php?id=124 -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}_v${PV}
+
+pkg_setup() {
+ CONFIG_CHECK="~!X86_POWERNOW_K8"
+ ERROR_X86_POWERNOW_K8="CONFIG_X86_POWERNOW_K8 should be configured to Module, to
+a) include needed symbol cpufreq_get_measured_perf and
+b) enable the replacemant of powernow-k8 with phc-k8."
+
+ MODULE_NAMES="phc-k8(misc:)"
+ BUILD_PARAMS="KERNELSRC=\"${KERNEL_DIR}\" -j1"
+ BUILD_TARGETS="all"
+
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ sed -e '/error Only support for 2.6 series kernels/d' \
+ -i Makefile || die
+
+ if kernel_is gt 2 6 32 ; then
+ #use mperf.{c,h,ko) from kerel
+ sed -e '/^MODULES/s:mperf.ko::' \
+ -e '/^obj-m/s:mperf.o::' \
+ -i Makefile || die
+ fi
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc Changelog README
+}