summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-04-17 22:46:41 +0000
committerJeroen Roovers <jer@gentoo.org>2011-04-17 22:46:41 +0000
commitfd2bff2e062ccbc6cce6593e0f8d87c9d859c0c6 (patch)
treef0798e39b243f9d3f4b2ac321036cd568e96dba2 /sys-process/at
parentWarn about crashing bugs, upstream #26900, #35391. (diff)
downloadgentoo-2-fd2bff2e062ccbc6cce6593e0f8d87c9d859c0c6.tar.gz
gentoo-2-fd2bff2e062ccbc6cce6593e0f8d87c9d859c0c6.tar.bz2
gentoo-2-fd2bff2e062ccbc6cce6593e0f8d87c9d859c0c6.zip
Add conf.d script for the few but potentially useful (batch related) options atd provides.
(Portage version: 2.2.0_alpha30/cvs/Linux i686)
Diffstat (limited to 'sys-process/at')
-rw-r--r--sys-process/at/ChangeLog11
-rw-r--r--sys-process/at/at-3.1.10.2-r2.ebuild75
-rw-r--r--sys-process/at/files/atd.confd8
-rwxr-xr-xsys-process/at/files/atd.rc66
4 files changed, 95 insertions, 5 deletions
diff --git a/sys-process/at/ChangeLog b/sys-process/at/ChangeLog
index b2f1fc9d7ffd..5ddfa8962cfb 100644
--- a/sys-process/at/ChangeLog
+++ b/sys-process/at/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-process/at
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/at/ChangeLog,v 1.25 2010/10/31 16:04:05 flameeyes Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/at/ChangeLog,v 1.26 2011/04/17 22:46:41 jer Exp $
+
+*at-3.1.10.2-r2 (17 Apr 2011)
+
+ 17 Apr 2011; Jeroen Roovers <jer@gentoo.org> +at-3.1.10.2-r2.ebuild,
+ +files/atd.confd, files/atd.rc6:
+ Add conf.d script for the few but potentially useful (batch related) options
+ atd provides.
31 Oct 2010; Diego E. Pettenò <flameeyes@gentoo.org>
-at-3.1.8-r11.ebuild, -at-3.1.8-r12.ebuild,
diff --git a/sys-process/at/at-3.1.10.2-r2.ebuild b/sys-process/at/at-3.1.10.2-r2.ebuild
new file mode 100644
index 000000000000..11c634b7f7d1
--- /dev/null
+++ b/sys-process/at/at-3.1.10.2-r2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/at/at-3.1.10.2-r2.ebuild,v 1.1 2011/04/17 22:46:41 jer Exp $
+
+inherit eutils flag-o-matic autotools pam
+
+DESCRIPTION="Queues jobs for later execution"
+HOMEPAGE="http://packages.qa.debian.org/a/at.html"
+SRC_URI="mirror://debian/pool/main/a/at/at_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="pam"
+
+DEPEND="virtual/mta
+ >=sys-devel/flex-2.5.4a
+ pam? ( virtual/pam )"
+RDEPEND="virtual/mta
+ virtual/logger"
+
+pkg_setup() {
+ enewgroup at 25
+ enewuser at 25 -1 /var/spool/at/atjobs at
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-3.1.8-more-deny.patch
+ epatch "${FILESDIR}"/${PN}-3.1.10.1-Makefile.patch
+ # fix parallel make issues, bug #244884
+ epatch "${FILESDIR}"/${P}-Makefile.in-parallel-make-fix.patch
+ epatch "${FILESDIR}"/${P}-configure.in-fix-PAM-automagick-dep.patch
+
+ # fixing version string shown on "at -V" - bug #252970
+ sed -e "/^VERSION=/s:3\.1\.9:${PV}:" -i "${S}"/configure.in \
+ || die "sed configure.in failed"
+ eautoconf
+}
+
+src_compile() {
+ use pam || my_conf="--without-pam"
+ econf \
+ --sysconfdir=/etc/at \
+ --with-jobdir=/var/spool/at/atjobs \
+ --with-atspool=/var/spool/at/atspool \
+ --with-etcdir=/etc/at \
+ --with-daemon_username=at \
+ --with-daemon_groupname=at \
+ ${my_conf} \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make install IROOT="${D}" || die
+
+ newinitd "${FILESDIR}"/atd.rc6 atd
+ newconfd "${FILESDIR}"/atd.confd atd
+ newpamd "${FILESDIR}"/at.pamd atd
+ prepalldocs
+}
+
+pkg_postinst() {
+ einfo "Forcing correct permissions on /var/spool/at"
+ chown at:at "${ROOT}/var/spool/at/atjobs"
+ chmod 1770 "${ROOT}/var/spool/at/atjobs"
+ chown at:at "${ROOT}/var/spool/at/atjobs/.SEQ"
+ chmod 0600 "${ROOT}/var/spool/at/atjobs/.SEQ"
+ chown at:at "${ROOT}/var/spool/at/atspool"
+ chmod 1770 "${ROOT}/var/spool/at/atspool"
+}
diff --git a/sys-process/at/files/atd.confd b/sys-process/at/files/atd.confd
new file mode 100644
index 000000000000..db42ea557ec7
--- /dev/null
+++ b/sys-process/at/files/atd.confd
@@ -0,0 +1,8 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/at/files/atd.confd,v 1.1 2011/04/17 22:46:40 jer Exp $
+
+# Define startup options for atd(8).
+# For example: ATD_OPTS="-l 3.0 -b 5"
+ATD_OPTS=""
diff --git a/sys-process/at/files/atd.rc6 b/sys-process/at/files/atd.rc6
index da022b0b769f..d0dc71045556 100755
--- a/sys-process/at/files/atd.rc6
+++ b/sys-process/at/files/atd.rc6
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/at/files/atd.rc6,v 1.1 2005/03/03 17:40:23 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/at/files/atd.rc6,v 1.2 2011/04/17 22:46:40 jer Exp $
depend() {
need clock logger
@@ -10,7 +10,7 @@ depend() {
start() {
ebegin "Starting atd"
start-stop-daemon --start --quiet --pidfile /var/run/atd.pid \
- --startas /usr/sbin/atd
+ --startas /usr/sbin/atd -- ${ATD_OPTS}
eend $?
}