summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2015-04-14 10:06:22 +0000
committerYixun Lan <dlan@gentoo.org>2015-04-14 10:06:22 +0000
commit5ee1166f20c718d8cd3ed1cf75983fee84856f81 (patch)
treeab63773d40319ccff2952a00c2b560221f268706 /sys-process/criu
parentStable for amd64, wrt bug #546186 (diff)
downloadgentoo-2-5ee1166f20c718d8cd3ed1cf75983fee84856f81.tar.gz
gentoo-2-5ee1166f20c718d8cd3ed1cf75983fee84856f81.tar.bz2
gentoo-2-5ee1166f20c718d8cd3ed1cf75983fee84856f81.zip
arm64 support added & drop old
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'sys-process/criu')
-rw-r--r--sys-process/criu/ChangeLog6
-rw-r--r--sys-process/criu/criu-1.5-r2.ebuild50
-rw-r--r--sys-process/criu/criu-1.5.1.ebuild5
-rw-r--r--sys-process/criu/files/criu-1.5.1-arm64-ptrace.patch12
4 files changed, 20 insertions, 53 deletions
diff --git a/sys-process/criu/ChangeLog b/sys-process/criu/ChangeLog
index d5a17bfdca83..3d9897b672ea 100644
--- a/sys-process/criu/ChangeLog
+++ b/sys-process/criu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-process/criu
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/criu/ChangeLog,v 1.21 2015/04/13 02:21:24 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/criu/ChangeLog,v 1.22 2015/04/14 10:06:22 dlan Exp $
+
+ 14 Apr 2015; Yixun Lan <dlan@gentoo.org> -criu-1.5-r2.ebuild,
+ criu-1.5.1.ebuild, +files/criu-1.5.1-arm64-ptrace.patch:
+ arm64 support added & drop old
*criu-1.5.1 (13 Apr 2015)
diff --git a/sys-process/criu/criu-1.5-r2.ebuild b/sys-process/criu/criu-1.5-r2.ebuild
deleted file mode 100644
index 21b4fbe76713..000000000000
--- a/sys-process/criu/criu-1.5-r2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/criu/criu-1.5-r2.ebuild,v 1.1 2015/03/16 02:51:21 radhermit Exp $
-
-EAPI=5
-
-inherit eutils toolchain-funcs linux-info flag-o-matic
-
-DESCRIPTION="utility to checkpoint/restore a process tree"
-HOMEPAGE="http://criu.org/"
-SRC_URI="http://download.openvz.org/criu/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm"
-IUSE="setproctitle"
-
-RDEPEND="dev-libs/protobuf-c
- setproctitle? ( dev-libs/libbsd )"
-DEPEND="${RDEPEND}
- app-text/asciidoc
- app-text/xmlto"
-
-CONFIG_CHECK="~CHECKPOINT_RESTORE ~NAMESPACES ~PID_NS ~FHANDLE ~EVENTFD ~EPOLL ~INOTIFY_USER
- ~IA32_EMULATION ~UNIX_DIAG ~INET_DIAG ~INET_UDP_DIAG ~PACKET_DIAG ~NETLINK_DIAG"
-
-RESTRICT="test"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.3.1-flags.patch
- epatch "${FILESDIR}"/${PN}-1.3.1-makefile.patch
- epatch "${FILESDIR}"/${P}-automagic-libbsd.patch
-}
-
-src_compile() {
- unset ARCH
- emake CC="$(tc-getCC)" LD="$(tc-getLD)" V=1 SETPROCTITLE=$(usex setproctitle) WERROR=0 all docs
-}
-
-src_test() {
- # root privileges are required to dump all necessary info
- if [[ ${EUID} -eq 0 ]] ; then
- emake -j1 CC="$(tc-getCC)" V=1 WERROR=0 test
- fi
-}
-
-src_install() {
- emake SYSCONFDIR="${EPREFIX}"/etc PREFIX="${EPREFIX}"/usr DESTDIR="${D}" install
- dodoc CREDITS README
-}
diff --git a/sys-process/criu/criu-1.5.1.ebuild b/sys-process/criu/criu-1.5.1.ebuild
index 83f3c6abde7a..5fa5e6c44461 100644
--- a/sys-process/criu/criu-1.5.1.ebuild
+++ b/sys-process/criu/criu-1.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/criu/criu-1.5.1.ebuild,v 1.1 2015/04/13 02:21:24 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/criu/criu-1.5.1.ebuild,v 1.2 2015/04/14 10:06:22 dlan Exp $
EAPI=5
@@ -12,7 +12,7 @@ SRC_URI="http://download.openvz.org/criu/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm"
+KEYWORDS="~amd64 ~arm ~arm64"
IUSE="setproctitle"
RDEPEND="dev-libs/protobuf-c
@@ -30,6 +30,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-1.3.1-flags.patch
epatch "${FILESDIR}"/${PN}-1.3.1-makefile.patch
epatch "${FILESDIR}"/${PN}-1.5-automagic-libbsd.patch
+ epatch "${FILESDIR}"/${P}-arm64-ptrace.patch
}
src_compile() {
diff --git a/sys-process/criu/files/criu-1.5.1-arm64-ptrace.patch b/sys-process/criu/files/criu-1.5.1-arm64-ptrace.patch
new file mode 100644
index 000000000000..497838132a24
--- /dev/null
+++ b/sys-process/criu/files/criu-1.5.1-arm64-ptrace.patch
@@ -0,0 +1,12 @@
+diff --git a/arch/aarch64/include/asm/types.h b/arch/aarch64/include/asm/types.h
+index 8dd336e..6657279 100644
+--- a/arch/aarch64/include/asm/types.h
++++ b/arch/aarch64/include/asm/types.h
+@@ -3,6 +3,7 @@
+
+ #include <stdbool.h>
+ #include <signal.h>
++#include <asm/ptrace.h>
+ #include "protobuf/core.pb-c.h"
+
+ #include "asm-generic/page.h"