summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-04-18 13:24:55 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-04-18 13:24:55 +0000
commit0d3be740822249acb3c8d0112c6031cffdcc4e65 (patch)
treecc35464a46cdecb7b3bae64d9e08671a0508e6f3 /sys-process/cronie/cronie-1.4.11-r3.ebuild
parentadd multilib support wrt #496586, patch by Michael Mair-Keimberger (diff)
downloadgentoo-2-0d3be740822249acb3c8d0112c6031cffdcc4e65.tar.gz
gentoo-2-0d3be740822249acb3c8d0112c6031cffdcc4e65.tar.bz2
gentoo-2-0d3be740822249acb3c8d0112c6031cffdcc4e65.zip
Only use anachron if /etc/cron.hourly/0anacron is executable
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-process/cronie/cronie-1.4.11-r3.ebuild')
-rw-r--r--sys-process/cronie/cronie-1.4.11-r3.ebuild83
1 files changed, 83 insertions, 0 deletions
diff --git a/sys-process/cronie/cronie-1.4.11-r3.ebuild b/sys-process/cronie/cronie-1.4.11-r3.ebuild
new file mode 100644
index 000000000000..ec8cae7c83af
--- /dev/null
+++ b/sys-process/cronie/cronie-1.4.11-r3.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/cronie-1.4.11-r3.ebuild,v 1.1 2014/04/18 13:24:54 polynomial-c Exp $
+
+EAPI=5
+
+inherit cron eutils pam systemd user
+
+DESCRIPTION="Cronie is a standard UNIX daemon cron based on the original vixie-cron."
+SRC_URI="https://fedorahosted.org/releases/c/r/cronie/${P}.tar.gz"
+HOMEPAGE="https://fedorahosted.org/cronie/wiki"
+
+LICENSE="ISC BSD BSD-2 GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="anacron +inotify pam selinux"
+
+DEPEND="pam? ( virtual/pam )
+ anacron? ( !sys-process/anacron )"
+RDEPEND="${DEPEND}"
+
+#cronie supports /etc/crontab
+CRON_SYSTEM_CRONTAB="yes"
+
+pkg_setup() {
+ enewgroup crontab
+}
+
+src_configure() {
+ SPOOL_DIR="/var/spool/cron/crontabs" \
+ ANACRON_SPOOL_DIR="/var/spool/anacron" \
+ econf \
+ $(use_with inotify) \
+ $(use_with pam) \
+ $(use_with selinux) \
+ $(use_enable anacron) \
+ --enable-syscrontab \
+ --with-daemon_username=cron \
+ --with-daemon_groupname=cron
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+
+ docrondir -m 1730 -o root -g crontab
+ fowners root:crontab /usr/bin/crontab
+ fperms 2751 /usr/bin/crontab
+
+ insinto /etc/conf.d
+ newins "${S}"/crond.sysconfig ${PN}
+
+ insinto /etc
+ newins "${FILESDIR}/${PN}-1.3-crontab" crontab
+ newins "${FILESDIR}/${PN}-1.2-cron.deny" cron.deny
+
+ keepdir /etc/cron.d
+ newinitd "${FILESDIR}/${PN}-1.3-initd" ${PN}
+ newpamd "${FILESDIR}/${PN}-1.4.3-pamd" crond
+
+ sed s:sysconfig/crond:conf.d/cronie: contrib/cronie.systemd \
+ > "${T}"/cronie.service
+ systemd_dounit "${T}"/cronie.service
+
+ if use anacron ; then
+ local anacrondir="/var/spool/anacron"
+ keepdir ${anacrondir}
+ fowners root:cron ${anacrondir}
+ fperms 0750 ${anacrondir}
+
+ insinto /etc
+
+ doins contrib/anacrontab
+
+ insinto /etc/cron.hourly
+ doins contrib/0anacron
+ fperms 0750 /etc/cron.hourly/0anacron
+ fi
+
+ dodoc AUTHORS README contrib/*
+}
+
+pkg_postinst() {
+ cron_pkg_postinst
+}