summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2012-10-30 20:09:27 +0000
committerChristian Ruppert <idl0r@gentoo.org>2012-10-30 20:09:27 +0000
commit69a0a9f7fa2aa093c32c0b8cc79c9378c4b79784 (patch)
tree6c477f845d2f66a460b710a6008b6dccb008f5ad /sys-process/htop/files
parentVersion bump. (diff)
downloadgentoo-2-69a0a9f7fa2aa093c32c0b8cc79c9378c4b79784.tar.gz
gentoo-2-69a0a9f7fa2aa093c32c0b8cc79c9378c4b79784.tar.bz2
gentoo-2-69a0a9f7fa2aa093c32c0b8cc79c9378c4b79784.zip
Cleanup
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key B427ABC8)
Diffstat (limited to 'sys-process/htop/files')
-rw-r--r--sys-process/htop/files/htop-0.9-debug.patch31
-rw-r--r--sys-process/htop/files/htop-0.9-small-width.patch42
-rw-r--r--sys-process/htop/files/htop-0.9-uclibc.patch54
3 files changed, 0 insertions, 127 deletions
diff --git a/sys-process/htop/files/htop-0.9-debug.patch b/sys-process/htop/files/htop-0.9-debug.patch
deleted file mode 100644
index a1aa1b9ea3ec..000000000000
--- a/sys-process/htop/files/htop-0.9-debug.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- trunk/DebugMemory.c 2006/11/08 20:40:10 66
-+++ trunk/DebugMemory.c 2011/03/22 20:37:08 216
-@@ -90,7 +90,7 @@
- return data;
- }
-
--void* DebugMemory_strdup(char* str, char* file, int line) {
-+void* DebugMemory_strdup(const char* str, char* file, int line) {
- assert(str);
- char* data = strdup(str);
- DebugMemory_registerAllocation(data, file, line);
-@@ -102,7 +102,7 @@
- }
-
- void DebugMemory_free(void* data, char* file, int line) {
-- assert(data);
-+ if (!data) return;
- DebugMemory_registerDeallocation(data, file, line);
- if (singleton->file) {
- if (singleton->totals) fprintf(singleton->file, "%d\t", singleton->size);
---- trunk/Process.c 2010/11/22 12:40:20 206
-+++ trunk/Process.c 2011/03/22 20:37:08 216
-@@ -471,7 +471,7 @@
- RichString_setAttr(out, CRT_colors[PROCESS_SHADOW]);
- if (this->tag == true)
- RichString_setAttr(out, CRT_colors[PROCESS_TAG]);
-- assert(out->len > 0);
-+ assert(out->chlen > 0);
- }
-
- void Process_delete(Object* cast) {
diff --git a/sys-process/htop/files/htop-0.9-small-width.patch b/sys-process/htop/files/htop-0.9-small-width.patch
deleted file mode 100644
index 743111137b03..000000000000
--- a/sys-process/htop/files/htop-0.9-small-width.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 17d258ff0a216dd87655c8e93d065e5e6c504f42 Mon Sep 17 00:00:00 2001
-From: Sebastian Pipping <sebastian@pipping.org>
-Date: Mon, 1 Aug 2011 02:51:24 +0200
-Subject: [PATCH 3/3] Fix segfault in BarMeterMode_draw() for small terminal
- widths
-
-Segfault can be triggered by running "COLUMNS=1 ./htop"
-For me, COLUMNS=40 was the first that would not crash.
----
- ChangeLog | 2 ++
- Meter.c | 11 +++++++++--
- 2 files changed, 11 insertions(+), 2 deletions(-)
-
-diff --git a/Meter.c b/Meter.c
-index 6947d9b..408b981 100644
---- a/Meter.c
-+++ b/Meter.c
-@@ -264,13 +265,19 @@ static void BarMeterMode_draw(Meter* this, int x, int y, int w) {
-
- w--;
- x++;
-- char bar[w];
-+
-+ if (w < 1) {
-+ attrset(CRT_colors[RESET_COLOR]);
-+ return;
-+ }
-+ char bar[w + 1];
-
- int blockSizes[10];
- for (int i = 0; i < w; i++)
- bar[i] = ' ';
-
-- sprintf(bar + (w-strlen(buffer)), "%s", buffer);
-+ const size_t bar_offset = w - MIN(strlen(buffer), w);
-+ snprintf(bar + bar_offset, w - bar_offset + 1, "%s", buffer);
-
- // First draw in the bar[] buffer...
- double total = 0.0;
---
-1.7.6
-
diff --git a/sys-process/htop/files/htop-0.9-uclibc.patch b/sys-process/htop/files/htop-0.9-uclibc.patch
deleted file mode 100644
index ffe4953d80a3..000000000000
--- a/sys-process/htop/files/htop-0.9-uclibc.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-http://bugs.gentoo.org/374595
-
---- CRT.c
-+++ CRT.c
-@@ -11,7 +11,9 @@ in the source distribution for its full
- #include <signal.h>
- #include <stdlib.h>
- #include <stdbool.h>
-+#ifdef HAVE_EXECINFO_H
- #include <execinfo.h>
-+#endif
-
- #include "String.h"
-
-@@ -125,12 +127,14 @@ static void CRT_handleSIGSEGV(int sgn) {
- CRT_done();
- #if __linux
- fprintf(stderr, "\n\nhtop " VERSION " aborting. Please report bug at http://htop.sf.net\n");
-- #else
-- fprintf(stderr, "\n\nhtop " VERSION " aborting. Unsupported platform.\n");
-- #endif
-+ #ifdef HAVE_EXECINFO_H
- size_t size = backtrace(backtraceArray, sizeof(backtraceArray));
- fprintf(stderr, "Backtrace: \n");
- backtrace_symbols_fd(backtraceArray, size, 2);
-+ #endif
-+ #else
-+ fprintf(stderr, "\n\nhtop " VERSION " aborting. Unsupported platform.\n");
-+ #endif
- abort();
- }
-
---- CRT.h
-+++ CRT.h
-@@ -14,7 +14,9 @@ in the source distribution for its full
- #include <signal.h>
- #include <stdlib.h>
- #include <stdbool.h>
-+#ifdef HAVE_EXECINFO_H
- #include <execinfo.h>
-+#endif
-
- #include "String.h"
-
---- configure.ac
-+++ configure.ac
-@@ -25,6 +25,7 @@ AC_HEADER_STDC
- AC_CHECK_HEADERS([stdlib.h string.h strings.h sys/param.h sys/time.h unistd.h curses.h],[:],[
- missing_headers="$missing_headers $ac_header"
- ])
-+AC_CHECK_HEADERS([execinfo.h],[:],[:])
-
- # Checks for typedefs, structures, and compiler characteristics.
- AC_HEADER_STDBOOL