summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-12-29 06:31:34 +0000
committerMike Frysinger <vapier@gentoo.org>2009-12-29 06:31:34 +0000
commit9ef28035c99a2d9a647f0b86ee47ed96854ec351 (patch)
tree4e57ae6cca117fd78cbd7807b32c7e2f2093c23f /sys-process/latencytop/latencytop-0.5.ebuild
parentcommitted wrong hunk for previous change to this ebuild; this commit adds the... (diff)
downloadgentoo-2-9ef28035c99a2d9a647f0b86ee47ed96854ec351.tar.gz
gentoo-2-9ef28035c99a2d9a647f0b86ee47ed96854ec351.tar.bz2
gentoo-2-9ef28035c99a2d9a647f0b86ee47ed96854ec351.zip
Fix building when USE=-gtk #297461 by Andrei Slavoiu.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'sys-process/latencytop/latencytop-0.5.ebuild')
-rw-r--r--sys-process/latencytop/latencytop-0.5.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-process/latencytop/latencytop-0.5.ebuild b/sys-process/latencytop/latencytop-0.5.ebuild
index 12cfe7b89567..8224ef5a3150 100644
--- a/sys-process/latencytop/latencytop-0.5.ebuild
+++ b/sys-process/latencytop/latencytop-0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/latencytop/latencytop-0.5.ebuild,v 1.1 2009/12/18 15:58:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/latencytop/latencytop-0.5.ebuild,v 1.2 2009/12/29 06:31:34 vapier Exp $
inherit eutils toolchain-funcs
@@ -23,11 +23,14 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-*.patch
+ sed -i \
+ -e "/^HAS_GTK_GUI/s:=.*:=$(use gtk && echo 1):" \
+ Makefile || die
}
src_compile() {
tc-export CC PKG_CONFIG
- emake HAS_GTK_GUI=$(use gtk && echo 1) || die
+ emake || die
}
src_install() {