summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-10-06 13:10:31 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-10-06 13:10:31 +0000
commit959d524dfa3e79e316570dc0cf3698b98fb65807 (patch)
treecd8fabdb859f1a61606e1e20b9cd5b55c9bbbfb6 /sys-process/numactl/numactl-2.0.10.ebuild
parentRemove me from metadata.xml (diff)
downloadgentoo-2-959d524dfa3e79e316570dc0cf3698b98fb65807.tar.gz
gentoo-2-959d524dfa3e79e316570dc0cf3698b98fb65807.tar.bz2
gentoo-2-959d524dfa3e79e316570dc0cf3698b98fb65807.zip
Version bump. Removed old
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-process/numactl/numactl-2.0.10.ebuild')
-rw-r--r--sys-process/numactl/numactl-2.0.10.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-process/numactl/numactl-2.0.10.ebuild b/sys-process/numactl/numactl-2.0.10.ebuild
new file mode 100644
index 000000000000..d326152f39af
--- /dev/null
+++ b/sys-process/numactl/numactl-2.0.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/numactl-2.0.10.ebuild,v 1.1 2014/10/06 13:10:31 polynomial-c Exp $
+
+EAPI="4"
+
+inherit autotools eutils toolchain-funcs multilib
+
+DESCRIPTION="Utilities and libraries for NUMA systems"
+HOMEPAGE="http://oss.sgi.com/projects/libnuma/"
+SRC_URI="ftp://oss.sgi.com/www/projects/libnuma/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+# ARM lacks the __NR_migrate_pages syscall.
+KEYWORDS="~amd64 -arm ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux"
+IUSE=""
+
+src_prepare() {
+ eautoreconf
+ epatch "${FILESDIR}"/${PN}-2.0.8-cpuid-pic.patch #456238
+}
+
+src_test() {
+ if [ -d /sys/devices/system/node ]; then
+ einfo "The only generically safe test is regress2."
+ einfo "The other test cases require 2 NUMA nodes."
+ emake regress2
+ else
+ ewarn "You do not have baseline NUMA support in your kernel, skipping tests."
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ # delete man pages provided by the man-pages package #238805
+ rm -r "${ED}"/usr/share/man/man[25] || die
+ dodoc README TODO CHANGES DESIGN
+}