summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-09-29 23:40:12 +0000
committerMike Frysinger <vapier@gentoo.org>2008-09-29 23:40:12 +0000
commit8d0bca4338c90ca9ca25c376dbe9f0b88ef9b863 (patch)
tree332aa9a5e78df279887c8ac90fdcdaa8b3901bf4 /sys-process/numactl
parentold (diff)
downloadgentoo-2-8d0bca4338c90ca9ca25c376dbe9f0b88ef9b863.tar.gz
gentoo-2-8d0bca4338c90ca9ca25c376dbe9f0b88ef9b863.tar.bz2
gentoo-2-8d0bca4338c90ca9ca25c376dbe9f0b88ef9b863.zip
Version bump and fix man-page collision #238805 by Joost Ruis.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'sys-process/numactl')
-rw-r--r--sys-process/numactl/ChangeLog7
-rw-r--r--sys-process/numactl/numactl-2.0.2.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/sys-process/numactl/ChangeLog b/sys-process/numactl/ChangeLog
index cd4fc5c59edb..a360e6cb640f 100644
--- a/sys-process/numactl/ChangeLog
+++ b/sys-process/numactl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/numactl
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/ChangeLog,v 1.7 2008/01/14 02:21:08 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/ChangeLog,v 1.8 2008/09/29 23:40:12 vapier Exp $
+
+*numactl-2.0.2 (29 Sep 2008)
+
+ 29 Sep 2008; Mike Frysinger <vapier@gentoo.org> +numactl-2.0.2.ebuild:
+ Version bump and fix man-page collision #238805 by Joost Ruis.
14 Jan 2008; Robin H. Johnson <robbat2@gentoo.org> -numactl-0.9.8.ebuild,
-numactl-0.9.9.ebuild, -numactl-0.9.10.ebuild, numactl-0.9.11.ebuild:
diff --git a/sys-process/numactl/numactl-2.0.2.ebuild b/sys-process/numactl/numactl-2.0.2.ebuild
new file mode 100644
index 000000000000..7bc480a04847
--- /dev/null
+++ b/sys-process/numactl/numactl-2.0.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numactl/numactl-2.0.2.ebuild,v 1.1 2008/09/29 23:40:12 vapier Exp $
+
+inherit base eutils toolchain-funcs
+
+DESCRIPTION="Utilities and libraries for NUMA systems."
+HOMEPAGE="http://oss.sgi.com/projects/libnuma/"
+SRC_URI="ftp://oss.sgi.com/www/projects/libnuma/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="perl"
+
+RDEPEND="perl? ( dev-lang/perl )"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" BENCH_CFLAGS="" || die
+}
+
+src_install() {
+ emake install prefix="${D}/usr" || die
+ # delete man pages provided by the man-pages package #238805
+ rm -rf "${D}"/usr/share/man/man[25]
+ doman *.8 || die # makefile doesnt get them all
+ dodoc README TODO CHANGES DESIGN
+ if ! use perl ; then
+ rm "${D}"/usr/bin/numastat "${D}"/usr/share/man/man8/numastat.8 || die
+ fi
+}
+
+src_test() {
+ einfo "The only generically safe test is regress2."
+ einfo "The other test cases require 2 NUMA nodes."
+ cd test
+ ./regress2 || die "regress2 failed!"
+}