summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-06-14 05:13:03 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-06-14 05:13:03 +0000
commite0807112db4e2cbd0b551ad696d37aa536a05636 (patch)
tree33800c5c2af690b980c82a44c3dd1868c347f49b /sys-process/numad/numad-0.5.ebuild
parentVersion bump. Add patch to detect cdb header properly. (diff)
downloadgentoo-2-e0807112db4e2cbd0b551ad696d37aa536a05636.tar.gz
gentoo-2-e0807112db4e2cbd0b551ad696d37aa536a05636.tar.bz2
gentoo-2-e0807112db4e2cbd0b551ad696d37aa536a05636.zip
Add initial version of numad, a daemon for monitoring and rebalancing assignment of NUMA resources.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'sys-process/numad/numad-0.5.ebuild')
-rw-r--r--sys-process/numad/numad-0.5.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-process/numad/numad-0.5.ebuild b/sys-process/numad/numad-0.5.ebuild
new file mode 100644
index 000000000000..01b668c5ef8a
--- /dev/null
+++ b/sys-process/numad/numad-0.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/numad/numad-0.5.ebuild,v 1.1 2012/06/14 05:13:03 cardoe Exp $
+
+EAPI=4
+
+inherit linux-info
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://git.fedorahosted.org/numad.git"
+ KEYWORDS="-arm -s390"
+else
+ SRC_URI="http://git.fedorahosted.org/git/?p=numad.git;a=snapshot;h=334278ff3d774d105939743436d7378a189e8693;sf=tbz2 -> numad-0.5.tar.bz2"
+ KEYWORDS="~amd64 ~x86 -arm -s390"
+ S="${WORKDIR}/${PN}-334278f"
+fi
+
+DESCRIPTION="The NUMA daemon that manages application locality"
+HOMEPAGE="http://fedoraproject.org/wiki/Features/numad"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~NUMA ~CPUSETS"
+
+src_prepare() {
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${FILESDIR}" \
+ epatch
+}
+
+src_configure() {
+ :
+}
+
+src_install() {
+ emake prefix="${ED}/usr" install
+}