summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2012-05-09 11:14:22 +0000
committerFabian Groffen <grobian@gentoo.org>2012-05-09 11:14:22 +0000
commit221b68f36cb506df301c2af8e72a9b8ea36c586e (patch)
tree1a567b5f23d2717c3bba16fa9c1db6a91f804b9f /sys-process/unixtop/unixtop-3.8_beta1-r3.ebuild
parentMake comply with multilib-strict (diff)
downloadgentoo-2-221b68f36cb506df301c2af8e72a9b8ea36c586e.tar.gz
gentoo-2-221b68f36cb506df301c2af8e72a9b8ea36c586e.tar.bz2
gentoo-2-221b68f36cb506df301c2af8e72a9b8ea36c586e.zip
Revbump for some patches from Oracle/OpenIndiana
(Portage version: 2.2.01.20430-prefix/cvs/SunOS i386)
Diffstat (limited to 'sys-process/unixtop/unixtop-3.8_beta1-r3.ebuild')
-rw-r--r--sys-process/unixtop/unixtop-3.8_beta1-r3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/sys-process/unixtop/unixtop-3.8_beta1-r3.ebuild b/sys-process/unixtop/unixtop-3.8_beta1-r3.ebuild
new file mode 100644
index 000000000000..5ccad0837793
--- /dev/null
+++ b/sys-process/unixtop/unixtop-3.8_beta1-r3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/unixtop/unixtop-3.8_beta1-r3.ebuild,v 1.1 2012/05/09 11:14:22 grobian Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="top for UNIX systems"
+HOMEPAGE="http://unixtop.sourceforge.net/"
+SRC_URI="mirror://sourceforge/unixtop/top-${PV/_/}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/top-${PV/_/}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-ncurses.patch
+ epatch "${FILESDIR}"/${P}-no-AX-macros.patch
+ epatch "${FILESDIR}"/${P}-renice-segfault.patch
+ epatch "${FILESDIR}"/${P}-memleak-fix-v2.patch
+ epatch "${FILESDIR}"/${P}-high-threadid-crash.patch
+ epatch "${FILESDIR}"/${P}-percent-cpu.patch
+ eautoreconf
+}
+
+src_compile() {
+ local myconf=
+
+ # don't do bi-arch cruft on hosts that support that, such as Solaris
+ export enable_dualarch=no
+
+ # configure demands an override because on OSX this is "experimental"
+ [[ ${CHOST} == *-darwin* ]] && myconf="${myconf} --with-module=macosx"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README FAQ Y2K
+}