summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2009-05-12 09:21:58 +0000
committerThilo Bangert <bangert@gentoo.org>2009-05-12 09:21:58 +0000
commit1481483ce94f60632f0481c980fa822e99b9f927 (patch)
treefc9a8d1c170a5df030c19974724206e90365707a /sys-process
parentreduce chance of race condition - bug #98189 (diff)
downloadgentoo-2-1481483ce94f60632f0481c980fa822e99b9f927.tar.gz
gentoo-2-1481483ce94f60632f0481c980fa822e99b9f927.tar.bz2
gentoo-2-1481483ce94f60632f0481c980fa822e99b9f927.zip
reduce chance of race condition - bug #98189
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/fcron/ChangeLog7
-rw-r--r--sys-process/fcron/files/crontab29
2 files changed, 21 insertions, 15 deletions
diff --git a/sys-process/fcron/ChangeLog b/sys-process/fcron/ChangeLog
index 4b9991d7fcc9..0c57bb3e5fe2 100644
--- a/sys-process/fcron/ChangeLog
+++ b/sys-process/fcron/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-process/fcron
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/ChangeLog,v 1.64 2008/09/13 07:49:20 nixnut Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/ChangeLog,v 1.65 2009/05/12 09:21:57 bangert Exp $
+
+ 12 May 2009; Thilo Bangert <bangert@gentoo.org> files/crontab:
+ reduce chance of race condition - bug #98189
13 Sep 2008; nixnut <nixnut@gentoo.org> fcron-3.0.4-r1.ebuild:
Stable on ppc wrt bug 237066
diff --git a/sys-process/fcron/files/crontab b/sys-process/fcron/files/crontab
index 1bc63cd4dddf..5e66c2959537 100644
--- a/sys-process/fcron/files/crontab
+++ b/sys-process/fcron/files/crontab
@@ -1,19 +1,22 @@
-# /etc/crontab
-#
-# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/files/crontab,v 1.1 2005/03/04 23:50:36 ciaranm Exp $
+# for fcron
+# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/files/crontab,v 1.2 2009/05/12 09:21:58 bangert Exp $
-# fcron || dcron:
-# This is NOT the system crontab! fcron and dcron do not support a system crontab.
-# to get /etc/cron.{hourly|daily|weekly|montly} working with fcron or dcron do
+# fcron:
+# This is NOT the system crontab! fcron does not support a system crontab.
+# to get /etc/cron.{hourly|daily|weekly|montly} working with fcron run
# crontab /etc/crontab
# as root.
# NOTE: This will REPLACE root's current crontab!!
-# 20 Apr 2002; Thilo Bangert <bangert@gentoo.org>
-# check scripts in cron.hourly, cron.daily, cron.weekly and cron.monthly
+# Global variables
+SHELL=/bin/bash
+PATH=/sbin:/bin:/usr/sbin:/usr/bin
+MAILTO=root
+HOME=/
-0 * * * * rm -f /var/spool/cron/lastrun/cron.hourly
-1 3 * * * rm -f /var/spool/cron/lastrun/cron.daily
-15 4 * * 6 rm -f /var/spool/cron/lastrun/cron.weekly
-30 5 1 * * rm -f /var/spool/cron/lastrun/cron.monthly
-*/10 * * * * /usr/bin/test -x /usr/sbin/run-crons && /usr/sbin/run-crons
+# check scripts in cron.hourly, cron.daily, cron.weekly and cron.monthly
+59 * * * * root rm -f /var/spool/cron/lastrun/cron.hourly
+9 3 * * * root rm -f /var/spool/cron/lastrun/cron.daily
+19 4 * * 6 root rm -f /var/spool/cron/lastrun/cron.weekly
+29 5 1 * * root rm -f /var/spool/cron/lastrun/cron.monthly
+*/10 * * * * root test -x /usr/sbin/run-crons && /usr/sbin/run-crons