summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-07-15 07:03:40 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-07-15 07:03:40 +0000
commit2fa25ced40ea158466d12c4054547711d7699b63 (patch)
treed63b4280938788d414d91db918c100178525056c /sys-process
parentwhitespace (diff)
downloadgentoo-2-2fa25ced40ea158466d12c4054547711d7699b63.tar.gz
gentoo-2-2fa25ced40ea158466d12c4054547711d7699b63.tar.bz2
gentoo-2-2fa25ced40ea158466d12c4054547711d7699b63.zip
Make audit-python compile on arches that use GCC __attribute in their headers, as it does not like that.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/audit/ChangeLog7
-rw-r--r--sys-process/audit/audit-1.5.4.ebuild4
-rw-r--r--sys-process/audit/files/audit-1.5.4-swig-gcc-attribute.patch11
3 files changed, 20 insertions, 2 deletions
diff --git a/sys-process/audit/ChangeLog b/sys-process/audit/ChangeLog
index f7709b6ea72f..087aebcf460e 100644
--- a/sys-process/audit/ChangeLog
+++ b/sys-process/audit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/audit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/ChangeLog,v 1.23 2007/07/11 18:31:58 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/ChangeLog,v 1.24 2007/07/15 07:03:40 robbat2 Exp $
+
+ 15 Jul 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +files/audit-1.5.4-swig-gcc-attribute.patch, audit-1.5.4.ebuild:
+ Make audit-python compile on arches that use GCC __attribute in their
+ headers, as it does not like that.
11 Jul 2007; Gustavo Zacarias <gustavoz@gentoo.org> audit-1.5.4.ebuild:
Keyworded ~sparc wrt #184563
diff --git a/sys-process/audit/audit-1.5.4.ebuild b/sys-process/audit/audit-1.5.4.ebuild
index 9727ebf73fd0..b76dd4a63167 100644
--- a/sys-process/audit/audit-1.5.4.ebuild
+++ b/sys-process/audit/audit-1.5.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/audit-1.5.4.ebuild,v 1.4 2007/07/11 18:31:58 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/audit-1.5.4.ebuild,v 1.5 2007/07/15 07:03:40 robbat2 Exp $
inherit autotools multilib toolchain-funcs
@@ -23,11 +23,13 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-swig-gcc-attribute.patch
# stupid package does not include generated autotools
eautoreconf
}
src_compile() {
+ append-flags -D'__attribute__(x)='
econf --sbindir=/sbin || die
emake || die "emake failed"
}
diff --git a/sys-process/audit/files/audit-1.5.4-swig-gcc-attribute.patch b/sys-process/audit/files/audit-1.5.4-swig-gcc-attribute.patch
new file mode 100644
index 000000000000..9d00f1c52093
--- /dev/null
+++ b/sys-process/audit/files/audit-1.5.4-swig-gcc-attribute.patch
@@ -0,0 +1,11 @@
+diff -Nuar --exclude '*~' audit-1.5.4.orig/swig/auditswig.i audit-1.5.4/swig/auditswig.i
+--- audit-1.5.4.orig/swig/auditswig.i 2007-06-14 08:17:00.000000000 -0700
++++ audit-1.5.4/swig/auditswig.i 2007-07-14 23:43:41.790390709 -0700
+@@ -26,6 +26,7 @@
+ %define __signed__
+ signed
+ %enddef
++#define __attribute(x) /*nothing*/
+ %include "/usr/include/asm/types.h"
+ %include "/usr/include/linux/audit.h"
+ #define __extension__ /*nothing*/