summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-01-25 03:35:01 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-01-25 03:35:01 +0000
commit6e496ec7899c35224a69bad051cfa181676d31d2 (patch)
treec8a91c2eb55c1f95d7342c11e9637e4c700b6c67 /sys-process
parentClean up patch. (diff)
downloadgentoo-2-6e496ec7899c35224a69bad051cfa181676d31d2.tar.gz
gentoo-2-6e496ec7899c35224a69bad051cfa181676d31d2.tar.bz2
gentoo-2-6e496ec7899c35224a69bad051cfa181676d31d2.zip
Version bump. Fix bug #352198: parallel build, bug #322239: prelude support, bug #352239: CONFIG_AUDIT check.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/audit/ChangeLog10
-rw-r--r--sys-process/audit/audit-2.0.5.ebuild134
2 files changed, 142 insertions, 2 deletions
diff --git a/sys-process/audit/ChangeLog b/sys-process/audit/ChangeLog
index f4ded3e4f9e1..ea8cb2d7875c 100644
--- a/sys-process/audit/ChangeLog
+++ b/sys-process/audit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/audit
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/ChangeLog,v 1.60 2010/10/15 21:15:49 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/ChangeLog,v 1.61 2011/01/25 03:35:01 robbat2 Exp $
+
+*audit-2.0.5 (25 Jan 2011)
+
+ 25 Jan 2011; Robin H. Johnson <robbat2@gentoo.org> +audit-2.0.5.ebuild:
+ Version bump. Fix bug #352198: parallel build, bug #322239: prelude support,
+ bug #352239: CONFIG_AUDIT check.
15 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
audit-1.7.4.ebuild, +files/audit-1.7.4-python.patch, audit-1.7.17.ebuild,
diff --git a/sys-process/audit/audit-2.0.5.ebuild b/sys-process/audit/audit-2.0.5.ebuild
new file mode 100644
index 000000000000..e6fc864ace6f
--- /dev/null
+++ b/sys-process/audit/audit-2.0.5.ebuild
@@ -0,0 +1,134 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/audit/audit-2.0.5.ebuild,v 1.1 2011/01/25 03:35:01 robbat2 Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit autotools multilib toolchain-funcs python linux-info
+
+DESCRIPTION="Userspace utilities for storing and processing auditing records"
+HOMEPAGE="http://people.redhat.com/sgrubb/audit/"
+SRC_URI="http://people.redhat.com/sgrubb/audit/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ldap prelude"
+# Testcases are pretty useless as they are built for RedHat users/groups and
+# kernels.
+RESTRICT="test"
+
+RDEPEND="ldap? ( net-nds/openldap )
+ prelude? ( dev-libs/libprelude )
+ sys-libs/libcap-ng"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ >=sys-kernel/linux-headers-2.6.34"
+# Do not use os-headers as this is linux specific
+
+CONFIG_CHECK="~AUDIT"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # Old patch applies fine
+ #EPATCH_OPTS="-p0 -d${S}" epatch "${FILESDIR}"/${PN}-1.5.4-build.patch
+
+ # Applied by upstream
+ #EPATCH_OPTS="-p1 -d${S}" epatch "${FILESDIR}"/${PN}-1.5.4-swig-gcc-attribute.patch
+
+ # Do not build GUI tools
+ sed -i \
+ -e '/AC_CONFIG_SUBDIRS.*system-config-audit/d' \
+ "${S}"/configure.ac
+ sed -i \
+ -e 's,system-config-audit,,g' \
+ -e '/^SUBDIRS/s,\\$,,g' \
+ "${S}"/Makefile.am
+ rm -rf "${S}"/system-config-audit
+
+ # Probably goes away in 1.6.9
+ #EPATCH_OPTS="-p1 -d${S}" epatch "${FILESDIR}"/audit-1.6.8-subdirs-fix.patch
+
+ if ! use ldap; then
+ sed -i \
+ -e '/^AC_OUTPUT/s,audisp/plugins/zos-remote/Makefile,,g' \
+ "${S}"/configure.ac
+ sed -i \
+ -e '/^SUBDIRS/s,zos-remote,,g' \
+ "${S}"/audisp/plugins/Makefile.am
+ fi
+
+ # Don't build static version of Python module.
+ epatch "${FILESDIR}"/${PN}-1.7.17-python.patch
+
+ # Regenerate autotooling
+ eautoreconf
+
+ # Disable byte-compilation of Python modules.
+ echo "#!/bin/sh" > py-compile
+
+ # Bug 352198: Avoid parallel build fail
+ cd "${S}"/src/mt
+ [[ ! -s private.h ]] && ln -s ../../lib/private.h .
+}
+
+src_configure() {
+ #append-flags -D'__attribute__(x)='
+ econf --sbindir=/sbin $(use_with prelude)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README* THANKS TODO
+ docinto contrib
+ dodoc contrib/*
+ docinto contrib/plugin
+ dodoc contrib/plugin/*
+
+ newinitd "${FILESDIR}"/auditd-init.d-1.7.17 auditd
+ newconfd "${FILESDIR}"/auditd-conf.d-1.2.3 auditd
+
+ # things like shadow use this so we need to be in /
+ dodir /$(get_libdir)
+ mv "${D}"/usr/$(get_libdir)/lib*.so* "${D}"/$(get_libdir)/ || die
+ gen_usr_ldscript libaudit.so libauparse.so
+
+ # remove RedHat garbage
+ rm -r "${D}"/etc/{rc.d,sysconfig} || die
+
+ # Gentoo rules
+ insinto /etc/audit/
+ doins "${FILESDIR}"/audit.rules*
+
+ # audit logs go here
+ keepdir /var/log/audit/
+
+ # Security
+ lockdown_perms "${D}"
+
+ # Don't install .la files in Python directories.
+ python_clean_installation_image
+}
+
+pkg_postinst() {
+ lockdown_perms "${ROOT}"
+ python_mod_optimize audit.py
+}
+
+pkg_postrm() {
+ python_mod_cleanup audit.py
+}
+
+lockdown_perms() {
+ # upstream wants these to have restrictive perms
+ basedir="$1"
+ chmod 0750 "${basedir}"/sbin/au{ditctl,report,dispd,ditd,search,trace} 2>/dev/null
+ chmod 0750 "${basedir}"/var/log/audit/ 2>/dev/null
+ chmod 0640 "${basedir}"/etc/{audit/,}{auditd.conf,audit.rules*} 2>/dev/null
+}