summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-20 10:35:39 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-20 10:35:39 +0000
commit793d2fdd08d8de2a30a57c96ce18d77719a4c32a (patch)
treed48a94609783857e55e64fb8b7fe2c5861ce8c19 /sys-process
parentVersion bump; tool installation is now optional. (diff)
downloadgentoo-2-793d2fdd08d8de2a30a57c96ce18d77719a4c32a.tar.gz
gentoo-2-793d2fdd08d8de2a30a57c96ce18d77719a4c32a.tar.bz2
gentoo-2-793d2fdd08d8de2a30a57c96ce18d77719a4c32a.zip
Version bump.
(Portage version: 2.2.0_alpha102/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/procps/ChangeLog8
-rw-r--r--sys-process/procps/files/procps-3.3.3-watch-8bit.patch42
-rw-r--r--sys-process/procps/procps-3.3.3.ebuild50
3 files changed, 99 insertions, 1 deletions
diff --git a/sys-process/procps/ChangeLog b/sys-process/procps/ChangeLog
index 1912ccda0943..9d5d97f526e3 100644
--- a/sys-process/procps/ChangeLog
+++ b/sys-process/procps/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-process/procps
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/ChangeLog,v 1.64 2012/05/03 04:54:03 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/ChangeLog,v 1.65 2012/05/20 10:35:39 vapier Exp $
+
+*procps-3.3.3 (20 May 2012)
+
+ 20 May 2012; Mike Frysinger <vapier@gentoo.org>
+ +files/procps-3.3.3-watch-8bit.patch, +procps-3.3.3.ebuild:
+ Version bump.
03 May 2012; Jeff Horelick <jdhore@gentoo.org> procps-3.3.2_p2-r1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/sys-process/procps/files/procps-3.3.3-watch-8bit.patch b/sys-process/procps/files/procps-3.3.3-watch-8bit.patch
new file mode 100644
index 000000000000..e2a1169bb78a
--- /dev/null
+++ b/sys-process/procps/files/procps-3.3.3-watch-8bit.patch
@@ -0,0 +1,42 @@
+From ff3ab9d52d2d5bb9eed1cfcb54013d5483a37677 Mon Sep 17 00:00:00 2001
+From: Craig Small <csmall@enc.com.au>
+Date: Sun, 20 May 2012 17:08:29 +1000
+Subject: [PATCH] watch compiles with 8bit enabled
+
+watch wouldn't compile with --enable-watch8bit as some variables were
+missing. This changes fixes it.
+---
+ watch.c | 8 ++++++++
+ 1 files changed, 8 insertions(+), 0 deletions(-)
+
+diff --git a/watch.c b/watch.c
+index 4465268..4649844 100644
+--- a/watch.c
++++ b/watch.c
+@@ -296,7 +296,11 @@ wint_t my_getwc(FILE * s)
+ }
+ #endif /* WITH_WATCH8BIT */
+
++#ifdef WITH_WATCH8BIT
++void output_header(wchar_t *restrict wcommand, int wcommand_columns, int wcommand_characters, double interval)
++#else
+ void output_header(char *restrict command, double interval)
++#endif /* WITH_WATCH8BIT */
+ {
+ time_t t = time(NULL);
+ char *ts = ctime(&t);
+@@ -718,7 +722,11 @@ int main(int argc, char *argv[])
+ }
+
+ if (show_title)
++#ifdef WITH_WATCH8BIT
++ output_header(wcommand, wcommand_columns, wcommand_characters, interval);
++#else
+ output_header(command, interval);
++#endif /* WITH_WATCH8BIT */
+
+ if (run_command(command, command_argv))
+ break;
+--
+1.7.8.6
+
diff --git a/sys-process/procps/procps-3.3.3.ebuild b/sys-process/procps/procps-3.3.3.ebuild
new file mode 100644
index 000000000000..029f13cd4112
--- /dev/null
+++ b/sys-process/procps/procps-3.3.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/procps/procps-3.3.3.ebuild,v 1.1 2012/05/20 10:35:39 vapier Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs autotools
+
+DEB_VER=${PV#*_p}
+MY_PV=${PV%_p*}
+DESCRIPTION="standard informational utilities and process-handling tools"
+HOMEPAGE="http://procps.sourceforge.net/ http://gitorious.org/procps http://packages.debian.org/sid/procps"
+SRC_URI="http://gitorious.org/procps/procps/archive-tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="+ncurses static-libs unicode"
+
+RDEPEND="ncurses? ( >=sys-libs/ncurses-5.2-r2[unicode?] )"
+DEPEND="${RDEPEND}
+ ncurses? ( virtual/pkgconfig )"
+
+S=${WORKDIR}/${PN}-${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-watch-8bit.patch
+
+ po/update-potfiles || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --exec-prefix="${EPREFIX}/" \
+ --docdir='$(datarootdir)'/doc/${PF} \
+ $(use_with ncurses) \
+ $(use_enable static-libs static) \
+ $(use_enable unicode watch8bit)
+}
+
+src_install() {
+ default
+ dodoc sysctl.conf
+
+ # The configure script is completely whacked in the head
+ mv "${ED}"/lib* "${ED}"/usr/ || die
+ gen_usr_ldscript -a procps
+ find "${ED}"/usr -name '*.la' -delete
+}