summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2011-07-10 19:41:09 +0000
committerLars Wendler <polynomial-c@gentoo.org>2011-07-10 19:41:09 +0000
commitec1b5617b774f9604676823899c4b381c7e0cce6 (patch)
tree46bf689e750d1764b42c9fdce97d934602e55eb1 /sys-process
parentunused useflag (diff)
downloadgentoo-2-ec1b5617b774f9604676823899c4b381c7e0cce6.tar.gz
gentoo-2-ec1b5617b774f9604676823899c4b381c7e0cce6.tar.bz2
gentoo-2-ec1b5617b774f9604676823899c4b381c7e0cce6.zip
Fixed bug #365651, bug #374011 and added myself as maintainer
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/cronie/ChangeLog14
-rw-r--r--sys-process/cronie/cronie-1.4.4-r1.ebuild (renamed from sys-process/cronie/cronie-1.4.4.ebuild)14
-rw-r--r--sys-process/cronie/cronie-1.4.6.ebuild14
-rw-r--r--sys-process/cronie/cronie-1.4.8.ebuild56
-rw-r--r--sys-process/cronie/metadata.xml4
5 files changed, 88 insertions, 14 deletions
diff --git a/sys-process/cronie/ChangeLog b/sys-process/cronie/ChangeLog
index a309936270dc..965086817543 100644
--- a/sys-process/cronie/ChangeLog
+++ b/sys-process/cronie/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-process/cronie
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/ChangeLog,v 1.14 2010/11/08 13:21:51 bangert Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/ChangeLog,v 1.15 2011/07/10 19:41:09 polynomial-c Exp $
+
+*cronie-1.4.8 (10 Jul 2011)
+*cronie-1.4.4-r1 (10 Jul 2011)
+
+ 10 Jul 2011; Lars Wendler <polynomial-c@gentoo.org> -cronie-1.4.4.ebuild,
+ +cronie-1.4.4-r1.ebuild, cronie-1.4.6.ebuild, +cronie-1.4.8.ebuild,
+ metadata.xml:
+ Fixed "crontab -e" permission bug reported by Mike Gilbert (bug #365651) who
+ also provided a complete fix. Committed a fixed revision straight to stable.
+ Version bump (bug #374011). Added myself as new package maintainer.
*cronie-1.4.6 (08 Nov 2010)
diff --git a/sys-process/cronie/cronie-1.4.4.ebuild b/sys-process/cronie/cronie-1.4.4-r1.ebuild
index 5ca635c8725b..c287f6b8c265 100644
--- a/sys-process/cronie/cronie-1.4.4.ebuild
+++ b/sys-process/cronie/cronie-1.4.4-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/cronie-1.4.4.ebuild,v 1.2 2010/08/12 08:21:01 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/cronie-1.4.4-r1.ebuild,v 1.1 2011/07/10 19:41:09 polynomial-c Exp $
EAPI="2"
@@ -20,6 +20,10 @@ RDEPEND="${DEPEND}"
#cronie supports /etc/crontab
CRON_SYSTEM_CRONTAB="yes"
+pkg_setup() {
+ enewgroup crontab
+}
+
src_configure() {
SPOOL_DIR="/var/spool/cron/crontabs" econf \
$(use_with inotify ) \
@@ -32,9 +36,9 @@ src_configure() {
src_install() {
emake install DESTDIR="${D}" || die "install failed"
- docrondir
- fowners root:cron /usr/bin/crontab
- fperms 2750 /usr/bin/crontab
+ docrondir -m 1730 -o root -g crontab
+ fowners root:crontab /usr/bin/crontab
+ fperms 2751 /usr/bin/crontab
insinto /etc
newins "${FILESDIR}/${PN}-1.2-crontab" crontab
diff --git a/sys-process/cronie/cronie-1.4.6.ebuild b/sys-process/cronie/cronie-1.4.6.ebuild
index 2b98eed20ee5..61055db7cd86 100644
--- a/sys-process/cronie/cronie-1.4.6.ebuild
+++ b/sys-process/cronie/cronie-1.4.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/cronie-1.4.6.ebuild,v 1.1 2010/11/08 13:21:51 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/cronie-1.4.6.ebuild,v 1.2 2011/07/10 19:41:09 polynomial-c Exp $
EAPI="3"
@@ -20,6 +20,10 @@ RDEPEND="${DEPEND}"
#cronie supports /etc/crontab
CRON_SYSTEM_CRONTAB="yes"
+pkg_Setup() {
+ enewgroup crontab
+}
+
src_configure() {
SPOOL_DIR="/var/spool/cron/crontabs" econf \
$(use_with inotify ) \
@@ -32,9 +36,9 @@ src_configure() {
src_install() {
emake install DESTDIR="${D}" || die "install failed"
- docrondir
- fowners root:cron /usr/bin/crontab
- fperms 2750 /usr/bin/crontab
+ docrondir -m 1730 -o root -g crontab
+ fowners root:crontab /usr/bin/crontab
+ fperms 2751 /usr/bin/crontab
insinto /etc
newins "${FILESDIR}/${PN}-1.2-crontab" crontab
diff --git a/sys-process/cronie/cronie-1.4.8.ebuild b/sys-process/cronie/cronie-1.4.8.ebuild
new file mode 100644
index 000000000000..35d31fb3cb3f
--- /dev/null
+++ b/sys-process/cronie/cronie-1.4.8.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/cronie/cronie-1.4.8.ebuild,v 1.1 2011/07/10 19:41:09 polynomial-c Exp $
+
+EAPI="3"
+
+inherit cron eutils pam
+
+DESCRIPTION="Cronie is a standard UNIX daemon cron based on the original vixie-cron."
+SRC_URI="https://fedorahosted.org/releases/c/r/cronie/${P}.tar.gz"
+HOMEPAGE="https://fedorahosted.org/cronie/wiki"
+
+LICENSE="ISC BSD BSD-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="inotify pam"
+
+DEPEND="pam? ( virtual/pam )"
+RDEPEND="${DEPEND}"
+
+#cronie supports /etc/crontab
+CRON_SYSTEM_CRONTAB="yes"
+
+pkg_setup() {
+ enewgroup crontab
+}
+
+src_configure() {
+ SPOOL_DIR="/var/spool/cron/crontabs" econf \
+ $(use_with inotify ) \
+ $(use_with pam ) \
+ --with-daemon_username=cron \
+ --with-daemon_groupname=cron \
+ || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+
+ docrondir -m 1730 -o root -g crontab
+ fowners root:crontab /usr/bin/crontab
+ fperms 2751 /usr/bin/crontab
+
+ insinto /etc
+ newins "${FILESDIR}/${PN}-1.2-crontab" crontab
+ newins "${FILESDIR}/${PN}-1.2-cron.deny" cron.deny
+
+ keepdir /etc/cron.d
+ newinitd "${FILESDIR}/${PN}-1.2-initd" cronie
+ newpamd "${FILESDIR}/${PN}-1.4.3-pamd" crond
+
+ dodoc NEWS AUTHORS README
+}
+
+pkg_postinst() {
+ cron_pkg_postinst
+}
diff --git a/sys-process/cronie/metadata.xml b/sys-process/cronie/metadata.xml
index 10169d7ce5a1..4cf857201623 100644
--- a/sys-process/cronie/metadata.xml
+++ b/sys-process/cronie/metadata.xml
@@ -3,8 +3,8 @@
<pkgmetadata>
<herd>cron</herd>
<maintainer>
- <email>bangert@gentoo.org</email>
- <name>Thilo Bangert</name>
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
</maintainer>
<longdescription lang="en">
Cronie contains the standard UNIX daemon crond that runs specified programs at