summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-03-30 21:00:59 +0000
committerMichał Górny <mgorny@gentoo.org>2014-03-30 21:00:59 +0000
commit61de0f5afe14241ce73e65579772ae3735fc516c (patch)
tree494c5e9605678c7ec5b934b673798b70500a5854 /virtual
parentVersion bump cffi to 0.8.2. (diff)
downloadgentoo-2-61de0f5afe14241ce73e65579772ae3735fc516c.tar.gz
gentoo-2-61de0f5afe14241ce73e65579772ae3735fc516c.tar.bz2
gentoo-2-61de0f5afe14241ce73e65579772ae3735fc516c.zip
Backport the :0 slot switch to pypy-2.0.2 since we have binpackages for this version.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'virtual')
-rw-r--r--virtual/pypy/ChangeLog9
-rw-r--r--virtual/pypy/pypy-2.0.2-r1.ebuild22
-rw-r--r--virtual/pypy/pypy-2.2.1.ebuild6
3 files changed, 33 insertions, 4 deletions
diff --git a/virtual/pypy/ChangeLog b/virtual/pypy/ChangeLog
index 143a46f02b6a..c034908a7bc5 100644
--- a/virtual/pypy/ChangeLog
+++ b/virtual/pypy/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for virtual/pypy
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/pypy/ChangeLog,v 1.6 2014/03/12 09:27:43 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/pypy/ChangeLog,v 1.7 2014/03/30 21:00:59 mgorny Exp $
+
+*pypy-2.0.2-r1 (30 Mar 2014)
+
+ 30 Mar 2014; Michał Górny <mgorny@gentoo.org> +pypy-2.0.2-r1.ebuild,
+ pypy-2.2.1.ebuild:
+ Backport the :0 slot switch to pypy-2.0.2 since we have binpackages for this
+ version.
12 Mar 2014; Michał Górny <mgorny@gentoo.org> pypy-2.2.1.ebuild:
Add the subslot.
diff --git a/virtual/pypy/pypy-2.0.2-r1.ebuild b/virtual/pypy/pypy-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..884e12c1e78e
--- /dev/null
+++ b/virtual/pypy/pypy-2.0.2-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/virtual/pypy/pypy-2.0.2-r1.ebuild,v 1.1 2014/03/30 21:00:59 mgorny Exp $
+
+EAPI=5
+
+inherit versionator
+
+DESCRIPTION="A virtual for PyPy Python implementation"
+HOMEPAGE=""
+SRC_URI=""
+
+LICENSE=""
+SLOT="0/$(get_version_component_range 1-2 ${PV})"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="bzip2 ncurses sqlite"
+
+RDEPEND="
+ || (
+ >=dev-python/pypy-${PV}:${SLOT}[bzip2?,ncurses?,sqlite?,ssl(+)]
+ >=dev-python/pypy-bin-${PV}:${SLOT}[sqlite?]
+ )"
diff --git a/virtual/pypy/pypy-2.2.1.ebuild b/virtual/pypy/pypy-2.2.1.ebuild
index bff628fd1f20..aa40a142ce2f 100644
--- a/virtual/pypy/pypy-2.2.1.ebuild
+++ b/virtual/pypy/pypy-2.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/virtual/pypy/pypy-2.2.1.ebuild,v 1.2 2014/03/12 09:27:43 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/virtual/pypy/pypy-2.2.1.ebuild,v 1.3 2014/03/30 21:00:58 mgorny Exp $
EAPI=5
@@ -17,6 +17,6 @@ IUSE="bzip2 ncurses sqlite"
RDEPEND="
|| (
- >=dev-python/pypy-2.2.1:${SLOT}[bzip2?,ncurses?,sqlite?,ssl(+)]
- >=dev-python/pypy-bin-2.2.1:${SLOT}[sqlite?]
+ >=dev-python/pypy-${PV}:${SLOT}[bzip2?,ncurses?,sqlite?,ssl(+)]
+ >=dev-python/pypy-bin-${PV}:${SLOT}[sqlite?]
)"