summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2005-01-10 13:03:00 +0000
committerBenedikt Boehm <hollow@gentoo.org>2005-01-10 13:03:00 +0000
commit560f8b4e675c8e84abe274ca081588be387342b1 (patch)
treebe887023bda824cf508d510267ad57a542da470a /www-apache/mod_umask
parentApache herd package refresh (New ebuild)" (Manifest recommit) (diff)
downloadgentoo-2-560f8b4e675c8e84abe274ca081588be387342b1.tar.gz
gentoo-2-560f8b4e675c8e84abe274ca081588be387342b1.tar.bz2
gentoo-2-560f8b4e675c8e84abe274ca081588be387342b1.zip
Apache herd package refresh (New ebuild)"
Diffstat (limited to 'www-apache/mod_umask')
-rw-r--r--www-apache/mod_umask/ChangeLog10
-rw-r--r--www-apache/mod_umask/Manifest5
-rw-r--r--www-apache/mod_umask/files/47_mod_umask.conf21
-rw-r--r--www-apache/mod_umask/files/digest-mod_umask-0.1.01
-rw-r--r--www-apache/mod_umask/metadata.xml8
-rw-r--r--www-apache/mod_umask/mod_umask-0.1.0.ebuild21
6 files changed, 66 insertions, 0 deletions
diff --git a/www-apache/mod_umask/ChangeLog b/www-apache/mod_umask/ChangeLog
new file mode 100644
index 000000000000..407956c81028
--- /dev/null
+++ b/www-apache/mod_umask/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for www-apache/mod_umask
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_umask/ChangeLog,v 1.1 2005/01/10 13:03:00 hollow Exp $
+
+*mod_umask-0.1.0 (10 Jan 2005)
+
+ 10 Jan 2005; Benedikt Boehm <hollow@gentoo.org> +metadata.xml,
+ +files/47_mod_umask.conf, +mod_umask-0.1.0.ebuild:
+ Apache herd package refresh (New ebuild)
+
diff --git a/www-apache/mod_umask/Manifest b/www-apache/mod_umask/Manifest
new file mode 100644
index 000000000000..f1ab7a9eed12
--- /dev/null
+++ b/www-apache/mod_umask/Manifest
@@ -0,0 +1,5 @@
+MD5 0d18f0fe5d603b41b988373892caf195 metadata.xml 226
+MD5 17015b5ed13d794b1d070743c8406fcc mod_umask-0.1.0.ebuild 490
+MD5 96af566c1658c0b2bb72176b85893130 ChangeLog 315
+MD5 8aa5c69f0d6dcc9b50d9ba1f0b95795c files/47_mod_umask.conf 547
+MD5 1afc502bb26ea30f986372386213eecc files/digest-mod_umask-0.1.0 68
diff --git a/www-apache/mod_umask/files/47_mod_umask.conf b/www-apache/mod_umask/files/47_mod_umask.conf
new file mode 100644
index 000000000000..6a6bbaae6363
--- /dev/null
+++ b/www-apache/mod_umask/files/47_mod_umask.conf
@@ -0,0 +1,21 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_umask/files/47_mod_umask.conf,v 1.1 2005/01/10 13:03:00 hollow Exp $
+
+# PLEASE NOTE: consider this as an example configuration;
+# So, a more useful place would be, to use UMask directive
+# inside a subversion module driven virtual host, e.g.
+
+<IfDefine UMASK>
+ <IfModule !mod_umask.c>
+ LoadModule umask_module modules/mod_umask.so
+ </IfModule>
+
+ # This is default:
+ # UMask 022
+
+ # This is usefull for group-write-access, such as used in subversion
+ # UMask 002
+</IfDefine>
+
+# vim:syntax=apache
diff --git a/www-apache/mod_umask/files/digest-mod_umask-0.1.0 b/www-apache/mod_umask/files/digest-mod_umask-0.1.0
new file mode 100644
index 000000000000..dd2e5c294e2b
--- /dev/null
+++ b/www-apache/mod_umask/files/digest-mod_umask-0.1.0
@@ -0,0 +1 @@
+MD5 fb33093c7db879ddd6ec710521c1ec05 mod_umask-0.1.0.tar.bz2 182078
diff --git a/www-apache/mod_umask/metadata.xml b/www-apache/mod_umask/metadata.xml
new file mode 100644
index 000000000000..10510cb8be95
--- /dev/null
+++ b/www-apache/mod_umask/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>apache</herd>
+<maintainer>
+ <email>apache-devs@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/www-apache/mod_umask/mod_umask-0.1.0.ebuild b/www-apache/mod_umask/mod_umask-0.1.0.ebuild
new file mode 100644
index 000000000000..16022b12b4f8
--- /dev/null
+++ b/www-apache/mod_umask/mod_umask-0.1.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_umask/mod_umask-0.1.0.ebuild,v 1.1 2005/01/10 13:03:00 hollow Exp $
+
+inherit apache-module
+
+DESCRIPTION="Sets the Unix umask of the Apache HTTPd process after it has started."
+SRC_URI="http://www.apache.org/~pquerna/modules/${P}.tar.bz2"
+HOMEPAGE="http://www.outoforder.cc/projects/apache/mod_umask/"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~x86"
+IUSE=""
+
+APACHE2_MOD_CONF="47_${PN}"
+APACHE2_MOD_DEFINE="UMASK"
+
+need_apache2
+
+# vim:ts=4