summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2005-01-10 11:26:38 +0000
committerBenedikt Boehm <hollow@gentoo.org>2005-01-10 11:26:38 +0000
commit0d6219d875261c480813117dc7edf1ec8562ad06 (patch)
tree68aaca7722fd367e0f06e0c0c84fb9077a13e78d /www-apache
parentMoved src_install, pkg_preinst, and pkg_postinst into eclass using gcc-3.3.5-... (diff)
downloadgentoo-2-0d6219d875261c480813117dc7edf1ec8562ad06.tar.gz
gentoo-2-0d6219d875261c480813117dc7edf1ec8562ad06.tar.bz2
gentoo-2-0d6219d875261c480813117dc7edf1ec8562ad06.zip
Apache herd package refresh. Initial revision
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_proxy_html/ChangeLog10
-rw-r--r--www-apache/mod_proxy_html/Manifest4
-rw-r--r--www-apache/mod_proxy_html/files/27_mod_proxy_html.conf12
-rw-r--r--www-apache/mod_proxy_html/files/digest-mod_proxy_html-2.4.31
-rw-r--r--www-apache/mod_proxy_html/metadata.xml9
-rw-r--r--www-apache/mod_proxy_html/mod_proxy_html-2.4.3.ebuild29
6 files changed, 65 insertions, 0 deletions
diff --git a/www-apache/mod_proxy_html/ChangeLog b/www-apache/mod_proxy_html/ChangeLog
new file mode 100644
index 000000000000..8035c6339cc7
--- /dev/null
+++ b/www-apache/mod_proxy_html/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for www-apache/mod_proxy_html
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_proxy_html/ChangeLog,v 1.1 2005/01/10 11:26:38 hollow Exp $
+
+*mod_proxy_html-2.4.3 (10 Jan 2005)
+
+ 10 Jan 2005; Benedikt Boehm <hollow@gentoo.org>
+ +files/27_mod_proxy_html.conf, +mod_proxy_html-2.4.3.ebuild:
+ Apache herd package refresh. Initial revision
+
diff --git a/www-apache/mod_proxy_html/Manifest b/www-apache/mod_proxy_html/Manifest
new file mode 100644
index 000000000000..8e6548a77373
--- /dev/null
+++ b/www-apache/mod_proxy_html/Manifest
@@ -0,0 +1,4 @@
+MD5 d158ccfb5c29d7625bc9136650aef819 mod_proxy_html-2.4.3.ebuild 721
+MD5 273ab47742d80950887d0593d0bdf085 ChangeLog 325
+MD5 ac1a5d80b1934eca00c21a4130a6e080 files/27_mod_proxy_html.conf 244
+MD5 13b126a10cbce1cfad294254b0ed4a34 files/digest-mod_proxy_html-2.4.3 60
diff --git a/www-apache/mod_proxy_html/files/27_mod_proxy_html.conf b/www-apache/mod_proxy_html/files/27_mod_proxy_html.conf
new file mode 100644
index 000000000000..0e00f4412175
--- /dev/null
+++ b/www-apache/mod_proxy_html/files/27_mod_proxy_html.conf
@@ -0,0 +1,12 @@
+<IfDefine PROXYHTML>
+ <IfModule !mod_proxy_html.c>
+ LoadModule proxy_html_module modules/mod_proxy_html.so
+ </IfModule>
+</IfDefine>
+
+<IfModule mod_proxy_html.c>
+
+# See http://apache.webthing.com/mod_proxy_html/ for now :/
+
+</IfModule>
+
diff --git a/www-apache/mod_proxy_html/files/digest-mod_proxy_html-2.4.3 b/www-apache/mod_proxy_html/files/digest-mod_proxy_html-2.4.3
new file mode 100644
index 000000000000..e1729ef1a3f0
--- /dev/null
+++ b/www-apache/mod_proxy_html/files/digest-mod_proxy_html-2.4.3
@@ -0,0 +1 @@
+MD5 e391f303572b3deb9a3c603ce99894d0 mod_proxy_html.c 31180
diff --git a/www-apache/mod_proxy_html/metadata.xml b/www-apache/mod_proxy_html/metadata.xml
new file mode 100644
index 000000000000..22bb50eb3661
--- /dev/null
+++ b/www-apache/mod_proxy_html/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>apache</herd>
+ <maintainer>
+ <email>hollow@gentoo.org</email>
+ <name>Benedikt Boehm</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/www-apache/mod_proxy_html/mod_proxy_html-2.4.3.ebuild b/www-apache/mod_proxy_html/mod_proxy_html-2.4.3.ebuild
new file mode 100644
index 000000000000..c707c320ee4e
--- /dev/null
+++ b/www-apache/mod_proxy_html/mod_proxy_html-2.4.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apache/mod_proxy_html/mod_proxy_html-2.4.3.ebuild,v 1.1 2005/01/10 11:26:38 hollow Exp $
+
+inherit eutils apache-module
+
+DESCRIPTION="An Apache2 DSO to rewrite links in html pages behind a reverse proxy"
+HOMEPAGE="http://apache.webthing.com/mod_proxy_html/"
+SRC_URI="http://apache.webthing.com/${PN}/${PN}.c"
+
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-libs/libxml2"
+
+APXS2_S="${WORKDIR}"
+APXS2_ARGS="`xml2-config --cflags` -c ${PN}.c"
+
+APACHE2_MOD_CONF="27_${PN}"
+APACHE2_MOD_DEFINE="PROXY_HTML"
+
+need_apache2
+
+src_unpack() {
+ cd ${APXS2_S}
+ cp ${DISTDIR}/${PN}.c . || die
+}